Notification of new messages no matter what RRS feed

  • Question


    It seems that in Windows Mobile 6 if I am reading a message and then hit the power button and put the phone in it's holster, I will not get a sound or vibrate notification if new messages arrive. So there are many times that I assume I don't have new mail when I actually do. On the various blackberry devices I have had, I would always get notified, no matter what I was doing on the device. Am I missing something?
    Thursday, January 10, 2008 1:47 PM


All replies


    Hi Ryan

    What is your device and holster make and model? I've never heard of a holster for WM devices that vibrates (along with the phone itself). This may be hardware and business model related. BlackBerry makes their own devices, and thus can standardize holster requirements. Windows Mobile devices are made by dozens of OEMs, and making vibrating holsters for all of them is probably not practical.


    Mel Sampat
    Program Manager, Microsoft
    This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, January 14, 2008 1:18 AM

    I could be wrong but I think he's simply stating that when he has the phone in suspend on his side, he's not getting notifications.


    Go to Start/Settings/(Personal)/Sound & Notifications

    In Notification Tab, select the Event and make sure it's configured as desired (Play Sound, Vibrate ect.)


    BTW, It's really annoying how Windows Mobile handles events on missed calls, emails ect. I walk away from my desk to attend a meeting come back and I have 4 missed calls, 6 emails, an sms, upcoming calander event ect... Why do I need to start dismissing everything. I'd much rather just have a little Today screen plug-in that shows missed calls, emails ect. like this


    [#] Email [#] Missed Calls [#] SMS [#] MMS


    That way I can clearly see it just by looking at my device I don't have waste time dismissing all the events. If you're going to take the Outlook approach, make it like Outlook, you don't see Outlook forcing you to read or dismiss every incoming email. At the very least there should be an option to disable it. It's really irritating, especially when I'm busy and I hear the phone ring or a new email come in. I know they're there, I don't need multiple avenues of notifications to tell me that!


    On another note, it's nice to see Program Managers reading these threads, I hope whoever is PM'ing Voice Command is also reading all the comments on Voice Command support with Mono Bluetooth headsets in WM6 and something is benig done about it Smile

    Saturday, January 26, 2008 4:32 PM
  • I guess a better way to sum up my problem is that if outlook is open i do not get a notification of new email. If Outlook is left open and the screen turned off, still no notification. This is the opposite of Outlook on the desktop where Outlook has to be open to be notified of new mail.


    Tuesday, January 29, 2008 8:34 PM
  • I'm experiencing the same problem.  If the device is in standby and running from battery then scheduled email checking does not occur or notification isn't raised.  When the device is brought out of standby pocket outlook is always at the "connecting" phase irresepctive of how long it has been in standby, so it looks like it starts but then something about being in standby prevents it from proceeding.


    However if the device is powered from mains (not sure for USB) and in standby then scheduled checking and notifications function as expected.  This is very frustrating as the whole point of having it check email automatically is so you get notified when you're out and about, not when it is sat charging.


    My search across the internet has found lots of complaints about this issue, but not many solutions.  I resorted to a hard reset but the problem is still the same.



    Friday, February 1, 2008 12:36 AM
  • Along with this annoyance is the problem that notifications only seem to happen in a new message is delivered to the inbox.  I have rules setup in Exchange that route mail do different folders.  I have specific folders setup to sync on my WM6 AT&T Tilt.  However, I only get notifications on the device if a rule does not move the message from the inbox to a sub folder.  It would get grate if notifications of new email occurred regardless of what folder the message ends up in.

    Wednesday, February 13, 2008 6:37 PM
  • My windows mobile 6 device (TyTn 2) will not collect my mail while the screen is off / phone is in standby, no matter what I set the automatic collection interval to. I know that I have my mail settings right becuase it works when I hit send and recieve or when I power up the device and wait a while, plus I have used a WM5 device for years without trouble. This is highly frustrating since getting notification of my emails near enough as they arrive is the primary reason I bought this phone and subscribe to a flat rate data plan. Is this a recognised bug? For further information I am connecting to Yahoo.co.uk via pop3 and smtp.
    Monday, February 18, 2008 6:56 PM
  • What settings do you have for your email for getting it delivered?


    Tuesday, February 19, 2008 6:26 AM
  • The settings are the default for Yahoo.co.uk


    My regular password

    Incoming: pop.mail.yahoo.co.uk
    account type: pop3
    Save Password: yes
    outgoing mail: smtp.mail.yahoo.co.uk:587
    Outgoing mail requires authentication: yes
    Use the same user name and password for sending mail: yes
    Require SSL for incoming mail: no
    Require SSL for outgoing mail: no
    Network Connection: T-Mobile internet
    Automatic Send/Recieve: Every 15 minutes
    DownloadMessages: From the past 3 days
    Send/Recieve when I click Send: yes
    Use automatic send/recieve schedual when roaming: no
    When Deleting messages: Delete them off the server
    Message format: html
    Message download limit: 2 KB

    Im on T-mobile with the flat rate dataplan in a well covered area (London) using a Vario 3 (TyTn 2) etc.

    As I say I had a Vario 1 which collected my mail in the background fine for years, and this one works when the screen is on. When I turn it on I sometimes catch it in various phases of send and recieve, connecting, looking for changes etc, but they never bring back any mail unless the cycle started while the device was "on". My colleague has the same phone on the same network and finds the same trouble if he tried to use yahoo, but like I say ive been collecting mail for years using a wm5 device.

    I'd be interested to hear any suggestions as this is quite a frustration. Ive tried restarting the mail process, restarting the device, and deleting the email settings and re-setting them up all to no avail.
    Tuesday, February 19, 2008 8:49 AM
  • I've found a solution.

    There is a free tool available called Kaiser tweak which gives access to what I presume are a bunch of registry settings. Among the options it provides are ones which set how much time schedualled tasks have to start while on battery and ac power. The description of the setting points out it is reported to fix some problems with email retrieval. It is set by default to 1 second, but the tool reccommends 60s. Having changed to 60s my email now works.

    Take note MS, I think this could fairly be described as a bug, and its surely an easy one to fix since you just need to change the factory setting.
    Thursday, March 13, 2008 9:27 PM
  • Thanks dor that update Julian.  I hope it continues to do what you need.  I looked for the link and found a couple but I'm assuming this is the link you probably used:


    Friday, March 14, 2008 4:27 AM