locked
Can't access files on WHS 2011 from Windows 8 RRS feed

  • Question

  • I have setup Windows Home Server 2011 in a box and hooked it up to my home network.  On my network I have two other computers, a home theater PC (running Vista Ultimate) and my desktop (running Windows 8 Pro).  I have shared folders from the HTPC so I can copy files to it from my desktop, this works fine.  I want to be able to map drives on both the HTPC and the desktop to point to the server and I also want access to some folders (not mapped) on the server from my desktop.

    Currently, on the server I have made an account (specified the username and password) and I have given that account read/write access to each Server Folder.  I have added all three computers to a Homegroup.  I have manually adjusted each folder's sharing from the server (via RDC) to give FAMILY-DESKTOP$ full access as well (the desktop is named FAMILY-DESKTOP).  Despite all this, when I click on the server under Network (not the streaming media folders, the portion that should let me access the shared drives of the server through Explorer) I get a note.

    "Network Error"
    "Windows cannot access \\WSHOMEMEDIA

    You do not have permission to access \\WSHOMEMEDIA. Contact your network administrator to request access."

    I don't know what else to do.  I don't know how to add my Windows 8, Microsoft linked account, to the share list explicitly (and really would rather not, I don't want to have to set permissions for each account at home, they should all just work).  Any tips on where to go from here?

    Saturday, October 26, 2013 6:54 PM

Answers

  • Windows Home Server 2011 does not know about the use of Microsoft Account credentials, which is a new feature on Windows 8 and newer devices. 

    One way to address this, as mentioned, is to open up the Credentials Manager on your Windows 8 PC and add an entry for your server.  However, if you ever run the WHS Launchpad tray app on your client, these credentials will be overwritten after your session is closed or the PC is restarted.

    The more reliable approach is to simply set the WHS Launchpad to run at startup and to have it log in automatically to WHS.  When it runs (and logs into the server) in it sets up the proper network credentials so that you can access shares and media on the server.  You can have it run minimized to the task tray now, if you prefer.

    A "best practices" approach to user accounts is to give each member of your family an account on the server, and to set explicit permissions for each account.  You should also give each of them a user account on each client PC, and have them log into the account before using the computer, and set up the Launchpad to log it automatically using their proper server credentials as described above.  For Windows 8/8.1 PCs, it's fine for them to use their Microsoft account credentials (a big improvement), as long as you set up the Launchpad to log in with their server credentials.  

    If you have multiple members of your family sharing a common user account, well, you should expect some issues.



    • Edited by Gary Voth Sunday, October 27, 2013 2:40 PM
    • Marked as answer by Ken Warren Monday, October 28, 2013 12:17 AM
    Sunday, October 27, 2013 2:32 PM

All replies

  • You need to go to the Control panel-Credentials Manager on Windows 8 and set the username and password you set up on the server.
    • Proposed as answer by doug2h Saturday, October 26, 2013 11:52 PM
    Saturday, October 26, 2013 11:52 PM
  • Windows Home Server 2011 does not know about the use of Microsoft Account credentials, which is a new feature on Windows 8 and newer devices. 

    One way to address this, as mentioned, is to open up the Credentials Manager on your Windows 8 PC and add an entry for your server.  However, if you ever run the WHS Launchpad tray app on your client, these credentials will be overwritten after your session is closed or the PC is restarted.

    The more reliable approach is to simply set the WHS Launchpad to run at startup and to have it log in automatically to WHS.  When it runs (and logs into the server) in it sets up the proper network credentials so that you can access shares and media on the server.  You can have it run minimized to the task tray now, if you prefer.

    A "best practices" approach to user accounts is to give each member of your family an account on the server, and to set explicit permissions for each account.  You should also give each of them a user account on each client PC, and have them log into the account before using the computer, and set up the Launchpad to log it automatically using their proper server credentials as described above.  For Windows 8/8.1 PCs, it's fine for them to use their Microsoft account credentials (a big improvement), as long as you set up the Launchpad to log in with their server credentials.  

    If you have multiple members of your family sharing a common user account, well, you should expect some issues.



    • Edited by Gary Voth Sunday, October 27, 2013 2:40 PM
    • Marked as answer by Ken Warren Monday, October 28, 2013 12:17 AM
    Sunday, October 27, 2013 2:32 PM
  • Hi Gary,

    I've got the same problem but I can't get the launchpad to automatically login even with the box ticked!

    I have a server running WSE 2012.
    I have a HTPC running Windows 8.1 Standard with a local account (setup in WSE) called MediaCentre. This works fine as I don't need a MS Account on it and the LaunchPad logs in automatically anyway.

    However, my laptop is running Windows 8.1 Standard with a Microsoft Account as I need Skydrive etc. Before the upgrade to 8.1 (from 8) the laptop was using a local user and connecting to WSE fine. Since the upgrade and changing to an MS account I have to manually log into the LaunchPad as it refuses to remember the password even with "remember me" ticked.

    I've un-installed and re-installed the connector and I've also tried adding my WSE user to Windows Credentials (set as Enterprise level) and it still forgets it on reboot.

    Any ideas? This is driving me insane!

    Thanks

    Tuesday, November 12, 2013 12:21 PM
  • Hi Gary,

    I've got the same problem but I can't get the launchpad to automatically login even with the box ticked!

    I have a server running WSE 2012.
    I have a HTPC running Windows 8.1 Standard with a local account (setup in WSE) called MediaCentre. This works fine as I don't need a MS Account on it and the LaunchPad logs in automatically anyway.

    However, my laptop is running Windows 8.1 Standard with a Microsoft Account as I need Skydrive etc. Before the upgrade to 8.1 (from 8) the laptop was using a local user and connecting to WSE fine. Since the upgrade and changing to an MS account I have to manually log into the LaunchPad as it refuses to remember the password even with "remember me" ticked.

    I've un-installed and re-installed the connector and I've also tried adding my WSE user to Windows Credentials (set as Enterprise level) and it still forgets it on reboot.

    Any ideas? This is driving me insane!

    Thanks

    Hi Vic, sorry to hear of your issue.

    I've not experience this in my own network--we have been using mostly Windows 8 and now Windows 8.1 clients for over a year with WHS 2011 without incident (once we figured out the credentials work-around). We are using the Pro version of Windows client, however. 

    Also, when I upgrade my Windows 8 clients to Windows 8.1, I decided I would treat the 8.1 machines as new PCs. So I first uninstalled the Connector from all clients (and rebooted), then removed the PCs from the server (archiving the backups).  After the 8.1 upgrade, I added the 8.1 machines back to the server as new PCs. (Because of the way WHS handles PC backups by storing only one copy of duplicate data, deleting and re-adding the PCs does not increase the client backup database size even when you've archived the older machines.)  This all worked fine. But this means I don't have experience with an 8.1 upgrade with the Connector installed. This could be the source of the problem perhaps.

    If an uninstall/reinstall of the Connector does not fix the issue, then my first thought is that something on your laptop is bugged up.  Have you considered doing a PC Refresh?  (Charms->Settings->Change PC Settings->Update and recovery-->Recovery).  This basically wipes your Win32 (desktop) environment while preserving your user accounts, data and Windows Store apps. You will just need to reinstall any desktop apps. (It works like a charm.)

    Short of this, you might try creating a new user account on the laptop and see if the problem migrates. If everything works fine in the other user account, then you could delete and recreate your primary account (backup up your data of course) to see if that fixes the issue.

    Also, if you are technically inclined, you might check the event logs on Windows to see if there is anything specific to Windows Server that is failing. What you find may or may not be actionable.




    • Edited by Gary Voth Tuesday, November 12, 2013 1:56 PM
    Tuesday, November 12, 2013 1:48 PM
  • Thanks, I'll have another play around tonight.

    My gut feeling is that this is either something to do with using the Standard version of Windows (not having group policy and things like that). I may revert back to a local account and ensure the connector auto logs in and then switch over to the MS Account again. I want to try and avoid doing a refresh as I'd have to re-install Visual Studio etc.  :)

    Tuesday, November 12, 2013 2:48 PM