locked
Some Times Getting Fault Exception while trying to create record in CRM RRS feed

  • Question

  • Hi All,

                I am getting this peculear error

    Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: System.ServiceModel.EndpointNotFoundException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #B4762225Detail: 
    <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
      <ErrorCode>-2147204345</ErrorCode>
      <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
      <Message>System.ServiceModel.EndpointNotFoundException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #B4762225</Message>
      <Timestamp>2014-11-18T04:18:59.7493905Z</Timestamp>
      <InnerFault i:nil="true" />
      <TraceText>
    
    [Xbitz.Crm.AdvancedCRMAutoNumber: Xbitz.Crm.AdvancedCRMAutoNumber.GenerateAutoNumber]
    [14eb4ee7-c99d-e111-b463-1cc1de6e2b2d: Xbitz.Crm.AdvancedCRMAutoNumber.GenerateAutoNumber: Create of  any Entity]
    
    
    </TraceText>
    </OrganizationServiceFault>
    
     

    When trying to create a new entity or delete an entity from the CRM web client. This error seems to popup only once in a while. There is no particular pattern to it. And only solution seems to be to recycle the apppool of CRM. Can someone give me some idea about why the error may be coming?

    The details of the environment is as follows

    CRM 2011 on premises with update rollup 13.

    Also has ADFS configured to be connected from internet

    Total number of users on peak load is about 200.

    Regards

    Tiklu

    Tuesday, November 18, 2014 11:02 AM

Answers

  • Hi,

    Did you check below?

    CRM Sandbox service is not running
    CRM Sandbox ports are unavailable on the sandbox server
    CRM Sandbox service is missing SPN's
    CRM Sandbox is remote and the CRM Services cannot be reached

    Try below links for the same.

    http://sqldbatips.wordpress.com/2014/02/26/the-plug-in-execution-failed-because-no-sandbox-hosts-are-currently-available/ 

    http://blogs.msdn.com/b/crminthefield/archive/2013/01/29/the-plug-in-execution-failed-because-no-sandbox-hosts-are-currently-available.aspx

    Thanks!

    Kalim Khan

    • Proposed as answer by Kalim Khan Wednesday, November 26, 2014 4:54 AM
    • Marked as answer by Tiklu Ganguly Wednesday, January 25, 2017 11:55 AM
    Tuesday, November 25, 2014 9:39 AM

All replies

  • Hi All,

                 I am still waiting for a reply. Do you need any more info that I am missing?

    Regards

    Tiklu

    Tuesday, November 25, 2014 6:28 AM
  • Have you registered your plugin in sandbox mode?

    Thanks!

    Kalim Khan

    Tuesday, November 25, 2014 8:22 AM
  • Hi Kalim,

                 The autonumber plugin is registered in sandbox mode.

    Regards

    Tiklu 

    Tuesday, November 25, 2014 9:24 AM
  • Hi,

    Did you check below?

    CRM Sandbox service is not running
    CRM Sandbox ports are unavailable on the sandbox server
    CRM Sandbox service is missing SPN's
    CRM Sandbox is remote and the CRM Services cannot be reached

    Try below links for the same.

    http://sqldbatips.wordpress.com/2014/02/26/the-plug-in-execution-failed-because-no-sandbox-hosts-are-currently-available/ 

    http://blogs.msdn.com/b/crminthefield/archive/2013/01/29/the-plug-in-execution-failed-because-no-sandbox-hosts-are-currently-available.aspx

    Thanks!

    Kalim Khan

    • Proposed as answer by Kalim Khan Wednesday, November 26, 2014 4:54 AM
    • Marked as answer by Tiklu Ganguly Wednesday, January 25, 2017 11:55 AM
    Tuesday, November 25, 2014 9:39 AM