locked
Error setting up E-mail Router with Forward Mailbox RRS feed

  • Question

  • I'm currently doing a test deployment on virtual servers (Oracle VirtualBox). So far I have the following servers:

    • Domain Controller w/ Active Directory
    • SQL Server
    • SQL Reporting Server
    • CRM Server
    • Exchange server

    Which are using the following software:

    • Windows 2008 Server R2
    • SQL Server 2008 R2
    • CRM 2011
    • Exchange 2010

    I've managed to get through everything up until this point. I installed the E-mail Router on the CRM Server machine, created a forward mailbox user in the AD and Exchange, and made a test user in CRM (and AD, Exchange) which is set to use a forward mailbox for incoming mail. Everything seemed to work in doing the Rule Deployment Wizard for this test user's mailbox as well.

    Then it came to configuring the E-mail Router. I created:

    Profile:

    • Name = CRM Forward Mailbox
    • Server type = Exchange 2010
    • Location = http://<Exchange machine name>/EWS/Exchange.asmx
    • Access Credentials = Other: credentials of forward mailbox account

    Deployment:

    • My Company
    • CRM Server: http://<CRM machine>:5555/<org name>
    • Access Credentials: Other: CRM admin account

    Forward Mailbox (after loading data):

    • Name: Forward Mailbox
    • E-mail Address: address of forward mailbox user found in Exchange
    • Incoming Configuration Profile: CRM Forward Mailbox (the one created above)
    • Delete messages: yes

    I then click on Test Access and get an error of:

    Name: Forward Mailbox
    Incoming Status: Failure - Client found response content type of '', but expected 'text/xml'.The request failed with an empty response.

    I know the Profile's Location is correct, since if I change it, it gives another error (The remote name could not be resolved). And I know the Profile's access credentials are correct, since if I change them, it also gives another error (401 - Unauthorized). Also, if I open a browser and go to the http://<machine/EWS/Exchange.asmx path, it displays the XML document as expected. I did have to turn off SSL-required and to accept client certificates on the Exchange server's EWS site to get it working this far.

    I haven't been able to find anything about receiving empty responses, so I'm hoping someone here can help get this resolved!

    Wednesday, March 23, 2011 2:12 AM

Answers

  • Did you add something new to the config file? Looks like there is conflict. So please remove the newly added settings.

    There should be an automatically generated backup config file (.bak). Could you please use that to restore the settings?
    Once you do so, repalce all occurances of ONLY httpsTransport with httpTransport.
    Save, IIS Reset.

    Also, double check that SSL was removed from the EWS site and the Main site of the Exchange Web site tree.

    Tuesday, May 31, 2011 3:29 AM

All replies

  • Wednesday, March 23, 2011 2:39 AM
  • Wednesday, March 23, 2011 2:40 AM
  • I looked through the web.config file, and there were no instances of "EWSHttpsBinding" endpoints. There are "EWSAnonymousHttpsBinding", "EWSBasicHttpsBinding", "EWSNegotiateHttpsBinding", and "EWSSecurityHttpsBinding". It already has the Http version of each of those as well, which is what this article was basically saying to add in.
    Wednesday, March 23, 2011 2:06 PM
  • Technet resource for the same.
    http://technet.microsoft.com/en-us/library/ee633481.aspx


    This is something that I didn't do, and wasn't done automatically. I went through and replaced all "httpsTransport" with "httpTransport", but the error returned is the same (empty response). It still loads the XML doc when I browse to the asmx in IE.

     

    Thanks for your suggestions so far!

    Wednesday, March 23, 2011 2:10 PM
  • I still haven't made any progress on this forward mailbox issue.
    Thursday, March 24, 2011 2:37 PM
  • I found the following error logged on the Exchange server, and the only hits I find for it all seem to end up pointing to the above blog. I've tried adding the sections that it suggests (even though it suggests one of them should already exist in the web.config), but still the empty response persists.

    This doesn't give me any useful clues... maybe it will to someone more experienced:

    Log Name:      Application
    Source:        System.ServiceModel 3.0.0.0
    Date:          3/25/2011 1:24:17 PM
    Event ID:      3
    Task Category: WebHost
    Level:         Error
    Keywords:      Classic
    User:          SYSTEM
    Computer:      VDC-EX.vdc.local

    Description:
    WebHost failed to process a request.


    Sender Information:
    System.ServiceModel.ServiceHostingEnvironment+HostingManager/30542218


    Exception:

    System.ServiceModel.ServiceActivationException: The service '/EWS/Exchange.asmx' cannot be activated due to an exception during compilation. 

    The exception message is:
    A binding instance has already been associated to listen URI 'http://vdc-ex.vdc.local/EWS/Exchange.asmx'. If two endpoints want to share the same ListenUri, they must also share the same binding object instance. The two conflicting endpoints were either specified in AddServiceEndpoint() calls, in a config file, or a combination of AddServiceEndpoint() and config.


    . --->
    System.InvalidOperationException: A binding instance has already been associated to listen URI 'http://vdc-ex.vdc.local/EWS/Exchange.asmx'. If two endpoints want to share the same ListenUri, they must also share the same binding object instance. The two conflicting endpoints were either specified in AddServiceEndpoint() calls, in a config file, or a combination of AddServiceEndpoint() and config.
       at System.ServiceModel.Description.DispatcherBuilder.InitializeServiceHost(ServiceDescription description, ServiceHostBase serviceHost)
       at System.ServiceModel.ServiceHostBase.InitializeRuntime()
       at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(String normalizedVirtualPath)
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)
       --- End of inner exception stack trace ---
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)
       at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)
     

    Process Name: w3wp
     
    Process ID: 3936

    Friday, March 25, 2011 8:00 PM
  •  

    It seems there is some problem with exchange endpoint can you try to reconfigure it using the below link. this should solve the issue.

    http://blogs.msdn.com/b/dvespa/archive/2009/12/22/how-to-configure-a-http-endpoint-for-exchange-web-services-in-exchange-2010.aspx


    - Vijay
    • Proposed as answer by vijay i Saturday, March 26, 2011 7:16 PM
    • Unproposed as answer by Mathieu Gilbert Monday, March 28, 2011 6:34 PM
    Saturday, March 26, 2011 7:16 PM
  •  

    It seems there is some problem with exchange endpoint can you try to reconfigure it using the below link. this should solve the issue.

    http://blogs.msdn.com/b/dvespa/archive/2009/12/22/how-to-configure-a-http-endpoint-for-exchange-web-services-in-exchange-2010.aspx


    - Vijay
    That's the same link that Ravindra supplied above. The 2 sections that it says to replace do not exist in my web.config file. I have tried simply adding in the "replace with this" blocks, but it had no effect (same error message).

    Monday, March 28, 2011 4:21 PM
  • Hello Mathieu,

     

    have you solved this issue yet?

    Wednesday, May 11, 2011 10:34 AM
  • No I have not. Now I'm just hoping that the problem doesn't reoccur if I have to set this up in a live environment.
    Wednesday, May 11, 2011 3:03 PM
  • Did you add something new to the config file? Looks like there is conflict. So please remove the newly added settings.

    There should be an automatically generated backup config file (.bak). Could you please use that to restore the settings?
    Once you do so, repalce all occurances of ONLY httpsTransport with httpTransport.
    Save, IIS Reset.

    Also, double check that SSL was removed from the EWS site and the Main site of the Exchange Web site tree.

    Tuesday, May 31, 2011 3:29 AM
  • If I remember correctly I have managed to resolve this by running the exchange service under an other account than the networksercvice 
    Friday, August 19, 2011 9:52 AM