locked
Cannot publish ISV Config RRS feed

  • Question

  • Hi all,  I export  the xml file for isv config and do some changes to add some new buttons.

    Then I import the file and publish this setting.

    But it fail while publish isv config in "Cusomize Entity".

    Can any one help?
    Tuesday, August 18, 2009 2:31 AM

Answers

  • Hi Brian,

    You can only publish custom or customizable entities .
    You do not need to publish system entities. The import of ISV.config should publish it automatically. You might need to press F5 after the import though.


    Hassan.


    Hassan Hussain | http://hassanhussain.wordpress.com/
    Tuesday, August 18, 2009 1:03 PM

All replies

  • Hi Brian,

    You will need to post the changes/code that you are adding to the ISV.config file. 

    If your code/xml is not strctured correctly it will cause an error during import.

    Hassan.


    Hassan Hussain | http://hassanhussain.wordpress.com/
    Tuesday, August 18, 2009 10:10 AM
  • Hi Hassan,


    Thanks for reply.

    In "Cusomize Entity", I can't publish any record with "system" type.

    The ISV is also "system" type.

    Should I publish setting in other place?

    Tuesday, August 18, 2009 10:17 AM
  • Hi Brian,

    You can only publish custom or customizable entities .
    You do not need to publish system entities. The import of ISV.config should publish it automatically. You might need to press F5 after the import though.


    Hassan.


    Hassan Hussain | http://hassanhussain.wordpress.com/
    Tuesday, August 18, 2009 1:03 PM
  • Hi Brian.. I had the same problem.. to enable the customizations made in the ISV.Config file, you have to enable the Custom menus and toolbars in the System Settings of Microsoft Dynamics, to do that follow the next steps:

    1. In the navigation pane clic Settings.
    2. Clic Administration.
    3. Clic system Settings.
    4. Select the Customizations tab.
    5. Set the clients to enable custom controls.

    I found this information in the SDK and this works for me :)


    Best Regards
    Edwin Alejandro Moreno Rivera

    Wednesday, January 13, 2010 6:20 PM