locked
Unable to initialize communication with the Passport server RRS feed

  • Question

  • I developed some pages with CRM.   It works great on my local machine.
    Once I deployed to the server. It gives me the following error.
    I did run environments.reg
    My sever doesn't have Visual Studio installed, so i can't directly compile on the server. But i did copy everything,

    Anybody could hel?  really appreciate

    Unable to initialize communication with the Passport server. (Error Code: 80048883)

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: Microsoft.Crm.Passport.Sample.PassportException: Unable to initialize communication with the Passport server. (Error Code: 80048883)

    Source Error:

    Line 190:            // Handle the MAX_RETRY exception here.
    Line 191:            // Sample will just rethrow
    Line 192:            throw ex;
    Line 193:        }
    Line 194:        return service;
    Tuesday, June 2, 2009 7:42 PM

Answers

  • I checked the code inside

    LogonManager.logo in IdCrlWrapper.dll   throw  the System.Security.Permissions.SecurityPermission

    The IdCrlWrapper.dll requires run the   crm\sdk\server\helpers\cs\idcrlwrapper\environments.reg

    I did run the register.

    But looks like the permission problem. anybody has idea what kind of permission and where i need give?

    Thanks
    • Marked as answer by Yuhe Wednesday, June 3, 2009 2:04 PM
    Tuesday, June 2, 2009 8:58 PM

All replies

  • I checked the code inside

    LogonManager.logo in IdCrlWrapper.dll   throw  the System.Security.Permissions.SecurityPermission

    The IdCrlWrapper.dll requires run the   crm\sdk\server\helpers\cs\idcrlwrapper\environments.reg

    I did run the register.

    But looks like the permission problem. anybody has idea what kind of permission and where i need give?

    Thanks
    • Marked as answer by Yuhe Wednesday, June 3, 2009 2:04 PM
    Tuesday, June 2, 2009 8:58 PM
  • Just an update for this in case somebody else has same problem.
     I resolved the problem by using local system user instead of network service user.
    Then the problem resolved
    Wednesday, June 3, 2009 2:04 PM
  • Yuhe - I'm running into a similar issue and appreciate you following up with your solution. I am struggling as to how to use a local system user. Is this a setting for "Log on as" for IIS in Services, or the anonymous access user for the virtual directory, or something under the Local Security Policy, or something else? Thanks.
    Monday, June 29, 2009 4:43 AM
  • Hi, I have the same problem and I also update the user in IIS to administrator, but the issue still exists.

    Any other ideas?


    I need more sleeping~_~
    Wednesday, August 12, 2009 2:55 AM
  • This error message is because the default app pool user does not have permission to initiate the msidcrl40.dll file which called by the IdCrlWrapper.dll

    To resolve this issue you have to follow the steps below:

    Step 1
    Make a change in the web.config file. Add the following line

     <identity impersonate="true" userName="[LOCAL ADMINISTRATOR USERNAME]" password="[ADMIN PASSWORD]" />

    You can also use a service account like mscrmsrv. In that case your web.config file entry will be as follows:

    <identity impersonate="true" userName="mscrmsrv" password="[mscrmsrv PASSWORD]" />

    If you are not sure where to add the above line then in that case you can open the IIS Manager. Right click on the website (the one which you are using for your MSCRM Custom App). Click on Properties. It will open the properties window. Click on the ASP.NET tab. Now click on the Edit Configuration button. It will open the ASP.NET Configuration Settings window. Now from this window click on the Application tab. In the application tab under Identity Settings click on Local impersonation. Now put the username and the password. Once you save it will post the entry in the web.config file.

    Step 2

    Now which ever account you are using for the local impersonation make sure that you now login to the server with the same account and then restart the IIS using IISRESET command. Once done try to run the application. It will not throw the error "Unable to initialize communication with the Passport server".

     If you reset the IIS from a different logged in user then this problem will showup once again.

    Hope this helps in resolving the issue.
     
    Tuesday, September 15, 2009 12:21 PM
  • Hi there.  I'm attempting to get the Dynamics CRM Online integration setup on a site.  I've read this thread, but I am concerned about the production-readiness of this solution.  Any chance any of you have looked deeper into this to determine a more secure and sustainable solution to this issue?

    Thanks in advance!

    Friday, April 9, 2010 5:33 PM
  • This error message is because the default app pool user does not have permission to initiate the msidcrl40.dll file which called by the IdCrlWrapper.dll

    To resolve this issue you have to follow the steps below:

    Step 1
    Make a change in the web.config file. Add the following line

     <identity impersonate="true" userName="[LOCAL ADMINISTRATOR USERNAME]" password="[ADMIN PASSWORD]" />

    You can also use a service account like mscrmsrv. In that case your web.config file entry will be as follows:

    <identity impersonate="true" userName="mscrmsrv" password="[mscrmsrv PASSWORD]" />

    If you are not sure where to add the above line then in that case you can open the IIS Manager. Right click on the website (the one which you are using for your MSCRM Custom App). Click on Properties. It will open the properties window. Click on the ASP.NET tab. Now click on the Edit Configuration button. It will open the ASP.NET Configuration Settings window. Now from this window click on the Application tab. In the application tab under Identity Settings click on Local impersonation. Now put the username and the password. Once you save it will post the entry in the web.config file.

    Step 2

    Now which ever account you are using for the local impersonation make sure that you now login to the server with the same account and then restart the IIS using IISRESET command. Once done try to run the application. It will not throw the error "Unable to initialize communication with the Passport server".

     If you reset the IIS from a different logged in user then this problem will showup once again.

    Hope this helps in resolving the issue.
     


    Although this solution works the likely reason that you are getting this error message is because your custom webpages being run under an application pool identity such network service. The application pool for the website needs to be run under a domain user account.  The reason for this is that the IDCRL wrapper class requires data to be written to the applicationdata directory. See the notes in the code or the URL below.

    http://msdn.microsoft.com/en-us/library/bb955624.aspx

    • Proposed as answer by DarrinD Friday, August 6, 2010 8:25 PM
    Friday, August 6, 2010 8:25 PM
  • Trevor,

    A much better authentication solution for integration is to use the Server-To-Server model with lightweight authentication method where user name, password, and device ID information can be used to authenticate the user instead of certificates. This is new to the 4.0.12 SDK release.

    http://msdn.microsoft.com/en-us/library/dd548515.aspx

    Another option, if you have both Dynamics GP and CRM License, is to use the Microsoft Integration SDK and customize it to integrate CRM Online to whatever other solution you have. If you are licensed in both of these products consult your Microsoft Partner to obtain the Dynamics GP to CRM integration and SDK.

     

    Darrin

    Friday, August 6, 2010 8:32 PM
  • This error message is because the default app pool user does not have permission to initiate the msidcrl40.dll file which called by the IdCrlWrapper.dll

    To resolve this issue you have to follow the steps below:

    Step 1
    Make a change in the web.config file. Add the following line

     <identity impersonate="true" userName="[LOCAL ADMINISTRATOR USERNAME]" password="[ADMIN PASSWORD]" />

    You can also use a service account like mscrmsrv. In that case your web.config file entry will be as follows:

    <identity impersonate="true" userName="mscrmsrv" password="[mscrmsrv PASSWORD]" />

    If you are not sure where to add the above line then in that case you can open the IIS Manager. Right click on the website (the one which you are using for your MSCRM Custom App). Click on Properties. It will open the properties window. Click on the ASP.NET tab. Now click on the Edit Configuration button. It will open the ASP.NET Configuration Settings window. Now from this window click on the Application tab. In the application tab under Identity Settings click on Local impersonation. Now put the username and the password. Once you save it will post the entry in the web.config file.

    Step 2

    Now which ever account you are using for the local impersonation make sure that you now login to the server with the same account and then restart the IIS using IISRESET command. Once done try to run the application. It will not throw the error "Unable to initialize communication with the Passport server".

     If you reset the IIS from a different logged in user then this problem will showup once again.

    Hope this helps in resolving the issue.

    I am reposting it because the earlier post was done through my other Windows Live ID. That was my mistake I apologize for that.
    Friday, September 10, 2010 9:57 PM