Problems with setup.exe RRS feed

  • Question

  • I have generated a setup.exe and MyClient.msi using VS2008 setup program and
    packaged it in a install.exe using iexpress.

    If I run setup.exe by double clicking it works fine and installs the the
    program but when I run install.exe then I get following error,

    === Verbose logging started: 9/2/2009 2:03:11 Build type: SHIP UNICODE
    4.00.6000.00 Calling process: C:\Windows\system32\msiexec.exe ===
    MSI (c) (3C:7C) [02:03:11:283]: Resetting cached policy values
    MSI (c) (3C:7C) [02:03:11:283]: Machine policy value 'Debug' is 7
    MSI (c) (3C:7C) [02:03:11:283]: ******* RunEngine:
    ******* Product:
    ******* Action:
    ******* CommandLine:
    MSI (c) (3C:7C) [02:03:11:286]: Note: 1: 2203 2:
    C:\Users\A\AppData\Local\Temp\IXP000.TMP\MyClient.msi 3: -2147287037
    MSI (c) (3C:7C) [02:03:11:345]: MainEngineThread is returning 3
    === Verbose logging stopped: 9/2/2009 2:03:11 ===

    I looked for MyClient.msi in C:\Users\A\AppData\Local\Temp\IXP000.TMP but
    did not find it. Somehow it gets deleted during the installation as I did
    verify that it is present in the start. I am not sure why it gets deleted or
    if there is some kind of race condition present.

    Install works on XP but On Vista it consistently gives me this error. I do
    not have anti virus autoprotect ON either. I am logged on as administrator.

    Any pointers would be greatly appreciated.
    • Moved by YiChun Chen Friday, September 4, 2009 7:45 AM It's off topic here. This forum is for the support of VS installation. You issue is related to deployment. (From:Visual Studio Setup and Installation)
    Wednesday, September 2, 2009 7:13 PM