locked
.zip files will not extract in Vista Business OS RRS feed

  • Question

  • When I try to extract files from a .zip file, all I get is an empty folder. I've tried right click, extract files. Double click and drag a folder/file to the desk top. I've tried double clicking the .zip and selecting extract all, but all I get is empty folders. I even created a .zip folder as shown here. It created fine, but then I could not extract a single file from the .zip I had just created. Yes, the files loaded into the .zip because it had 36MG in the folder, but will not extract. Anyone else with this problem and/or a solution??? This is an upgrade from XP PRO and files extracted just fine before the upgrade to Vista Business Edition.
    Thursday, January 25, 2007 2:18 AM

All replies

  • I have Windows Vista Business also and I have about the same problem.  Windows extracts my files very slowly.  It measures around 2 bytes/sec.  I needed to extract a 250 MB file and it said it would be done in a few days.  I expected that it woud speed up eventually, but it does not.  Other extraction programs work fine, but it would be nice to have an extraction program well integrated into Windows.
    Monday, February 5, 2007 7:44 PM
  • I have the same problem. I have a Vista Business and the extract feature is ridiculiasly slow. I need to extact 450 MB and its extacting at 5 bytes. WinRAR works fine.

    Jaweed

     

    Saturday, February 17, 2007 7:27 AM
  • I had a similar problem with XP Pro. The problem appeared to be with Windows Defender, which I believe is built into Vista. In my case the solution was to remove Windows Defender, disable my internet connection then extract the files. Worked fine - not as fast as ZipGenius, but fast enough. Then when I again enabled the internet connection, the speed improvement was maintained. I don't know if you can remove Windows Defender from a Vista installation, but maybe turning of real-time scanning - it might prduce the same effect. The disabling of the internet connection seems to be essential.
    Sunday, February 25, 2007 8:16 PM
  • I made a zip in win xp, and tried to extract in vista it took 40mins size 1.2gb, i tried extraxting in Winxp it took 3mins. Vista extract util is a shame.
    Friday, March 2, 2007 10:46 PM
  • I tried dadooq's XP fix in vista business, no go.
    Friday, March 16, 2007 12:06 AM
  • Has anyone found a fix to this problem yet?
    Friday, March 16, 2007 7:19 AM
  • Had the same problem. Downloaded the .reg file from this site:

    http://www.dougknox.com/xp/file_assoc.htm

    I was reticent to run the file, but it seemed to do the trick. I'm running Vista Business and now I can open .zip files, just like I could in XP.

    Friday, March 23, 2007 2:09 PM
  • I've got the same problem on Vista business with it being extremely slow.

    It was going to take vista between 2 and 3 hours to unzip something that took 7-zip 15 seconds to unzip.

    Hopefully Microsoft acknowledges that this is a problem and fixes it.

    7-zip is free and open-source if you need a copy.

    www.7-zip.org



    Thursday, May 10, 2007 9:28 PM
  • Thanks, CharlesJ!!!

     

    Now I can also open and extract .zip files in Vista Business just like as in XP. Great tip, but I am wondering why Vista wasn't able to extract by itself...

    Monday, May 21, 2007 6:23 PM
  • Thanks for the tip on 7-zip, it works like a dream.

     

    Also thanks to the contributors on this thread. It quickly helped me understand the blank folder being displayed in my Win Vista Home Premium extract.

    Tuesday, May 22, 2007 9:38 PM
  • Excellent! Thank you for 7-zip. This issue has been a thorn in my side every time I download something. I was having to go to the Win2k3 server to unzip the downloads. A real pain in the b- - t!
    Monday, June 18, 2007 3:38 PM
  • 7-zip works fine.   It's a shame, that Microsoft doesn't has a solution for this problem.  It's a waste of time, trying to find solutions to these bugs not found in early versions of windows.
    Sunday, June 24, 2007 12:07 AM
  • Thanks for the 7 zip tip.  This has been the biggest pain in the b**t ever.  Thanks!
    Tuesday, September 18, 2007 9:50 PM
  • I also had ZIP extraction problems on a Vista Home Premium HP Pavillion tx1000 tablet / notebook.  It would compress anything using the right-click, send to, compressed (zipped) folder method.  When I double-click the zipped file to view/unzip, internet explorer launches and then that browser window maximizes, minimizes in a perpetual loop which I could only stop by shutting down / restarting the PC.

     

    I downloaded 7-Zip also.  Worked fast and well.  Thanks to the original poster for the tip. 

    Friday, November 9, 2007 5:54 PM
  • i dont have windows vista business, but i do have windows vista and i have a DF2 game that some how 3 programs on the cd got zipped and now im having a problem unzipping it i have the WinRAR and installed the 7-zip and still come up with the same problem, does any1 know anything about DF2 (Delta Force2) (PC shooter game) and when i try to install the game all i get is when i put the game in the CD thingy its as if i never installed the game
    Thursday, November 22, 2007 10:33 PM
  • so as I see it 7-zip is the ONLY zip and unzp program that works with Vista Premium edition, is that correct
    Wednesday, November 28, 2007 2:16 AM
  • I ran the .reg file but it still doesn't work.  So I downloaded the 7-zip and still couldn't extract the zip file.  Is there any way I can undo the .reg file?

     

    Thank you.

    Monday, February 4, 2008 5:52 PM
  •  

    THANK YOU SO MUCH!!!!!!!!
    Sunday, February 24, 2008 8:03 PM
  • Thanks a lot! That really helps me out. I've been having a lot of trouble with this lately
    Wednesday, June 4, 2008 6:58 PM