locked
Unable to update to UR12. Missing Serviceability Folder RRS feed

  • Question

  • Hello,

    We are currently running CRM 2011 on update rollup 11, and we would like to update to rollup 12.

    When running UR12 the installation failed with the following error:

    Could not find a part of the path 'C:\Program Files\Microsoft Dynamics CRM\Setup\Serviceability\Latest\ConfigDb.cab'.

    Further to our investigation we noticed that the serviceability folder does not exist on the server, so we tried to copy the whole folder from our test environment. We run UR12 again and this time seemed to install without problems, however when opening CRM we got a message box stating that SQL server could not be found.

    I suspect that there is some sort of connection string in ConfigDb.cab that is pointing to the test environment DB server. However we could not find it anywhere.

    Any ideas please?

    Thank you


    Darren Mercieca

    Friday, February 7, 2014 12:00 PM

All replies

  • Hi

    Did you try to repair  your CRM setup. Maybe that would re create missing files 

    Friday, February 7, 2014 12:04 PM
  • Yes we did. We got the following error during the repair and could not proceed:

    Method not found: 'Boolean Microsoft.Crm.Setup.Common.Utility.Win32Utility.get_IsWindowsServer2012OrLater()'.


    Darren Mercieca


    • Edited by darrmerc Friday, February 7, 2014 12:32 PM
    Friday, February 7, 2014 12:24 PM
  • When you started the repair, did you choose the option to get updates?  This downloads any fixes for the installer that have been released since RTM.  There was a fix for the installer that let you install CRM on Windows Server 2012, and that is likely what you will need.  Don't confuse this with the Windows updates option that you also get to choose at another point.

    Also, running a repair will blow away previous rollups that were installed on the CRM server.  So you will need to install rollup 6 again before you can install rollup 12 since 6 is the prerequisite.


    Jason Peterson

    Friday, February 7, 2014 3:42 PM
  • UR 12 is a major update (aka Polaris) did you try to install it on a test environment or straight on production? (I hope not...)

    Anyway it is very likely that you have unsupported plugins / code in your deployment that gives you errors - you should try to disable any plugins on a test environment and see how that goes.

    Michael

    Monday, February 10, 2014 10:47 AM
  • UR12 installed smoothly on the test environment, and every plugin/customisation worked fine. The problem on the production environment seems to be this missing Serviceability folder, which I cannot replace.

    Darren Mercieca


    • Edited by darrmerc Tuesday, February 11, 2014 1:39 PM
    Tuesday, February 11, 2014 1:39 PM
  • Is the problem now that you still can't install UR12 or you did and are now getting an 'SQL server could not be found' error - if so can you upload a more detailed error \ log file?

    Michael

    Thursday, February 13, 2014 9:39 AM