locked
Realtek RTL8111C Gigabit chipset (Asus motherboard) + speed slow-down RRS feed

  • General discussion

  • NOTE: I posed this question in another (and somewhat unrelated) hardware thread. This thread was created to end that derailleur.

    I am curious about people's experience with the Realtek RTL8111C Gigabit chipset. I just put into service an Asus and AMD motherboard based WHS machine and, for some reason, the Realtek RTL8111C motherboard-based NIC was throttled down to 100mbit service.

    Yes, a current, Realtek-distributed WinServer 2003-friendly Realtek driver was installed as the first step once the WHS installation process completed, as WHS did not support the NIC out-of-the-box. Upon installation and prior to the Windows Update process running, the NIC was connecting with a local switch at a 1gbit rate of speed.

    At some point during the Windows updating process or just after, the NIC dropped its connection to 100mbit and hasn't changed since. The machine has been rebooted and the Device Manager reports no problems. WHS reports that it is fully up-to-date.

    The only thing that I can think of that went awry is maybe WHS determined that the rest of my LAN, outside of the local switch to which it is connected, operates at 100mbit and WHS throttled the network connection down. All LAN speed settings are on auto.

    Unfortunately, the heaviest data transfer work is intended to take place via that local gigabit switch and at gigabit network speeds.

    Thoughts?

    Machine Spec for the curious:
    Case: Antec Mini P180
    Mobo: Asus M3A78-EM
    CPU: AMD Athlon X2 4850e
    Heatsink: Scythe Ninja Mini (passive :) )
    RAM: Kingston DDR2 800 (1GB x2)
    PSU: Antec Earthwatts 430W
    Optical: Lite-on generic spec'd drive
    Drive(s): Seagate ES-class 500GB (x2)
    Wednesday, December 3, 2008 7:23 PM

All replies

  • Charles,

    WHS doesn't have any facility to negotiate the NIC connection speed.
    I would download the Server 2003 version of the driver and do another install of it if it was working correctly before.

    Colin


    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    Wednesday, December 3, 2008 7:56 PM
    Moderator
  • Colin, I think that statement is not true.
    Windows Server 2003 is doing a more harsh evaluation of the environment, than XP does. So if something is low quality (i.e. cable or plugs) the speed will be lowered to warrant for a reliable connection.
    I had this myself with WHS - as long as my server was connected to a plug in the wall, it gave me only 100 MBit/s even if connected to a GigaBit port on the other end with a GigaBit NIC. As soon as I took the cable and put it directly into the switch, the expected GigaBit connection got established.

    Best greetings from Germany
    Olaf
    Thursday, December 4, 2008 8:36 AM
    Moderator
  • Charles Buck said:

    Thoughts?



    You could try to force the NIC to gigabit speeds:
    DeviceManager->Network Adapter->Realtec->properties: advanced, linkspeed option.

    Make sure you can connect using keyboard/display to undo this in case you permanently loose the servers network connection!
    Also note that effectively this would disable link speed negotiation and could result in unreliable network connections.

    Theo.
    No home server like Home Server
    Thursday, December 4, 2008 10:50 PM
    Moderator
  • Update: After installing some AMD and ATI system board / bus related drivers and 1 - 2 reboots of the OS, the NIC bumped back up to gigabit service. Ah the joys of running server software (WHS) with drivers that sort of support the OS.

    The machine is connected to an almost-new, locally-placed, five-port switch with new Cat 6 patch cables. It was late when all of this config work took place so I will have to test speeds at another point.

    Music library bomb bay doors open! :-D

    Thursday, December 11, 2008 4:26 PM
  • Olaf,
    Yes, Server 2003 will negotiate speed down -or up- to get a consistent connection without data loss. However, it will not change the NIC settings, which is what I was referring to above.

    Colin





    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    Thursday, December 11, 2008 7:58 PM
    Moderator
  • Charles...have reliable source for the drivers.  I'm preparing my installation with that board.

    Thanks!
    Monday, December 15, 2008 10:06 PM
  • Sorry to dig such an old thread.

    I do have a spare machine running as a NAS and using an embedded Realtek RTL8111C NIC (motherboard is a Gigabyte GA-G31M-ES2L). It doesn't use Windows but FreeBSD (FreeNAS). I do have exactly the same pb with this NIC. It often works at 1Gbit but sometimes it drops at 100Mbit, no matter what cable I use. As far as I know, it is not due to any software drivers as the NIC clearly goes 100Mbit at the very booting time. Just look at the leds on the connector. It should be orange (gigabit), it is green (fast ethernet). And no OS/drivers is loaded yet.

    After several reboots, it may go gigabit again, with the same cable attached and the same machines on the network… This NIC is just a buggy one.
    Monday, April 6, 2009 11:37 AM
  • Just to inform you I have found a workaround. It may be useful for other people who use this NIC.
    I went to the BIOS and launched an ethernet cable test. I don't know if this option is available on other motherboard brands (I have one on the Gigabyte and also on my Asus MB that uses a Marvell NIC). The test detected an ethernet cable that supports gigabit ethernet. When I look at the LED, it went orange (same on my gigabit switch) so gigabit has been enabled. It seems that doing this test 'forces' a better detection at BIOS level.
    Monday, April 6, 2009 2:41 PM
  • I had the same problem as described here: Only 100Mbit connection. Additionally I had the problem that I took a looong time (up to 30sec) until it got a link. I first although thought the NIC is to blame, but finally I found out it isn't really.

    - First I tried another NIC on the same cable. It was an intel NIC and worked just perfect out of the box.
    - Then I tried to connect the RTL8111C to another swich, but there it didn't get any link.
    - Then I connected it directly to another PC. Hm suddenly instant 1Gbit link?!
    - Then I thought ok the maybe the switch(es) are to blame...
    - I got a new one. This time a really good managed one from HP.
    - Now I got 1Gbit connection, but still looong time spans until it got the link!
    - Played a bit with the driver and switch... nothing helped.

    At this point I hadn't any more ideas. But finally I just changed the LAN cable AND now it gets 1Gbit link INSTANT (as it should). The odd think is that with the same cable, at the same port other NIC's worked perfect just from beginning without any problems.
    Tuesday, June 16, 2009 7:56 PM
  • GhoSe, YOU ROCK!

    I swapped the cable and it worked perfectly!
    Wednesday, December 30, 2009 4:21 AM
  • can you provide me a link to windows 2003 driver, all drivers i got from net is not compatible with W2K3. 
    mark my post as answer if my post was usefull to you
    Friday, April 23, 2010 12:15 PM
  • Did you try XP Drivers?

    http://support.asus.com/download/download.aspx

    You have to give the details of your motherboard as Asus have stupidly not allowed you to copy and paste links to their downloads - my advice would be to use a decent PCI based NIC - on motherboard network adapters are junk, especially RealTek - you will just end up with more problems in the future.

    Edit: They do allow links - try these drivers:
    http://support.asus.com/download/download.aspx?model=M3A78-EM&f_name=LAN.zip&f_type=5&os=17

     


    --
    Friday, April 23, 2010 2:20 PM
  • i have had the same problem, but it is more severe and i am ready to toss my motherboard out the window (parden the pun). I have Realtek 8169/8110SC chip on my jetway mini-itx motherboard. It worked fine for years, then some WHS update causes the network connection to only go to 100MBits and most of time the system fails. I have tried installing new drivers , cables, switches etc. Nothing works! Anyone have any ideas?

     

    Wednesday, August 10, 2011 12:09 AM