locked
CRM 2013 setup failed: looking for user with same name as the computer? RRS feed

  • Question

  • Hello, I've searched and searched and can't find anyone else with this issue. Essentially my install of Dynamics CRM 2013 is failing here:

     

    Action Microsoft.Crm.Setup.Server.GrantConfigDBDatabaseAccessAction failed.

    Windows NT user or group 'DOMAIN\CRMSERVER$' not found.

     

    There are several people who have a similar issue with the SQLAccessGroup not being found but in my case, the install seems to be looking for a user or group with the same name as the computername that I'm using for the CRM install. I've tried renaming the server (CRMSERVER1) and the next time the install fails searching for a user with the new name

     

    I've tried all the usual suspects (closing SQL management; closing remote desktop to SQL server, renaming an existing user account to CRMSERVER$). It still fails at this same spot.

     

    A little background:

    This server hosted a CRM 2011 install but the company database is on a remote SQL server. When I attempted to upgrade to CRM 2013 last night it failed with this same error. Now I can't go back to 2011 because something in the company must have been updated and It never completes the 2013 install. I've tried installing a new instance planning to then import the original company after the install but it fails at the same spot in the process.

     

    Has anyone come across this before?

    Why is CRM looking for that particular user name?

     

    I'd greatly appreciate any help anyone can offer.

    Thanks!

    Devin

    Friday, December 20, 2013 1:38 AM

Answers

  • After posting this I remembered that while I'd checked if that account existed in the domain I hadn't checked the login list in the SQL manager. Sure enough, that user account was missing. I manually added that account into the login list and viola! the error disappeared.

    Happy new year!
    --Devin
    • Marked as answer by uf97ddim Friday, December 27, 2013 6:29 PM
    Friday, December 27, 2013 6:29 PM