none
SCCM Prerequisites - SQL Sever TCP port failed

    Question

  • Hey, 

    I currently have the task to test the SCCM 1511, but I ran into a few problems while doing this.

    I build a testing environment with 2 VMs (1 with AD and DNS and the other with SQL 2012 and SCCM) that both run Win Server 2012. 

    When installing SCCM I get the error:

    Configuration Manager primary site and central administration site require SQL Server Tcp is enabled and set to Static port.

    TCP is enabled and set to static port 1433 by default when I look in SQL Configuration Manager

    I'm stuck right know does anyone know how to fix this?

    Thanks.

    Monday, January 18, 2016 8:57 AM

Answers

  • What architecture is on your SQL Server? (SQL not Windows)

    I had the same problem and I realised I had an x86 SQL Server installed.

    So I uninstalled it and installed SQL Server 2014 SP1 x64 instead, then the problem went away.


    Tuesday, January 26, 2016 9:53 AM

All replies

  • What architecture is on your SQL Server? (SQL not Windows)

    I had the same problem and I realised I had an x86 SQL Server installed.

    So I uninstalled it and installed SQL Server 2014 SP1 x64 instead, then the problem went away.


    Tuesday, January 26, 2016 9:53 AM
  • I have been troubleshooting this error message for more than a week and I have found websites that goes through the troubleshooting steps but its amazing that none of those websites did not mention that the SQL Server had to be x64 (at least from what I found). I knew that it required x64 bit, which is what I thought I installed, but it was not until I read this message that made me actually check it. Thank you for the solution.
    Sunday, April 17, 2016 10:15 PM
  • I was installing SCCM 1606, with SQL 2016 - and was getting the same prereq error, and in the alert it was mentioning a non static port was set to dynamic. After digging around I found various posts, and decided to try this.

    I went to "SQL server manager/Sql server network configuration/"my instance"/ right click on tcp/ip select properties, go down to the bottom under the "IPAII"

    Then I cleared the dynamic port box, and set the TCP Port to 63728 and leaving TCP Dynamic port empty, hit apply, OK'd out. Then restarted the SQL service. This allowed the sccm prereq check to pass, and SCCM is installing now. The installer is still running but I have a green check for "Setting up the SQL server database". Woot! 

    References:

    http://dba.stackexchange.com/questions/102014/mixed-sql-server-instances-with-static-and-dynamic-ports

    http://www.sqlserver-expert.com/2012/07/configure-sqlserver-to-listen-on-static.html


    • Edited by Dan Spec Thursday, October 27, 2016 6:33 PM ..
    Thursday, October 27, 2016 6:27 PM