WHS freezes up. No console or input from mouse or keyboard possible. RRS feed

  • Question

  • My WHS has been humming along with no problems, managing backups and other services like a force of nature for nearly six months at least now.  One morning I find that both my gateway machine, a linux box SME Server distro, and WHS has frozen up.  I hard rebooted the gateway machine and it seems to be restored.  I hard rebooted the WHS machine and logged in and after the system reported recovering from a "serious error" and tried to report to MS, it froze up again.  No input from the mouse or keyboard gets any kind of imediate response.  I suspect that I might have run out of disk space, but wouldn't I get some kind of warning from WHS about running out of disk space?

    What should I do next?  I'm afraid of doing too many hard reboots, I don't want to permanently corrupt the system.

    Any and all tips or clues would be appreciated.

    Wednesday, May 4, 2011 5:02 PM

All replies

  • I had some other problems a while back with locking up that was associated with a client server problem.  This does not appear to be related to that.  Here is that thread:


    I just got a Blue Screen shutdown and reboot from the system, "to prevent serious damage".  Something about a thread causing a problem.  Now the reboot has locked up.

    Wednesday, May 4, 2011 5:16 PM
  • Server reinstall?
    Wednesday, May 4, 2011 5:22 PM
  • I have interrupted the frozen reboot with a hard reboot.  I have shut down the gateway system in case there was some client issue.  Now I am getting an error message on the reboot saying a file is missing or corrupt, "<Windows root>\system32\ntoskrnl.exe. Please re-install a copy of the above file".

    Wednesday, May 4, 2011 5:31 PM
  • Server reinstall?

    Why would I do that?
    Wednesday, May 4, 2011 5:31 PM
  • I guess to see if that fixes your problem! Unless of course you believe it's a hardware problem? Your previous message indicates a software issue so a server "repair" using the installation disk might be the first step to take.
    Wednesday, May 4, 2011 5:44 PM
  • I agree about using the installation disk.  But there is a "Repair" option there that I would try first.

    But, there are some new developments.

    I've tried rebooting several times.  My last attempt was to apply the installation disk, but the boot missed the CDROM drive and went to the hard drive where I managed a successful boot.  I went through the notification about the "serious error" again, but this time there was no lock up and as I type this now, everything appears to be running normally.  I was notified that there appeared to be a problem with a driver.  I went to a refered site at microsoft where I was notified of a huge list of updates that needed to be installed.  Most of them seemed to be in reference to Windows Server 2003.  Apparently my automatic update was not functioning.  It is on now and I will monitor it to make sure I get my updates.

    We will see what happens.

    It also appears I am not getiing my reply notifications from this site.

    Sunday, May 8, 2011 5:36 PM
  • Locking up continues to be a problem.  Tried installing updates that included an ATA Controller driver update.  Tried shutting down the MySQL server and switching to manual restart.  Nothing seems to work.  Checked the CMOS battery, it's fine.

    After sitting there for at least six months now, functioning flawlessly, suddenly the whole thing is completely useless. 

    I'll be happy to submit a report if someone will explain how to do that.

    Monday, May 9, 2011 7:02 PM

  • I'll be happy to submit a report if someone will explain how to do that.

    You will need to log into connect.microsoft.com to log a bug.
    Monday, May 9, 2011 7:24 PM
  • Freezing out of the nowhere is happening rarely due to software issues.

    How old is the machine? Was it new or reused hardware?

    Did you ever open it and check for dust on the cooler fans and on the cooler itself and remove it?

    Check also the seating of the cables, while you are at it.

    Which model is it? With an HP Mediasmart 475 I experienced random freezes after upgrading to 2 GB RAM - downgrading to 1 GB stabilized the system.

    Best greetings from Germany

    Tuesday, May 10, 2011 2:15 PM
  • Yes, I am beginning to suspect hardware issues.  One of the upgrades posted at MS that I was due to apply was for a SiI 3512 SATARaid controller.  And this is what I am using for my primary drive.  I am using a controller installed in a PCI slot, and not the mainboard controller.

    I had some other problems with this card in the past:


    A frequent report printed out when the system was hard rebooted was that of a driver failure of some kind.  My latest attempt to correct the problem involved upgrading the BIOS on the SATA card.  Another problem that emerges as a consequence is that the option to repair the system does not come up when you boot from the installation CDROM.

    I used SATA PCI controller because I wanted to use a SATA drive instead of the old IDE tape type and there was no SATA port on this machine, a Dell Optiplex GX 260.

    Unless I can get some advice on how to deal with the current situation, my next attempt to solve my problem will be to move the contents of this SATA drive to an IDE drive installed on the mainboard.  The PCI controller is just not worth the trouble.

    Tuesday, May 10, 2011 4:33 PM
  • You know, I feel like an idiot for not even considering this ...

    Would WHS work if I used a SATA to IDE converter so that I could install the SATA drive on the old IDE type interface on my mainboard?

    It could be I could just replug the whole SATA drive with the converter and see what changes I get.

    Any advice or experience with this?

    Tuesday, May 10, 2011 4:47 PM
  • I just tried reinstalling the driver for the SATA PCI SiI 3512 SATARaid controller from Windows Update.  Still locking up.
    Tuesday, May 10, 2011 9:37 PM
  • Oh the old Dell machines - the GX260 is very old and from my experience it is easily possible, that either the power supply or some capacitors on the mainboard are going to die (in GX270/280 models we had this issue in more than 50% of the machines - especially, but not exclusively the small form factor cases).

    I never used such an IDE-SATA converter and would usually not recommend to invest in this kind stuff for such outdated hardware. Instead get a newer platform - this would be my recommendation.

    Best greetings from Germany

    Wednesday, May 11, 2011 9:24 AM
  • A pattern is beginning to develop.

    The lockups appear to occur whenver I am trying to apply updates from Microsoft.  And there was also a similar problem for my other client machines.  They would be automatically getting updates and when I shut down, they would notify me that they were going to install an update and shut down.  But they would never shut down.  The update installation progress indicator would hang at installing 1 of 1 updates and I would have to shut it down manually, but soft, not hard.  The system would not lock up.  This happened at least three times and has not happened agains and I assumed Microsoft had fixed the problem somehow.

    Wednesday, May 11, 2011 9:59 PM
  • More clues.  From the Event Viewer under Administrative Tools:

    Error: LoadPerf, The performance strings in the Performance registry value is corrupted when process Performance extension counter provider. BaseIndex value from Performance registry is the first DWORD in Data section, LastCounter value is the second DWORD in Data section, and LastHelp value is the third DWORD in Data section.

    Error: LoadPerf, Unloading the performance counter strings for service WmiApRpl (WmiApRpl) failed. The Error code is the first DWORD in Data section.

    Information: LoadPerf, Performance counters for the WmiApRpl (WmiApRpl) service were loaded successfully. The Record Data contains the new index values assigned to this service.

    A search of "LoadPerf" here turns up another sufferer:


    And a hard drive connection problem is suggested here too.

    Friday, May 13, 2011 10:21 PM
  • For some reason, the problem has vanished.  WHS has rebooted and has remained stable for about 2 days now.  MySQL is active again and updates are automatic again and I am experiencing no lockups.  I have made no changes that might suggest a solution.

    Once WHS appeared to be running stable again, I tried solving the "LoadPerf" problem.  This was pretty easy.  If you see the error showing up in your Event Viewer, right click the error entry and call up Properties.  There you will see a link to your Help and Support Center which will tell you what to do.  Basically, you just run Lodctr /r on the command line.

    Monday, May 16, 2011 4:59 PM
  • Still sounds hardware related and as such it will return at some point!
    Monday, May 16, 2011 5:47 PM
  • Locked up again.  Finally, the most persistent symptom is the failure of the driver for my SATA PCI SiI 3512 SATARaid controller.  A system migration is in progress.

    My advice to anyone suffering from similar problems is to monitor the Event Viewer which is found in Control Panel->Adminstrative Tools->Event Viewer.

    Friday, May 27, 2011 5:33 PM