Microsoft Validation Issues when downloading - GenuineCheck errors RRS feed

All replies

  • This problem appears to have been resolved - finally!

    Internet Explorer now appears to function properly, validating with the ActiveX controls.

    FireFox and Chrome validate using a functional version of GenuineCheck.exe

    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Friday, October 26, 2012 1:42 PM
  • Noel,

    Someone at Microsoft woke up and fixed the expired tool.

    Gee whiz.  It only took two months! 

    Thursday, November 1, 2012 10:12 PM
  • :) the sleeping giant finally awoke!

    (I mad it nearer 10 weeks :( )

    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Friday, November 2, 2012 10:02 AM
  • Actually, I JUST encountered this issue this evening! (8-22-2013!!!) Using Microsoft's own site to obtain the appropriate 32bit WinHelp program for Windows 7 Enterprise and by choosing appropriate OS, svc pack, etc., I was directed to this link:


    I changed the 'exe-validation' term to 'genuine-validation' as in the helpful hint above, hit enter and was redirected to here:


    Upon seeing "Windows Help program (WinHlp32.exe) for Windows Vista" and knowing this was NOT what I wanted, I used the Search feature looking for "Windows Help program (WinHlp32.exe) for Windows 7"

    and found a link to the proper download page here:


    Downloaded and proceeded through the 'wizard' and TALLYHO! I'm viewing my antique 32bit 3D Home Architect .hlp files in all their glorious 32bit antique splendor!

    Thanks, MicroSoft for making our lives SOOOOO much better!

    And my friends wonder why I insist on keeping this "product" running in VMWare on my perfectly functioning Mac!  Wonder that myself.  Often!!

    Friday, August 23, 2013 12:29 AM
  • 08/27/2013:  Well, I'm glad it worked for you (on '8-22-2013!!').  I've followed your instructions to the 'T', without success.  The dowload keeps giving me the same file, GenuineCheck.exe, 1,528,184 bytes, version  When run, I receive the message, "This version of Windows Genuine Advantage validation tool is no longer supported.  Please download the newest version and ensure that your system clock is accurate".  I'm using this on a (genuine) Windows 7 Home Premium 32 bit system, and have ensured that my system clock is accurate (using the internet update feature for setting the correct time).

    I will continue to search for the file to download, but suspect I can grab the one I'm using from my other system, which was a Vista system, prior to upgrading to Windows 7.  Microsoft doesn't want to let me download the Vista version of the help file, instead, puts me (and many others) through the wringer, trying to get Help files to display.  Why such a simple function, which Microsoft has allowed the user to fix, grudgingly, up to now, is such a pain in the a** to install, is beyond me.  This ability to read older help files should have been in the system from day one.  Does Microsoft think we all throw away our old software just because we buy a new computer?!!  Unbelievable, that this problem has gotten WORSE over time, instead of better!!

    Frustrated.  No wonder Microsoft is struggling, as a company!  They have 'lost the way'!!


    Wednesday, August 28, 2013 1:53 AM
  • 08/27/2013:  Further update on above:  Apparently, the links above (see "(8-22-2013!!!)", by [anonymous]) are browser dependent.  It is safest to use Internet Explorer ("I.E.") to view the links, as it presents a different page than some other non-Microsoft browsers (they immediately show the Download button, as, I suppose, they are not set up like I.E. to install Active-X controls, the way I.E. does).  When using I.E., one is prompted to allow the installation of an Active-X control to do the validation.  The old program, referenced in my post, above, was used as an 'alternate method' for those not wanting to install and run an Active-X control in their browser, and though I used to use it with Windows 7, an update from Microsoft, I assume, broke it, and it no longer works.  Instead, it gives the message to obtain a new off-line version (which it appears does not exist - I'm still researching this).

    Anonymous, referenced above, did not specify what he meant by 'download'.  That is, did he download a file to run the check off-line (not connected via browser to the internet)?  Or, did he 'download' an Active-X control, complete the browser's steps, and 'Tallyho!', etc.  This is not clear from his post.  (To me, 'download' means obtaining a file from the internet, and saving it to a selected folder on my hard drive, not installing some add-in through some particular browser.  But that's my understanding.)

    More to come later, if I solve the problem....


    Wednesday, August 28, 2013 3:59 AM
  • 08/28/2013:  Well, here's what I've found regarding the above, from doing a LOT of reading of various forums for several hours:

    First, Microsoft ("MS") apparently changed something regarding their validation procedure about a year ago, c. August 2012.  Their 'offline' tool, GenuineCheck.exe no longer works, and despite a forum post last September (2012) that claimed there was a new version, I've been unable to find one.

    Second, if you need to download a MS file that requires validation, DO IT USING INTERNET EXPLORER 32 BIT - not the 64 bit version.  Usually both are installed, if you are using a 64 bit version of Windows.  The default for 64 bit Windows is the 64 bit Internet Explorer ("I.E."), so you'll have to hunt for the shortcut to the 32 bit version.  I.E. 32 bit will ask to install an Active-X control, which will allow you to do the 'genuine check' from within the browser.  You will not use the 'offline' method that requires running GenuineCheck.exe off-line (it no longer works).  [That method used to give you a code to copy/paste back into a box in a browser window, to allow MS to validate your setup as 'genuine'.]

    Third, if you are just trying to download a single file, you can use a workaround, that worked for me, bypassing the genuine check screens altogether:

    For example, for the WinHlp32.exe file for Windows 7 (necessary for displaying older Help files), one would normally arrive at this URL, which has the 'validation required' notification:


    However, one can change the URL slightly, replacing the word 'details' with the word 'confirmation', allowing one to immediately download the file without the validation check, as follows:


    I found the above workaround at http://www.msfn.org/board/topic/158078-microsoft-removing-xp-downloads/page-2#entry1012059.  My thanks to tomasz86 for posting it, and to RJM for confirming it (18 and 19 September 2012, respectively).

    Note that this method may work for other files MS restricts to validated users only, but I have not tested any others.  Also note, since this method bypasses MS's internal restrictions, it is likely to be changed in the future.  It would be too much to hope for, I suppose, that MS would remove the restrictions for these files, or at the very least, for WinHlp32.exe.  If that occurs, you will have to resort to the "approved solution" in "Second, ..." , above.

    Best of luck, and hope this post will help some frustrated users.  And judging by the many, many forum posts on this and related topics, there are plenty of them!


    Wednesday, August 28, 2013 6:04 AM
  • I tried everything above and nothing worked.  I would get prompted for the ActiveX and click install but nothing would happen and I would be redirected to download the Genuine Advantage Validation Tool which wouldn't work.  I'm pretty sure the .exe validation tool didnt work because the certificate they signed it with is now expired.  Thats why it asks you to check your system time.  The solution for me was to run Internet Explorer 32-bit as Administrator (Right-Click, choose "Run As Administrator").  This allowed me to run the ActiveX control and get to the actual download.  The word of caution with this is that you probably dont want to do any additional browsing while running IE as Admin as it presents some security risks.

    Friday, August 30, 2013 7:04 AM