locked
Problem with e-Sata disk on PC Backup in WHS RRS feed

  • Question

  • Hi everybody.

    I´ve setted up a new computer with Windows 7 Professional 64bits.

    This computer has an external e-Sata hard drive, wich is plugged eventually, like a pendrive.

    Well, so I´ve set up the WHS backup in this computer to do NOT backup of this disk...everything fine...but...each time this hard disk is unplugged and replugged, I have the warning message on the WHS that a new disk is found on this computer, so I have to configure the backup...

    As I can see, WHS recognizes this disk as INTERNAL disk...so maybe is this the cause...How can I set up this disk as a EXTERNAL one? becouse is an External disk really but with e-Sata connection...

    Thanks a lot for your help!

    Saturday, March 6, 2010 3:42 PM

All replies

  • Whether a drive is recognized as internal or external is dependent on hardware and drivers. But in the end, it won't matter; a hard drive will pretty much always be recognized as not backed up by Windows Home Server.

    Your best bet is to connect the drive when you need it, but not otherwise.
    I'm not on the WHS team, I just post a lot. :)
    Saturday, March 6, 2010 3:53 PM
    Moderator
  • Whether a drive is recognized as internal or external is dependent on hardware and drivers. But in the end, it won't matter; a hard drive will pretty much always be recognized as not backed up by Windows Home Server.

    Your best bet is to connect the drive when you need it, but not otherwise.

    I'm not on the WHS team, I just post a lot. :)

    Thanks a lot Ken!

    Yes, that´s what I do, I only connect the e-Sata Hard Drive as I need it, but as I connect the HD, I´ve always get the WHS alert of New disk found, and I have to config the Backup...

    Theres no option to get rid of this message?

    Thanks a lot!

    Saturday, March 6, 2010 3:59 PM
  • Thanks a lot Ken!

    Yes, that´s what I do, I only connect the e-Sata Hard Drive as I need it, but as I connect the HD, I´ve always get the WHS alert of New disk found, and I have to config the Backup...

    Theres no option to get rid of this message?

    Thanks a lot!

    You could try clicking "ignore this message" in the Console the next time it comes up.
    Saturday, March 6, 2010 4:45 PM
    Moderator
  • If the drive isn't connected at the time of the backup, you won't have a problem. So clicking "ignore" as kariya21 recommended is probably the easiest option.
    I'm not on the WHS team, I just post a lot. :)
    Saturday, March 6, 2010 5:34 PM
    Moderator
  • Thanks a lot.

    For the moment it works, but I can´t controll when the disk is connected, so maybe it stays connected all night during the backupl, becouse is my brothers computer...

    The thing is that it should be a way to detect this disk as external instead of internal...

    With this problem, and the warning popup caused in WHS with the Security essentials antivirus (posted also in this forum, with no working solution...) I´m a littl bit tired of Windows 7...

    Thanks for your help!

    Monday, March 8, 2010 3:36 PM
  • ...
    The thing is that it should be a way to detect this disk as external instead of internal...
    ...

    As far as I've been able to tell, digging into the internals where I can, it's a problem with all versions of Windows. Mass storage is reported as mass storage to the Windows Home Server connector (whether internal or external), and if newly connected mass storage is formatted with NTFS (which most eSATA drives are) then you have the situation you find yourself in: Windows Home Server wants to back up the newly connected drive. The same thing happens with a USB drive that's been formatted with NTFS.
    I'm not on the WHS team, I just post a lot. :)
    Monday, March 8, 2010 3:46 PM
    Moderator