locked
Unable to connect to CRM Fetch Data Source (cloud) RRS feed

  • Question

  • Hi there,

    I am currently trying to create a new fetchxml report for Dynamics CRM 2011. I have installed the Dynamics CRM Fetch extension and have input my connection string (the same URL I use in the web-browser to access our cloud CRM environment). I have also specified the correct credentials. However, I receive the following error:

    Unable to connect to data source 'DataSource1'.The connection to server "https://<myorg>.crm5.dynamics.com/XRMServices/2011/Discovery.svc" could not be established. Make sure that the connection string and credentials are correct, and try again.

    Any help will be appreciated.

    Monday, February 21, 2011 3:05 AM

Answers

  • Hi

    Please verify that you are able to connect to the URL "https://<myorg>.crm5.dynamics.com/XRMServices/2011/Discovery.svc" through a web browser using the same credentials that you are providing in BIDS. If you are able to successfully connect using the browser, try enabling CRM tracing on the BIDS machine. You can do this by creating the regular CRM trace registry entries<http://support.microsoft.com/kb/907490> under HKLM\SOFTWARE\Microsoft\MSCRMBidsExtensions (HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MSCRMBidsExtensions, if it's a 64 bit machine).

    Thanks, Abhishek

    Monday, February 21, 2011 9:23 AM
  • You would need to create the folder yourself. Once you do that, you should start seeing the trace file inside that folder.
    Abhishek Agarwal MSFT
    Friday, February 25, 2011 6:27 AM

All replies

  • Hi

    Please verify that you are able to connect to the URL "https://<myorg>.crm5.dynamics.com/XRMServices/2011/Discovery.svc" through a web browser using the same credentials that you are providing in BIDS. If you are able to successfully connect using the browser, try enabling CRM tracing on the BIDS machine. You can do this by creating the regular CRM trace registry entries<http://support.microsoft.com/kb/907490> under HKLM\SOFTWARE\Microsoft\MSCRMBidsExtensions (HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MSCRMBidsExtensions, if it's a 64 bit machine).

    Thanks, Abhishek

    Monday, February 21, 2011 9:23 AM
  • Thanks for your reply. I have added the required registry entries and then attempted to connect once again. However, there is no folder called C:\CRMTrace created on my machine so I am unable to find the trace file.
    Monday, February 21, 2011 10:05 PM
  • You would need to create the folder yourself. Once you do that, you should start seeing the trace file inside that folder.
    Abhishek Agarwal MSFT
    Friday, February 25, 2011 6:27 AM