locked
Backup service failing RRS feed

  • Question

  •  

    The Backup service stops just after it starts.

     

    chkdsk reports no errors.

     

    A reinstall (using the reinstall option) did not fix the problem.

     

    Several errors appear in the event log when the backup service tries to start:

     

    First-

     

    Unexpected error 0x6 from DeleteFile on D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\Copy.{96630062-3562-46CB-88C9-0CD2B4875548}.new: The handle is invalid.

     

    The path d:\folders does not contain a file by this name.

     

    Second-

     

    Client Backup server failed at d:\qhsv1_main\qhs\src\backup\util\datafile.cpp(1484)

     

    This path does not exist. Windows Desktop search shows no files named "datafile.cpp"

     

    Third-

     

    Persistent Drive Letter Service failed: Starting service: No attempts to start the service have been made since the last boot.

     

    I cannot find a "persistent drive letter service" listed in the services console.

     

    Other solutions for the problem of the backup service not starting have been deleting a file or reinstalling. Neither seems to work here. Any suggestions?

    Friday, May 4, 2007 12:34 AM

Answers

  • Well I figured it out after searching and finding this post:

    http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=2614910&SiteID=50

     

    Here's the summary:

     

    1. open a command prompt on the WHS server

    2. Go to the folder containing the invalid files (D:\shares\...)

    3. Type fsutil reparsepoint delete <FileName>

    4. Hit Enter

    5. Now try deleting the pointer

     

    where FileName is the name of the file with the invalid handle.  My backup DB is still in tact and backup service is running again.

    Thursday, May 15, 2008 1:54 PM

All replies

  • This is exactly what I am seeing on my system as well.

     

    I am hoping for a way to get the service started or a way to at least extract the files sitting in the backup db.

    Friday, May 4, 2007 12:59 AM
  • Add me to the list, I guess wiping the backup DB is the only option for this right now, not my first choice for sure.

    Thursday, May 15, 2008 1:42 PM
  • Well I figured it out after searching and finding this post:

    http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=2614910&SiteID=50

     

    Here's the summary:

     

    1. open a command prompt on the WHS server

    2. Go to the folder containing the invalid files (D:\shares\...)

    3. Type fsutil reparsepoint delete <FileName>

    4. Hit Enter

    5. Now try deleting the pointer

     

    where FileName is the name of the file with the invalid handle.  My backup DB is still in tact and backup service is running again.

    Thursday, May 15, 2008 1:54 PM