locked
I am having trouble removing a failing disk RRS feed

  • Question

  • About a month ago my server started slowing down. I found Ken Warren's script that runs chkdsk on all the drive and between that, the event viewer and a western digital diagnostic app I figured out which drive was failing. It seems that the system keeps going into PIO mode on that disk when it finds a few dozen bad blocks.

    I copied off enough data to be able to remove my 2tb drive prior to the RMA getting here this Tuesday and have tried to use the console to remove the drive. The first time I ran it, it locked up the machine to the point it was not seen on the network but it was still running. I did a hard reset and it came up. The drive was label failed. I went into device manager and removed the driver so it would put the drive back in DMA mode and I restarted. I did this twice before the drive came back up but it was still part of the pool. I started the removal process again yesterday afternoon and I checked this morning and the progress meter has stopped again and the drive is back to PIO mode. I imagine the system will be froze by the time I get home after work in about 12 hours.

    I am wondering if I should disable the demigrator service, because if the machine reboots I don't want it to go through and start spreading the files back onto the bad drive. From what I've seen the system is smart enough to remember it was in the process of removing the drive.

    Is it possible to pull the drive and get the data off by connecting it to a different system?

     

    Monday, February 21, 2011 2:26 PM

All replies

  • Update: On the second attempt to remove the failing disk the server is locked and I have no way to access the server remotely either via RDP or the desktop remote windows server console.
    Monday, February 21, 2011 5:58 PM