locked
Issue with Email Router v4.0 RRS feed

  • Question

  • Hey everyone. I have CRM 4.0 installed and working great. I also have Exchange 2007 installed and working, but I'm having problems getting the Email Router to work with Inbound Exchange settings. Here's my configuration:

    E-mail Server Type: Exchange
    Authentication Type: Windows Authentication
    Location: https://mx.senvoy.com
    Access Credentials: Local System Account

    I'm using "https://
    mx.senvoy.com" in the location field because I have my exchange OWA SSL Protected (with a valid go-daddy cert). This is the error that is returned:
    Code Snippet

    Incoming Status: Failure - The remote server returned an error: (400) Bad Request.



    This is the error message I get when I use "http://mx.senvoy.com" in the location field:
    Code Snippet

    Incoming Status: Failure - The remote server returned an error: (403) Forbidden.


    Anyone have any ideas?? Thanks!

    - Adam
    Friday, February 1, 2008 9:28 PM

Answers

  • Not sure if this will help or if you have already tried it, but I was having a similar issue.  However, I am not in a cluster environment.

     

    I resolved my issue by logging onto the e-mail router service with the an e-mail user account that has full rights to the Exchange server.  If you have a CRM Admin mail box or something of that nature, that has full rights to Exchange, try that. 

     

    We use the forward e-mail box feature so I used that e-mail user for the service logon.  Also, our router is installed on the CRM server.

     

    Below are my settings for reference:

     

    Incoming

     

    E-mail server type = Exchange

    Authentication Type = Windows

    Location = http://(mail.nameofcompany.com)

    Access Credentials = Other Specified

    User Name = (domain name)/(forward e-mail box user name )

     

    Deployments

     

    Deployment = My Company

    Microsoft Dynamics Server = http://(crmservername)/(organizationname)  The org name is case sensitive

    Access Credentials = CRM Admin Account

    Password = CRM Admin password

    Correct Associations for Incoming and Outgoing profiles

     

    If this does not help then you may need to open a ticket with Microsoft because there may be something different that you need to do with a Cluster environment.

     

     

    Tuesday, July 8, 2008 1:51 PM
  • Chris,

     

    One user gets this message when testing access:

    Incoming Status: Failure - The remote Microsoft Exchange e-mail server returned the error "(401) Unauthorized". Verify that you have permission to connect to the mailbox. The remote server returned an error: (401) Unauthorized. The logon attempt failed

    What Access Credentials you use? The user must have access right on the Exchange side.

    You can setup the Access Credentials via E-Mail Router Configuration Manager.

     

    Also, can you access this url via IE: http://192.168.180.50/Exchange/youremail@domain.com

     

     

    The other user gets this message:

    Incoming Status: Failure - An error occurred while checking the connection to the Microsoft Dynamics CRM server http://192.168.180.50/Exchange/youremail@domain.com

     

     

    The other user gets this message:

    Incoming Status: Failure - An error occurred while checking the connection to the Microsoft Dynamics CRM server http://crmserver/CorporateTraffic. The selected Microsoft Dynamics CRM account cannot be authenticated. Please make sure the selected account is a valid account for the specified Microsoft Dynamics CRM organization, or has permission to impersonate other users. The request failed with HTTP status 401: Unauthorized.

    Please check this user in CRM, make sure he/she has CRM access right.

     

     

    Jim

    Wednesday, July 9, 2008 7:46 AM
    Moderator
  • OMG IT WORKS!!!

     

    To clarify a couple of things for any future users with this problem.  You must use the IP address of your Exchange Mailbox Role and its the IP for the Cluster.  But the one that counted most was the username I was using for my Email Router Service.  It was using a local service account and once I change the IP and used a domain admin account it worked.

     

    Thanks guys for all the help!  It is greatly appreciated.

     

    Chris

    Wednesday, July 9, 2008 5:06 PM

All replies

  • Dear,

     

    here is post regarding this  it will help you

     

    http://www.sadev.co.za/node/143

     

    Best Regards,

    Imran

     

    http://microsoftcrm3.blogspot.com

     

    Saturday, February 2, 2008 9:02 AM
    Moderator
  • Imran,

    Thank you for your reply. I have already added the 's' to make it "https://", that's when I get the error that says:

    "Incoming Status: Failure - The remote server returned an error: (400) Bad Request."

    I go to "https://mx.senvoy.com" in my browser, and see an Under Construction page. Does the e-mail router care about this?
    Sunday, February 3, 2008 11:28 AM
  • A little more information, I enabled the "WebDAV" extension in IIS on the MX server, and as soon as I did that, I now get a different error message that reads:

    Code Snippet

    Incoming Status: Failure - The remote Microsoft Exchange e-mail server returned the error "(404) Not Found". This user or queue does not have a mailbox. Create a mailbox and try again. The remote server returned an error: (404) Not Found.


    I can guarantee you that the credentials are correct, I've tried this for 5 different users who have mail boxes. Also, here's some more information from the EventViewer:

    #26090 - An error occurred while opening mailbox abrazie@senvoy.com. Microsoft.Crm.Tools.Email.Providers.EmailException: The remote Microsoft Exchange e-mail server returned the error "(404) Not Found". This user or queue does not have a mailbox. Create a mailbox and try again. ---> System.Net.WebException: The remote server returned an error: (404) Not Found.
       at System.Net.HttpWebRequest.GetResponse()
       at Microsoft.Crm.Tools.Email.Providers.HttpDavRequest.SubmitXmlCommand(HttpWebRequest httpWebRequest, String body)
       at Microsoft.Crm.Tools.Email.Providers.HttpDavRequest.RetrieveInboxUri()
       at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.OpenMailbox()
       --- End of inner exception stack trace ---
       at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.WrapException(Exception e)
       at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.OpenMailbox()
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.Run()\r\nSystem.Net.WebException: The remote server returned an error: (404) Not Found.
       at System.Net.HttpWebRequest.GetResponse()
       at Microsoft.Crm.Tools.Email.Providers.HttpDavRequest.SubmitXmlCommand(HttpWebRequest httpWebRequest, String body)
       at Microsoft.Crm.Tools.Email.Providers.HttpDavRequest.RetrieveInboxUri()
       at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.OpenMailbox()

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Monday, February 4, 2008 1:59 AM
  •  

    Did you ever get this fixed?  I am having this same issue with no luck.
    Wednesday, May 28, 2008 9:03 PM
  • Have the same error.

     

    Try to use IP address instead of NetBios name.

     

    But if another error will appear, showing "Incoming Status: Failure - The operation has timed out "

    Try this link http://forums.microsoft.com/Dynamics/ShowPost.aspx?PostID=3241827&SiteID=27

    Sunday, June 1, 2008 10:10 PM
  • Has anyone resolved this?  I've spent countless hours review, reinstalling, reconfiguring and generally ripping my hair out.

     

    "Incoming Status: Failure - The remote Microsoft Exchange e-mail server returned the error "(404) Not Found". This user or queue does not have a mailbox. Create a mailbox and try again. The remote server returned an error: (404) Not Found."

     

    I have tried with both HTTP & HTTPS connections (modified our exchange server IIS), adjusted settings in the MSCRM_CONFIG & checked the settings with CRM4IFDTool to no avail.

     

    HELP!

     

     

    Wednesday, June 18, 2008 11:58 PM
  •  

    I'm assuming you are using a forwarding mailbox? for the incoming profile I
    used:

    Auth Type="Windows Authentication"
    Credentials="Other Specified"
    UserName=domain\username_of_forward_mailbox_account
    Password=password_of_forward_mailbox_account


    hope this helps.

    http://www.mikelu.org/archives/180

     

    Regards,

    Imran

    Thursday, June 19, 2008 6:56 AM
    Moderator
  • I am still trying to get this to work with no luck.  Has anyone had any luck with this?  I am about to scrap this project.

     

    I am not using a forward mailbox.

     

    Thursday, July 3, 2008 7:39 PM
  • ctcline,

     

    If you are using Email Router, make sure the incoming settings:

    1. The protocol, url, port are right
    2. The url is the mailbox server, it may not the OWA address
    3. You don't need the /exchange or /owa on the end of the Url, because the router service will find it
    4. Sometimes you have to publish and settings and restart the email router service then do the load/test

     

    Hope it helps.

    Jim

    Sunday, July 6, 2008 12:13 PM
    Moderator
  • Hi Jim,

    Here is some more details on my Exchange setup.

     

    I have two servers running as a cluster with Exchange2007 Mailbox role installed.  The common IP for the mailbox cluster is 192.168.180.50.

     

    I have two servers running Exchange 2007 with the client access and hub roles installed on both.  I have OWA installed on one of those servers IP 192.168.180.22.

     

    I have a E-mail Routher Configuration Profile with the email server type set to Exchange, Authentication Type as Windows Authentication, Server Location as 192.168.180.50 which is my actual "mailbox" server cluster address.

     

    I stop and start the router service after EVERY change.

     

    One user gets this message when testing access:

    Incoming Status: Failure - The remote Microsoft Exchange e-mail server returned the error "(401) Unauthorized". Verify that you have permission to connect to the mailbox. The remote server returned an error: (401) Unauthorized. The logon attempt failed

     

    The other user gets this message:

    Incoming Status: Failure - An error occurred while checking the connection to the Microsoft Dynamics CRM server http://crmserver/CorporateTraffic. The selected Microsoft Dynamics CRM account cannot be authenticated. Please make sure the selected account is a valid account for the specified Microsoft Dynamics CRM organization, or has permission to impersonate other users. The request failed with HTTP status 401: Unauthorized.

     

    Any ideas on what I am doing wrong?

     

    Thanks,

    Chris

     

    Monday, July 7, 2008 3:51 PM
  • Not sure if this will help or if you have already tried it, but I was having a similar issue.  However, I am not in a cluster environment.

     

    I resolved my issue by logging onto the e-mail router service with the an e-mail user account that has full rights to the Exchange server.  If you have a CRM Admin mail box or something of that nature, that has full rights to Exchange, try that. 

     

    We use the forward e-mail box feature so I used that e-mail user for the service logon.  Also, our router is installed on the CRM server.

     

    Below are my settings for reference:

     

    Incoming

     

    E-mail server type = Exchange

    Authentication Type = Windows

    Location = http://(mail.nameofcompany.com)

    Access Credentials = Other Specified

    User Name = (domain name)/(forward e-mail box user name )

     

    Deployments

     

    Deployment = My Company

    Microsoft Dynamics Server = http://(crmservername)/(organizationname)  The org name is case sensitive

    Access Credentials = CRM Admin Account

    Password = CRM Admin password

    Correct Associations for Incoming and Outgoing profiles

     

    If this does not help then you may need to open a ticket with Microsoft because there may be something different that you need to do with a Cluster environment.

     

     

    Tuesday, July 8, 2008 1:51 PM
  • Chris,

     

    One user gets this message when testing access:

    Incoming Status: Failure - The remote Microsoft Exchange e-mail server returned the error "(401) Unauthorized". Verify that you have permission to connect to the mailbox. The remote server returned an error: (401) Unauthorized. The logon attempt failed

    What Access Credentials you use? The user must have access right on the Exchange side.

    You can setup the Access Credentials via E-Mail Router Configuration Manager.

     

    Also, can you access this url via IE: http://192.168.180.50/Exchange/youremail@domain.com

     

     

    The other user gets this message:

    Incoming Status: Failure - An error occurred while checking the connection to the Microsoft Dynamics CRM server http://192.168.180.50/Exchange/youremail@domain.com

     

     

    The other user gets this message:

    Incoming Status: Failure - An error occurred while checking the connection to the Microsoft Dynamics CRM server http://crmserver/CorporateTraffic. The selected Microsoft Dynamics CRM account cannot be authenticated. Please make sure the selected account is a valid account for the specified Microsoft Dynamics CRM organization, or has permission to impersonate other users. The request failed with HTTP status 401: Unauthorized.

    Please check this user in CRM, make sure he/she has CRM access right.

     

     

    Jim

    Wednesday, July 9, 2008 7:46 AM
    Moderator
  • OMG IT WORKS!!!

     

    To clarify a couple of things for any future users with this problem.  You must use the IP address of your Exchange Mailbox Role and its the IP for the Cluster.  But the one that counted most was the username I was using for my Email Router Service.  It was using a local service account and once I change the IP and used a domain admin account it worked.

     

    Thanks guys for all the help!  It is greatly appreciated.

     

    Chris

    Wednesday, July 9, 2008 5:06 PM
  • Hi Imran

     

    Thanks for the link to Michael Lu's website - it's been a great help.

     

    Thursday, January 29, 2009 11:41 AM
  • my users test out fine however the call queues do not.  see below:

     

    Name: Dale Shulmistra
    Incoming Status: Succeeded

    Name: Sales
    Incoming Status: Failure - The remote Microsoft Exchange e-mail server returned the error "(404) Not Found". This user or queue does not have a mailbox. Create a mailbox and try again. The remote server returned an error: (404) Not Found.

     

    is there something i need to do to set the queues/distribution groups to work properly? 

     

    thanks,

    dale

    Wednesday, July 7, 2010 4:36 PM