none
Photos and Images don't show up in WLW

    Question

  • Recently, when I link to a photo or insert an image into WLW, all I get is the familiar box with the broken logo in the upper left corner of the box.  When I go to "Print Preview" i can see the images and photos. And when I publish, the images and photos show up correctly.  I just can't see them in WLW.

    Any ideas?
    Wednesday, March 11, 2009 1:36 AM

All replies

  • What language is your operating system?
    -Brandon Turner [MSFT]
    Monday, March 16, 2009 11:02 PM
  • Sorry about that. I am running Vista.  I was told to uninstall and reinstall, but I am unable to do that as well. When I go to Add/Remove Programs and try to uninstall or Repair WLW, I get the error : Installation source for this product is not available.

    When I try to reinstall over the old one, I get the error: Older version cannot be removed and references error hr:0x80070643
    Monday, March 16, 2009 11:24 PM
  • This tool will help you uninstall WLW:
    http://support.microsoft.com/kb/290301

    What language is your operating system?  Like spanish, german, english, etc...
    -Brandon Turner [MSFT]
    Monday, March 16, 2009 11:52 PM
  • Ok..I ran the uninstaller, reinstalled, rebooted, and same thing is happening. ....  The images show up as empty boxes.

    Tuesday, March 17, 2009 1:10 AM
  •  What language is your operating system?  Like spanish, german, english, etc...
    -Brandon Turner [MSFT]
    Tuesday, March 17, 2009 4:24 AM
  • English
    Tuesday, March 17, 2009 3:29 PM
  • Do you know what your %TEMP% path is?

    You can find it by going to Start>type "cmd.exe">in the black box that shows up type "echo %TEMP%">press enter

    What is the path that is shows?


    -Brandon Turner [MSFT]
    Tuesday, March 17, 2009 3:53 PM
  • \users\appdata\local\temp
    Wednesday, March 18, 2009 12:12 AM
  • There is no drive letter?  That is kind of weird, and could be related to the problem. 
    -Brandon Turner [MSFT]
    Thursday, March 19, 2009 5:32 PM
  • Sorry..there is a c:\ there..I just didnt put it in
    Friday, March 20, 2009 12:21 AM
  • Did you leave off your user name? That is the key thing Brandon was asking--if it has non English characters, then this is a known bug that will be fixed in a future release. Sorry!
    Wednesday, March 25, 2009 7:21 PM
    Owner
  • Oh..sorry..no non english characters at all. The weird thing is, that it was working..and then I went to post another item to my blog about a week and half later, and then it started.
    Wednesday, March 25, 2009 11:35 PM
  • How about if you turn off "View | Edit using theme"? Are the images visible then?

    Does this happen as soon as you insert a new image--it never shows up correctly in the editor?
    Thursday, March 26, 2009 3:05 PM
    Owner
  • If I turn off "View - Edit using theme" the only thing that changes is the background changes color. The images don't change and don't show up.

    It happens when I either create a new post and add an image OR when I add an image using Picassa links OR when I pull up an already existing post.

    Again, they all view correctly in "Print Preview"

    Weird..
    Friday, March 27, 2009 12:52 AM
  • Maybe you can e-mail me at joe.cheng *AT* microsoft.com--we'll have to dig a little deeper. Thanks.
    Monday, March 30, 2009 4:28 PM
    Owner
  • I have noticed that I see the empty graphic boxes in other programs as well now.  I was using windows help because I was getting an error code 64C when doing a Windows Update, and even in the Windows Help there were empty graphic boxes where it was showing me where to click to open Windows Update for example.  If I insert a graphic into email, I can see it, but on other screens, help screens etc, I get the empty graphic box.

    I changed all my temp variables in the Environmental Variables to all be the same directory, and no difference.  I updated all my flash and adobe drivers, no difference.  Very very strange!
    Saturday, April 4, 2009 3:04 AM
  • More info now:
    It seems that this exact web page I am typing this on looks fine in Firefox, but in IE all the graphics are missing. If I right click on graphic box and select "show image" the image then shows.  The graphics are only missing on Microsoft products  - LiveWriter, IE, Windows Help etc.
    Just another finding to add to the mystery!
    Saturday, April 4, 2009 7:22 PM
  • http://support.microsoft.com/?kbid=283807

    Might be helpful to just run through those steps to see if that fixes any of the problems.

    WLW depends on Internet Explorer, and shares a lot of settings with it, as do many other (Microsft) programs.
    -Brandon Turner [MSFT]
    Friday, April 10, 2009 5:55 PM
  • All of those items were fine, BUT what I did do, is uninstall IE all together, and then ran Windows Update and reinstalled IE, rebooted and guess what? It worked!!! It's amazing!
    Thanks for all your help, and patience with me!  Not sure what it was exactly, but uninstalling/reinistalling IE helped this time!
    Saturday, April 11, 2009 9:06 PM