Cannot uninstall SQL Server Compact 3.5 SP1 English RRS feed

  • Question

  • I (and a few others in the office as I have found out) am having an odd issue. I am a network engineer, as well as an admin on all desktops/laptops in our organization. I am also set up as a local admin on my machine. Normally I can install and uninstall programs as I see fit or am required to do so.
    We were trying to test software deployment with Config Man, which required me to uninstall SQL Server Compact 3.5 SP1 in order to test the software deploying to a clean machine (neither SQL or the software itself installed on the machine). At that time, I was able to uninstall it. Attempted to install the in-house created software, and it failed out. Went back to the developer and let him know this, then re-installed SQL. ran his app again, and it installed fine. When it came time to test the clean install again, this is when my machine decided to no longer remove SQL. It will act like it is removing the program, but then when the Add/Remove program window refreshes, SQL Server Compact 3.5 SP1 is still there. I have tried to use 3rd party uninstallers (Ccleaner), and it will remove it from the list-leading you to believe it was uninstalled. If you close and re-open it however, SQL is still there. I have also tried running theough the command-line (msiexec /uninstall <ssceruntime file name>) and it also fails. The message that I was getting had something to do with a network error, but the file is locally copied onto the machine, eliminating the need to be connected to a network of any kind correct? Ideas?
    Friday, July 17, 2009 2:07 PM


All replies