none
Signatures - Problems with HTML

    Question

  • Is anybody else having problems with putting HTML in their forum signatures? As you can see from my sig, I have my name, followed by my blog link. 

    At first, I didn't specify my blog as a link with the proper HMTL tags. And it was all on one line, as it is now. So, I edited my sig with to put a break, so that the blog would be on a separate line. That worked, my sig contained two lines, but I still didn't have a link. So, I edited my sig again to use the proper HTML to make it a link. That works, but now the break doesn't work (and you can see the HTML tag for a break being displayed there) and it's all on one line again.

    It's almost like the signature is only allowing the last bit of HTML to work as it should, and anything before that gets displayed as the HTML tags, instead of implementing the HTML tags.

    EDIT: BTW, this didn't start happening until I went into My Settings to look at and change something totally different (threading). My sig was fine before then (it was what it had been before the new forum re-design). So, editing of anything in the My Settings is what screwed up my sig.

    Anyone have any suggestions? Or is this a bug?


    ~~Bonnie Berent DeWitt [C# MVP] <br/> http://geek-goddess-bonnie.blogspot.com



    • Edited by BonnieBMVP Saturday, July 6, 2013 4:52 PM
    Saturday, July 6, 2013 4:46 PM

Answers

  • Trying what you explained, I went into MySettings and simply hit [submit].

    Then I composed and submitted a test post, and my animated image signature was trashed.  Raw html.

    I had to go back into MySettings to fix it.  Luckily, re-editing it worked.


    Viewing this present page's html, I saw what your sig looked like there, and got a hunch how to fix it.

    In mine below (originally only the <img /> element), I appended a link, but nested both lines in paragraphs <p></p> instead of trying to CRLF them with a <br>.

    See?  That worked.



    panhandler image link


    Saturday, July 6, 2013 10:26 PM

All replies

  • Trying what you explained, I went into MySettings and simply hit [submit].

    Then I composed and submitted a test post, and my animated image signature was trashed.  Raw html.

    I had to go back into MySettings to fix it.  Luckily, re-editing it worked.


    Viewing this present page's html, I saw what your sig looked like there, and got a hunch how to fix it.

    In mine below (originally only the <img /> element), I appended a link, but nested both lines in paragraphs <p></p> instead of trying to CRLF them with a <br>.

    See?  That worked.



    panhandler image link


    Saturday, July 6, 2013 10:26 PM
  • I was going to try your paragraph suggestion instead of the break, but noticed something peculiar when I went to edit it. There were some extraneous characters surrounding my break tag. So, I removed them. Now, let's see if it worked:

    EDIT: hahaha, no it didn't! I'll try the paragraph next ...


    ~~Bonnie Berent DeWitt [C# MVP] lt;br/gt; lt;a href=quot;http://geek-goddess-bonnie.blogspot.com quot;gt;http://geek-goddess-bonnie.blogspot.com lt;/agt;


    • Edited by BonnieBMVP Saturday, July 6, 2013 10:42 PM because
    Saturday, July 6, 2013 10:40 PM
  • OK, now I've got the paragraph tag. Keeping my fingers crossed ...

    Arrgghhh!!!


    ~~Bonnie Berent DeWitt [C# MVP] lt;pgt; lt;a href=quot;http://geek-goddess-bonnie.blogspot.com quot;gt;http://geek-goddess-bonnie.blogspot.com lt;/agt;lt;/pgt;


    • Edited by BonnieBMVP Saturday, July 6, 2013 10:50 PM because
    Saturday, July 6, 2013 10:44 PM
  • One more time ....

    OK, this is good enough (I'd prefer a break instead of a paragraph, but at least it looks better than all on one line. Thanks for your suggestion, Handy!


    ~~Bonnie Berent DeWitt [C# MVP]

    http://geek-goddess-bonnie.blogspot.com


    • Edited by BonnieBMVP Saturday, July 6, 2013 10:48 PM because
    Saturday, July 6, 2013 10:46 PM
  • Definitely will not ever do that again!!!!  ;0)

    ~~Bonnie Berent DeWitt [C# MVP]

    http://geek-goddess-bonnie.blogspot.com

    Saturday, July 6, 2013 10:54 PM
  • I'll never hit submit in my settings Lol
    and <br> rocks me.

    Visual Studio Cloud Services
    http://www.microsoft.com

    Tuesday, August 20, 2013 3:36 AM
  • All replies have been deleted, so this thread now lacks context. What was the problem and solution, can you briefly explain?

    Thanks.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog


    My TechNet articles

    Monday, September 9, 2013 6:05 PM
    Moderator
  • All replies have been deleted, so this thread now lacks context. What was the problem and solution, can you briefly explain?

    Thanks.


    From what I remember, this issue is about how going into My Settings and making a change breaks your signature if you don't fix the HTML each time.

    EDIT: The answer from Handy Michaelson is still up there, just in tiny text. Here's a larger version:

    Trying what you explained, I went into MySettings and simply hit [submit].

    Then I composed and submitted a test post, and my animated image signature was trashed.  Raw html.

    I had to go back into MySettings to fix it.  Luckily, re-editing it worked.

    Viewing this present page's html, I saw what your sig looked like there, and got a hunch how to fix it.

    In mine below (originally only the <img /> element), I appended a link, but nested both lines in paragraphs <p></p> instead of trying to CRLF them with a <br>.

    See?  That worked.


    Don't retire TechNet! - (Maybe there's still a chance for hope, over 11,610+ strong and growing)




    Monday, September 9, 2013 6:12 PM
    Moderator
  • Yeah, thanks for jumping in, Mike ... that was pretty much what this thread was about and how to resolve it.

    It's interesting though that some of the replies have been deleted and that Handy's is in teeny, tiny text. I wonder why?


    ~~Bonnie Berent DeWitt [C# MVP]

    http://geek-goddess-bonnie.blogspot.com

    Monday, September 9, 2013 6:27 PM
  • BTW, funny, but in Google Chrome I don't see text at all. It all looks like --- in Handy's response. I even tried increasing the font using Ctrl+ several times but nothing happened.

    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog


    My TechNet articles

    Monday, September 9, 2013 6:30 PM
    Moderator
  • BTW, funny, but in Google Chrome I don't see text at all. It all looks like --- in Handy's response. I even tried increasing the font using Ctrl+ several times but nothing happened.
    Yeah, same in FF. I got around it by copying the text into notepad.

    Don't retire TechNet! - (Maybe there's still a chance for hope, over 11,610+ strong and growing)



    Monday, September 9, 2013 6:33 PM
    Moderator
  • Yeah, thanks for jumping in, Mike ... that was pretty much what this thread was about and how to resolve it.

    It's interesting though that some of the replies have been deleted and that Handy's is in teeny, tiny text. I wonder why?


    Based on what I can see through the XML view, Handy deleted most of his posts and then set his answer to be displayed in 1px font size. No idea if that's actually correct though.

    Don't retire TechNet! - (Maybe there's still a chance for hope, over 11,610+ strong and growing)



    Monday, September 9, 2013 6:43 PM
    Moderator
  • Old thread, I know. But, I just hosed my sig again and I had forgotten how to fix it. I had to look up my old threads to find this one to jog my memory on how to fix it. And then, of course, I had to test the fix somewhere.  ;)

    ~~Bonnie DeWitt [C# MVP]

    http://geek-goddess-bonnie.blogspot.com

    Friday, July 18, 2014 3:28 PM
  • I really, really, really wish they'd fix My Settings and its insatiable hunger for HTML.

    There's no reason for it to mangle the tags....

    Side bit of info - I usually just create threads in the sandbox for testing after I need to rebuild my signature.

    http://social.technet.microsoft.com/Forums/en-us/home?forum=tnsandbox&filter=alltypes&sort=lastpostdesc


    Don't retire TechNet! - (Don't give up yet - 12,950+ strong and growing)

    Friday, July 18, 2014 3:45 PM
    Moderator