locked
Field 'VATNum' in table 'CompanyInfo' has not been explicitly selected. RRS feed

  • Question

  • Dear All,

    I am getting the below error when I am trying to Post a Sales order.

    I have AX 2012 r2 Kernel version : 6.2.1000.4051 and Application version : 6.2.158.0

    The error details are as below.

    Stack trace: Field 'VATNum' in table 'CompanyInfo' has not been explicitly selected.

    Stack trace

    (S)\Classes\SalesInvoiceDP\insertIntoSalesInvoiceHeaderFooterTmp - line 47 (S)\Classes\SalesInvoiceDP\insertInvoiceHeaderInformation - line 16 (S)\Classes\SalesInvoiceDPBase\createData - line 17 (S)\Classes\SalesInvoiceJournalPostBase\createReportData - line 38 (S)\Classes\FormletterService\run - line 106 (S)\Classes\FormletterService\postSalesOrderInvoice - line 14 (S)\Classes\DictClass\callObject (S)\Classes\SysOperationServiceController\runOperation - line 93 (S)\Classes\SysOperationServiceController\run - line 27 (S)\Classes\FormLetterServiceController\run - line 3 (S)\Classes\SalesFormLetter\run - line 72 (S)\Classes\SalesFormLetter_Invoice\run - line 6 (S)\Classes\SalesFormLetter\runServer - line 9 (C)\Classes\SalesFormLetter\run (C)\Classes\SalesFormLetter_Invoice\run (C)\Classes\SalesFormLetter\main (C)\Classes\FormFunctionButtonControl\Clicked

    I checked in CompanyInfo Table from table browser in AX, and found that the vatnum field value is showing "Unretired".

    How can I update this field value. I am not able to edit this field from table browser nor select it from SQL.

    I Google the issues and I found the below link and I tried but nothing worked out.

    https://community.dynamics.com/ax/f/33/p/106091/208207.aspx#208207


    Please help in solving this issue.


    Hope for kind assistance and support.


    Thanks & Regards.

     


    Thursday, April 17, 2014 6:40 AM

Answers