locked
demigrator errors RRS feed

  • Question

  • Hello,

    I did a server reinstall and now I am getting errors at startup.
    Error reporting pops up with the following crashes:

    whsarch.exe
    demigrator.exe

    and event log have the following errors:

    Process demigrator failed at d:\wssg_src\whs_pp1\qhs\src\storage\de\deutil\volumeinfo.cpp(218).
    Unexpected error 0x2 from GetVolumeNameForMountPoint: The system cannot find the file specified.

    any ideas whats the problem?

    many thanks
    Bill.
    Wednesday, November 4, 2009 6:56 PM

All replies

  • Hi Bill,
    for me it seems, that the system could not find all disks, which have been part of the storage pool before.
    Did you apply the mass storage drivers during the blue screen part of setup (pressing F6 and provide the drivers on a floppy drive)?
    Are all disks listed in the console?
    Could also be, that a disk has a corrupted file system or whatever - what exactly was the reason for the server reinstall?
    (A server reinstall will not be able to fix problems, which are not OS specific.)

    Best greetings from Germany
    Olaf
    Thursday, November 5, 2009 7:44 AM
    Moderator
  • Hi Olaf,

    Thanks for assisting.
    I had a USB disk before reinstall that I tried to removed from the storage pool. WHS transfered all the data to other HD's but the disk itself cannot be removed (I can't remember what was the error), so I just unplugged it.

    After the reinstallation, this disk was in the storage pool as missing. 
    I allready tried and connected it again, and now all my drives are there.

    But the error is still there. 

    You think the problem is there because I reinstalled without this drive ?

    Sould I try another reinstall with this drive connected ?
     
    many thanks
    Bill.
    Thursday, November 5, 2009 9:26 AM
  • I would recommend to attempt another server reinstall with all drives connected, which did belong to the original configuration.

    You also can try, if it is possible to remove the disk from the registry on your server by exporting and deleting the for this disk appropriate subkeys in
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Home Server\Storage Manager\Disks
    and in
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Home Server\Storage Manager\Volumes
    You will see the missing volume locally on the server by trying to open the subfolders in c:\fs.
    This would normally work, but in a server reinstall context it can be difficult.
    After doing this reboot.
    Best greetings from Germany
    Olaf
    Thursday, November 5, 2009 12:55 PM
    Moderator