locked
Cannot connect using Remote Desktop RRS feed

  • Question

  • I thought I'd be able to find the answer to this one without having to resort to asking questions, but have not yet been able to get a solid answer.

    I have...

    1. installed Windows Home Server,
    2. assigned a static IP address to the server of 192.168.0.100,
    3. placed it in my workgroup,
    4. forwarded 7 ports to the server (without forwarding all 7 ports, I CANNOT connect to the server using ANYTHING),
    5. set up my Connector software on the client desktop, 
    6. created an account on the server using the same logon and password as is used on the client,
    7. turned on Remote Access in the Settings area of the Server Console for said account,
    8. manually configured my Motorola SBG900 (not UPnP) Note step 4 above,
    9. Set up my Live domain

    I can connect to the Server using the Console

    I can connect to the Server using the https://domainname.homeserver.com URL

    I CANNOT connect using Remote Desktop. When I enter my connection information into the RD logon dialog and click on connect, I get an error message stating 'To log on to this remote computer, you must be granted the Allow log on through Terminal Services right. By default, members of the Remote Desktop Users group have this right. If you are not a member of the Remote Desktop Users group or another group that has this right, or if the Remote Desktop Users group does not have this right, you must be granted this right manually.'

    Per step 7 above, my created User Account was allowed Remote Desktop rights, so should have the TS right, by default. Anyone have this same issue or have a way to work around WHS pig-headed refusal to allow me to log on? BTW, this is my third installation in less than one week due to a couple of 'undocumented features' in the software and, the first two times, Remote Desktop worked like a champ until I hit this brick wall.

    Friday, January 30, 2009 5:47 AM

Answers

  • I got this one fixed.

    1. Log onto the Server as Admin
    2. Click on Start
    3. Right-click on My Computer
    4. Click on Properties
    5. Click on Remote tab
    6. Click on Select Remote Users
    7. Highlight the offending account and click on Remove
    8. Click on Add
    9. Type in the account name and click on Check Name
    10. If account name is found on Server, click on OK
    11. Click on OK
    12. Click on OK
    13. Log off the server
    14. Remote in to the server from the client computer
    • Marked as answer by Bruce Darby Friday, January 30, 2009 6:52 AM
    Friday, January 30, 2009 6:52 AM

All replies

  • I got this one fixed.

    1. Log onto the Server as Admin
    2. Click on Start
    3. Right-click on My Computer
    4. Click on Properties
    5. Click on Remote tab
    6. Click on Select Remote Users
    7. Highlight the offending account and click on Remove
    8. Click on Add
    9. Type in the account name and click on Check Name
    10. If account name is found on Server, click on OK
    11. Click on OK
    12. Click on OK
    13. Log off the server
    14. Remote in to the server from the client computer
    • Marked as answer by Bruce Darby Friday, January 30, 2009 6:52 AM
    Friday, January 30, 2009 6:52 AM
  • Windows Home Server Remote Desktop access is permitted only for the built in Administrator account with the console password for administrative purposes. All other usages of Remote Desktop on the server are a violation of the EULA.

    Best greetings from Germany
    Olaf

    Friday, January 30, 2009 7:06 AM
    Moderator
  • To add, why do you need to log in to the WHS as a standard/limited user anyway? WHS is designed to be administered via the WHS console. Only in isolated cases do you really need to log in via Remote Desktop as the WHS administrator for maintenance or other purposes.
    MS-MVP Windows Desktop Experience, "When all else fails, read the instructions"
    Friday, January 30, 2009 12:24 PM
  • Was not attempting to log-in to the Server as a User. Was trying to log-in to the server as the Admin and was receiving this error. I understand that one may ASSUME they know what a person is trying to do, but I do try not to do so because I am very often incorrect in my assumptions. Thanks for the input.
    Friday, January 30, 2009 1:57 PM
  • Hi Bruce,

    the symptoms and actions you described, was pointing to any account but the "Administrator" account. So based on this the assumption could have been correct (or you could have added another user account to the local Administrators group on the server, which gets also rejected by WHS default).

    Sometimes its hard to hit the nail on the head, as poster and as answerer.

    Best greetings from Germany
    Olaf

    Friday, January 30, 2009 3:07 PM
    Moderator
  • Bruce, by design the only "admin" account on Windows Home Server is the built-in account "Administrator". If you haven't made any changes to permissions, only that account should be able to log in to your server using Remote Desktop. Were you using that account or another? 

    Also, please be aware that if you were using another account which you had added to the Administrators group yourself accounts in that group are prohibited by Windows Home Server from logging in to the Remote Access web site.

    I'm not on the WHS team, I just post a lot. :)
    Friday, January 30, 2009 3:50 PM
    Moderator
  • Olaf Engelke said:

    Hi Bruce,

    the symptoms and actions you described, was pointing to any account but the "Administrator" account. So based on this the assumption could have been correct (or you could have added another user account to the local Administrators group on the server, which gets also rejected by WHS default).

    Sometimes its hard to hit the nail on the head, as poster and as answerer.

    Best greetings from Germany
    Olaf



    Understood, Olaf. And I wasn't really trying to be antagonistic, I was just putting it out there exactly as it should be. I hadn't tried to create an Admin account on the server. My client account was simply a user account set up for standard User settings and I was trying to Remote into the Server as Administrator with the account that was created on the server during the installation. Not sure what got crossed, but until I deleted and recreated the User account, I could not Remote into the server using 'any' account. Again, thanks for the input.
    Saturday, January 31, 2009 4:02 AM
  • Ken Warren said:

    Bruce, by design the only "admin" account on Windows Home Server is the built-in account "Administrator". If you haven't made any changes to permissions, only that account should be able to log in to your server using Remote Desktop. Were you using that account or another? 


    Also, please be aware that if you were using another account which you had added to the Administrators group yourself accounts in that group are prohibited by Windows Home Server from logging in to the Remote Access web site.

    I'm not on the WHS team, I just post a lot. :)



    Ken,

    I was just using the 'built-in' Admin account. I'll be honest with you, I am NOT a networking kind of fellow, so I wasn't trying to 'geek' the system. I simply loaded the software and created the user account, then got the server set up for Remote Access and tried to log on as the Admin when the program tossed out that message. I looked around a LOT to try to find out what might possibly be causing the issue. A short time after posting my issue, I got a wild hair and deleted the User acct and recreated it and everything started working the way it should.
    Saturday, January 31, 2009 4:06 AM