MissingMethodException RRS feed

  • Question

  • I think I get the following error after installing and uninstalling MSCRM OUTLOOK Toolbar. This is really critical. I cannot open any forms that have currency field.

    Could anybody share some light on this problem. Thanks!
    Event Type: Warning
    Event Source: ASP.NET 2.0.50727.0
    Event Category: Web Event 
    Event ID: 1309
    Date: 18/11/2009
    Time: 6:49:17 a.m.
    User: N/A
    Computer: SERVER
    Event code: 3005 
    Event message: An unhandled exception has occurred. 
    Event time: 11/18/2009 6:49:17 AM 
    Event time (UTC): 11/17/2009 6:49:17 PM 
    Event ID: f3311df4301144f2b1c0503537af76c8 
    Event sequence: 610 
    Event occurrence: 9 
    Event detail code: 0 
    Application information: 
        Application domain: /LM/W3SVC/6/ROOT-1-129029261979410578 
        Trust level: Full 
        Application Virtual Path: / 
        Application Path: C:\Program Files\Microsoft CRM\CRMWeb\ 
        Machine name: SERVER 
    Process information: 
        Process ID: 1760 
        Process name: w3wp.exe 
    Exception information: 
        Exception type: MissingMethodException 
        Exception message: Method not found: 'System.String Microsoft.Crm.Formatting.CrmFormatter.GetCurrencySymbolForAttribute(Microsoft.Crm.Metadata.MoneyAttributeMetadata, System.Guid, Microsoft.Crm.IOrganizationContext)'. 
    Request information: 
        Request URL: http://server:5555/SalesTrainingAssessmentRecruit/sfa/conts/edit.aspx?id={C05ADD64-9AEA-DC11-A61F-0017A40DA92E} 
        Request path: /SalesTrainingAssessmentRecruit/sfa/conts/edit.aspx 
        User host address: 
        User: SALES-STAR\Administrator 
        Is authenticated: True 
        Authentication Type: Negotiate 
        Thread account name: NT AUTHORITY\NETWORK SERVICE 
    Thread information: 
        Thread ID: 1 
        Thread account name: NT AUTHORITY\NETWORK SERVICE 
        Is impersonating: False 
        Stack trace:    at Microsoft.Crm.Application.Components.Sdk.FormControls.Web.MoneyControl.set_Metadata(AttributeMetadata value)
       at Microsoft.Crm.Application.ControlActivator.CreateControl(ControlDescriptor controlDescriptor, String clientId)
       at Microsoft.Crm.Application.Forms.CrudForm.BuildFormModel(FormDescriptor formDescriptor)
       at Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity entity, String formType)
       at Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity entity)
       at Microsoft.Crm.Web.SFA.ContactDetailPage.ConfigureForm()
       at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    Custom event details: 

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


    Tuesday, November 17, 2009 7:17 PM


  • Hi Guys,

    I have now finally got this problem solved.

    All I have done is to restore the original DLLs in GAC.

    Thanks you all for the help.

    • Marked as answer by Daniel Z Wednesday, November 18, 2009 2:00 AM
    Wednesday, November 18, 2009 2:00 AM

All replies

  • Can you open the forms with currency fields from the Web client? If not, have you recently deleted any money fields from any of your entities?
    Best Regards, Donna
    Tuesday, November 17, 2009 7:42 PM
  • Tuesday, November 17, 2009 7:47 PM
  • Hi Donna,

    I cannot open forms with money fields in it. No money fields have been deleted or changed or added.

    I noticed that the DLLs in GAC (C:\windows\assembly folder) have been updated to 4.0.7333.2138 (I think this is rollup 7) after installing. I guess if I can roll back to the original status which is 4.0.7333.3, then it may fix this problem.

    I have done the followings:
    1. I have tried to repair MSCRM SERVER, but it did not restore the original dlls. 
    2. I have also tried GACUTIL /U "Assembly name", but it cannot find the assembly. 
    3. Tried to uninstall in Windows Explore by right clicking on the assembly and choosing uninstall, it prompts error saying "Assembly Microsoft.Crm.Platform.Sdk could not be uninstalled because it is required by other applications"

    Please help!!!



    Tuesday, November 17, 2009 9:05 PM
  • Hi ckeller,

    I have looked at the KB2005759. This is the same error, but my MSCRM website files haven't moved to a different location. I have checked the registry and IIS, they all point to the right MSCRM website location.

    • Proposed as answer by Jan Aagaard 75 Friday, January 7, 2011 9:20 AM
    Tuesday, November 17, 2009 9:15 PM
  • Hi Guys,

    I have now finally got this problem solved.

    All I have done is to restore the original DLLs in GAC.

    Thanks you all for the help.

    • Marked as answer by Daniel Z Wednesday, November 18, 2009 2:00 AM
    Wednesday, November 18, 2009 2:00 AM
  • Daniel,

    Can you give me some directions on how to "restore the original DLL"s in GAC".

    Thank you!

    Thursday, February 4, 2010 3:33 PM
  • Find the different DLLs in the GAC folder. Make sure you have the backup files for these. And then you can just drag the DLLs you want to replace with into the GAC folder.

    Tuesday, February 9, 2010 12:53 AM
  • That is a solution but one which means you sacrifice all rollups.

    I belive this is caused when you install the Outlook client with a later version than the server.  Regardless, the way I resolved this was to do the following:

    First I verified the proper location of the software as indicated in this KB article. http://support.microsoft.com/kb/2005759

    THen I applied the UR 7 for all components.  Outlook, Server etc.

    This solved my problem without sacrifcing a roll back to CRM RTM.

    • Proposed as answer by Mike Olsson Sunday, June 20, 2010 4:44 PM
    Sunday, June 20, 2010 4:40 PM