none
Converting the source - Strange issue with WLW

    Question

  • Ok, this is weird. I have a wlw plugin which should work just fine but it does not. Here is the plugin:

    http://highlightme.codeplex.com/

    Here is the main code:

    http://highlightme.codeplex.com/SourceControl/changeset/view/d3ae4c8218de#TugberkUg.WLW.HighlightMe%2fWLWPlugin.cs

    The issue I am having is this:

    For example, let say we would like to highlight a code and according the plugin code, it should output it as below:

    <div class="code-wrapper border-shadow-1">
    <div style="BACKGROUND-COLOR: white; COLOR: black"><pre><span style="color: blue">&lt;</span><span style="color: #a31515">p</span><span style="color: blue">&gt;</span>
          This is the code!
    <span style="color: blue">&lt;/</span><span style="color: #a31515">p</span><span style="color: blue">&gt;</span>
    </pre></div></div>
    


    But, what I am getting instead is this:

    <d  IV class="code-wrapper border-shadow-1">
    <d  IV style="BACKGROUND-COLOR: white; COLOR: black"><pre><span style="color: blue">&lt;</span><span style="color: #a31515">p</span><span style="color: blue">&gt;</span>
          This is the code!
    <span style="color: blue">&lt;/</span><span style="color: #a31515">p</span><span style="color: blue">&gt;</span>
    </pre></DIV></DIV>
    
    

    No idea what is causing this. Can you help?


    Tugberk Ugurlu
    Wednesday, January 18, 2012 8:18 AM

All replies

  • It turns out that it is not just <div> tag, also same is happening for <li> tag and I am generating that <li> tag with WLW tools, not a separate plugin.

    Is there a way to solve this issue?


    Tugberk Ugurlu
    Wednesday, January 18, 2012 10:11 AM