CRM 4.0 Installation Error - Unable to verify that SQL Server Agent RRS feed

  • Question

  • I'm running into the following error trying to install CRM 4.0 on a new server.  I have successfully installed CRM 4.0 a dozen times over the past and have never run into this issue.  The CRM and SQL Server 2005 instances are being installed on the same server.

    19:51:32|Warning| Check SqlServerAgentValidator : Warning: Setup was unable to verify that SQL Server Agent (SqlAgent$qacrm) was running.
    19:51:32|   Info| Check SqlInstanceNameValidator: Success
    19:51:32|  Error| Check CrmSqlDomainValidator : Failure: The SQL Server '{0}' is unavailable.
    19:51:32|   Info| Check SqlServerValidator: Success
    19:51:32|   Info| Check SysAdminValidator: Success
    19:51:42|   Info| Check WordBreakerValidator: Success
    19:51:42|   Info| Check FullTextInstalledValidator: Success
    19:51:42|  Error| Check FullTextRunningValidator : Failure: Cannot open Service Control Manager on computer 'qa-sqlcrm'. This operation might require other privileges.
    Access is denied

    I have verified that the SQL Agent is running and that it is named "SqlAgent$qacrm" as a registry key.  Also, Full Text is also installed and running.

    The account I am installing CRM with is a sysadmin to the SQL Server.

    Any assistance with this issue would be greatly appreciated.


    Thursday, June 7, 2012 1:16 AM

All replies

  • The privileges required to interrogate the Service Control Manager (which is how the CRM Setup determines the status of the SQL Server Agent Service) is unrelated to your installation account's SQL Server privileges.

    Is the installation User a Local (SQL Server) Machine Admin?

    --pogo (pat) @ pogo69.wordpress.com

    • Edited by pogo69 Thursday, June 7, 2012 4:26 AM
    Thursday, June 7, 2012 4:25 AM
  • Yes, the installation user is in the Local Administrators group on the install machine which is the same as the SQL Server.

    I was able to get through the installation this morning after using the Hostname (USVCLTQACRM01) instead of a CNAME (qa-sqlcrm) for the database.  I had to run the following SQL Server statements to roll back changes during my implementation:

    sp_dropserver 'qa-sqlcrm\qacrm'

    sp_addserver 'USVCLTQACRM01\QACRM', local

    Now everything appears to be working.  I'm not sure why this was working in our Development environment but not in our new QA environment.

    Thanks for the reply.

    Thursday, June 7, 2012 2:14 PM