none
Job Manager crashes on launch, File Not Found RRS feed

  • Question

  • Hi,

    I'm running a Microsoft HPC Pack 2012R2 Update 2 cluster, all on Windows Server 2012R2 (8x Compute nodes, 1x Head node, 1x RDS access node). I'm trying to give cluster users the ability to run the standard "Job Manager" client from an RDS access node where they also run their client applications that submit jobs to the head node. This will let them manage their own jobs, see progress and see how busy the cluster is.

    Job Manager works fine on the head node, but on the RDS access node it just crashes on launch before even showing a GUI. Logs show a "File Not Found" Exception, but no further information. The same machine can submit jobs fine using MATLAB, so I think the Client Tools install is solid.

    This seems like a very simple setup, so I have to imagine others have come across this problem. Any ideas?

    Cheers,

    Mark
    Wednesday, December 16, 2015 11:44 AM

Answers

  • First, check whether you installed with:

    1. the HPC client redistributable pack (http://www.microsoft.com/en-us/download/details.aspx?id=36044) or

    2. the full client pack (You can launch it through \\<headnodename>\reminst\setup.exe)

    Second, where did you get the exception? Can you help identify what file is missing? If you can, you can enable the fusion log to check: here is some example: http://stackoverflow.com/questions/255669/how-to-enable-assembly-bind-failure-logging-fusion-in-net


    Qiufang Shi

    • Marked as answer by SparkyW Tuesday, January 12, 2016 11:36 PM
    Thursday, December 17, 2015 2:39 AM

All replies

  • First, check whether you installed with:

    1. the HPC client redistributable pack (http://www.microsoft.com/en-us/download/details.aspx?id=36044) or

    2. the full client pack (You can launch it through \\<headnodename>\reminst\setup.exe)

    Second, where did you get the exception? Can you help identify what file is missing? If you can, you can enable the fusion log to check: here is some example: http://stackoverflow.com/questions/255669/how-to-enable-assembly-bind-failure-logging-fusion-in-net


    Qiufang Shi

    • Marked as answer by SparkyW Tuesday, January 12, 2016 11:36 PM
    Thursday, December 17, 2015 2:39 AM
  • Thank you for the pointer in the right direction, I revisited the install process and realised I had run the client .msi, rather than the full install (setup.exe). This meant I was missing the various other prerequisite component installers the Job Manager tool needs.

    Once these were installed by the setup.exe wizard everything worked correctly. Not sure why I didn't do that in the first place!

    Thanks Again, Mark

    Tuesday, January 12, 2016 11:36 PM