locked
Urgent help needed - CRM 2011crashed RRS feed

  • Question

  • Windows 2008R2 (64bit)  hosting CRM2011 & ADFS

    Windows 2008R2 (64Bit) hosting SQL2008R2

    A disgruntled ex employee has played with the crm setting and now no one can log in.

    I can log onto the windows Server and get into CRM, however no reports can be run, all come up with the dreaded RSProceddAborted.

    When trying to log in from external I get the following message

    An error has occurred.

    Try this action again. If the problem continues,
    check the Microsoft Dynamics CRM Community for solutions or contact your
    organization's Microsoft Dynamics CRM Administrator. Finally, you can contact
    Microsoft Support

    I have restored the originationCRM_MSCRM database from last nights backup but that has had no effect. It also appears that the employee had not been creating the backups either.

    Is there any way of fixing this. I am not an expert in CRM, but there is no one else to deal with this. I have full domain access across all servers

    any help would be greatly appreciated


    Dont ask me .. i dont know

    Thursday, September 26, 2013 5:45 PM

Answers

  • All sorted. Problem was firewall related

    Thanks for the help, I really must remember to look in the logs first !


    Dont ask me .. i dont know

    • Marked as answer by Pete Newman Wednesday, October 2, 2013 8:16 PM
    Wednesday, October 2, 2013 8:16 PM

All replies

  • If the problem is solely with reports, then the reporting services log files may help diagnose the problem, and help you fix it.

    However, if you think that an ex-employee has maliciously caused damage, then it's easier and safer to go to a known correct configuration, rather than try to work out what has changed, and undo it. I'd try:

    1. Run a Repair installation of CRM. This will leave the organisation database intact, but will rebuld files and registry keys, and this may be sufficient to get a working system
    2. If the previous step doesn't work, the safest option is to reinstall CRM (which will recreate the MSCRM_Config database), then import the current organisation database. This should get all the infrastructure correctly configured
    3. If you do step 2, and are missing data, then you may have to restore a previous backup of the organisation database, then reimport it

    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Thursday, September 26, 2013 7:51 PM
    Moderator
  • HI,

    Thank you for the advice,

    I will go back in overnight and try your suggestions


    Dont ask me .. i dont know

    Thursday, September 26, 2013 8:32 PM
  • HI,

    After several attempts, i have managed the following;

    1. set up a clean CRM2011

    2. Imported a good backup of old CRM2011

    3. installed and configured ADFS

    So far so good. I can now import data from our SQLCLR project, however one thing I can not get working is the reports. I keep getting a rsProcessingAborted when trying to run a report. I have looked at several threads but have not managed to get this fixed yet.

    Crm is running on ServerA  SQL is on ServerB

    Access to crm is https://mycrm.domain.co.uk:port

    Crm App pool is Networkservices

    Reporting services is running on account domain\ReportProcessor

    I see there is a lot of talk about SETSPN, but ti be honest, Im lost as to which server to apply this to and what details should be entered.

    I would appreciate any help in resolving this and i am at a standstill


    Dont ask me .. i dont know

    Wednesday, October 2, 2013 3:12 PM
  • Good job on the restore.  It shows a strong ability.

    Now, the Service Principle Names are in the LDAP database.

    Open a command prompt on your application server with elevated permissions.

    Run SETSPN /? for the options but you can use SetSPN -L and then the name of a server or site to see if the attributes are in the LDAP database.

    You can use SETSPN to set them from the command prompt, but I would also encourage you to run adsiedit on a DC to view and understand the need for the Service Principle Names.


    Curtis J Spanburgh

    Wednesday, October 2, 2013 4:19 PM
    Moderator
  • I have done that and i can see the url address that is used for the crm server ... but to be honest, I really don't know what Im meant to be looking for


    Dont ask me .. i dont know

    Wednesday, October 2, 2013 4:31 PM
  • Hi,

    Would you please check the Log file generated at location SQL installed drive\Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\LogFiles and post the error?

    Thanks!

    Wednesday, October 2, 2013 4:46 PM
  • Hi,

    Error from Log

    erver stack trace:
       at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
       at System.ServiceModel.Channels.BufferedConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
       at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)
       at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Ch
    webserver!ReportServer_0-4!8a8!10/02/2013-18:23:38:: e ERROR: Reporting Services error Microsoft.ReportingServices.Diagnostics.Utilities.RSException: An error has occurred during report processing. ---> Microsoft.ReportingServices.ReportProcessing.ProcessingAbortedException: An error has occurred during report processing. ---> Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: Query execution failed for dataset 'ClientStats'. ---> Microsoft.Crm.Reporting.DataExtensionShim.Common.ReportExecutionException:
    Microsoft.Crm.CrmException: An unexpected error occurred.
    System.ServiceModel.EndpointNotFoundException: Could not connect to net.tcp://cbj/CrmSandboxSdkListener-w3wp. The connection attempt lasted for a time span of 00:00:42.0743888. TCP error code 10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 10.10.1.207:808.
    System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 10.10.1.207:808 ---> Microsoft.Crm.Reporting.DataExtensionShim.Common.ReportExecutionException: An unexpected error occurred. ---> Microsoft.Crm.Reporting.DataExtensionShim.Common.ReportExecutionException: Could not connect to net.tcp://cbj/CrmSandboxSdkListener-w3wp. The connection attempt lasted for a time span of 00:00:42.0743888. TCP error code 10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 10.10.1.207:808.  ---> Microsoft.Crm.Reporting.DataExtensionShim.Common.ReportExecutionException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 10.10.1.207:808
       at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
       at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
       at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
       at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
       at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
       at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
       --- End of inner exception stack trace ---


    Dont ask me .. i dont know

    Wednesday, October 2, 2013 5:30 PM
  • All sorted. Problem was firewall related

    Thanks for the help, I really must remember to look in the logs first !


    Dont ask me .. i dont know

    • Marked as answer by Pete Newman Wednesday, October 2, 2013 8:16 PM
    Wednesday, October 2, 2013 8:16 PM