locked
Hyper V stabilty Issue RRS feed

  • Question

  • Hello all,

    I am having major stability issue with my WHS 2011 installation. I am running WHS on Hyper VR2. The physical hardware has 2 quad core zenon 5405's, 8 gigs of ram and three drives the first two are in a RAID 1 the third drive is just a single drive.

    The issue I have is after WHS is up and running for a short time maybe an hour or two it will lock up, the web site gives you a 503 error and you can not remote in or connect (from HyperV console) to the VM. Only option is restart the VM. is there anything I can do to stop this from happening?

    Monday, October 15, 2012 10:04 PM

All replies

  • Hi,

    There are three methods here to disable the auto lock on WHS:

    Method 1:
    =======
    1. Right click on desktop, select Personalization;
    2. Select Screen Saver;
    3. Clear the check box "On resume, display logon screen";

    Method 2:
    =======
    1. Open registry in run;
    2. Navigate to HKCU\ControlPanel\Desktop\ScreenSaveActive, set the value to 0;

    Note: Please backup the registry before modify the registry.

    Method 3:
    =======
    1. Type gpedit.msc in run;
    2. Navigate to User Configuration > Administrative Templates > Control Panel > Display > Password protect the screen saver;
    3. Double click on “Password protect the screen saver”;
    4. Select Disable;

    HTH.

    Regards,

    James


    James Xiong

    TechNet Community Support

    Tuesday, October 16, 2012 7:16 AM
  • Is there anyting in the event log of the host?

    Did you disable any Power Save settings in the properties of included physical and virtual network adapters?

    Best greetings from Germany
    Olaf

    Tuesday, October 16, 2012 1:18 PM
  • Thank you both for the reply. I will try disabling the auto lock tonight when I get home and see if that helps.

    I will also check the power settings on the Host os.

    I do not see anything unusual in the host os event log. I do see a strange error in the VM instace log file about the desktop expierence manger offhand I believe that it is an error 9000. I will check tonight.

    Tuesday, October 16, 2012 2:40 PM
  • James,

    I have checked the setting you noted. and made the appropriate changes.

    See if they help any.

    Olaf,

    There are no power save settings that would affect this that I can see. In the VM event log every time this issue occurs it appears that I get erro 9009 Desktop Window Manager: The desktop window manager has exitied with code (0x40010004).

    Tuesday, October 16, 2012 9:18 PM
  • Another update, This does not appear to have fixed the issue.
    Wednesday, October 17, 2012 2:08 AM
  • There are no power save settings that would affect this that I can see. In the VM event log every time this issue occurs it appears that I get erro 9009 Desktop Window Manager: The desktop window manager has exitied with code (0x40010004).

    • Open Network and Sharing Center on both host and guest OS.
    • In left frame click Change adapter settings.
    • Right click each adapter, select Properties, click Configure and check, if there is a Power management tab.
    • If so, on this tab uncheck the box Allow the computer to turn of this device to save power.

    Best greetings from Germany
    Olaf


    • Edited by Olaf Engelke Wednesday, October 17, 2012 8:22 AM
    Wednesday, October 17, 2012 8:21 AM
  • I have disabled both of the power management options from the device manager of the host 2008 R2 installation. There is no power management tab for the WHS 2011 VM.

    The issue ist still happening.

    Wednesday, October 17, 2012 5:07 PM