Disable Top/Bottom UI Panels in Kiosk Mode RRS feed

  • Question

  • Hello,

    For my WWT Guided Tour, I need to run the end product in Kiosk mode. I got this set up correctly, but in the actual kiosk mode the top and bottom navigation panels are always showing. 

    I simply need to get these two panels to stop showing and am unsure how to go about doing that.



    Tuesday, January 21, 2014 6:15 PM

All replies

  • Hello,

    I want to do the same.

    We want to run WWT in Kiosk Mode in a public museum - currently Users can quit, change settings, or can open the web browser. Thats not brilliant :-(


    Monday, January 27, 2014 3:37 PM
  • The "hardened" Kiosk mode activated by launching WWT with the -kiosk flag is designed for touch-only museum kiosk with no keyboard use, and not for playing tours.

    For a kiosk mode that is tour driven wwt should be launched with the tour as a parameter, with a hardened O/S shell (as your IT configures it) and it should either have an interactive menu and have all paths return that that menu slide, or should loop on itself. Also the settings should have "Full screen tours".

    An interactive mode inside the Kiosk can be achieved with a minimal UI designed as overlays with LCAPI calls to activate properties hosted on a slide with a long timeout, and no end camera position so the user is free to explore.

    If you are not already aware, you can add UI elements to a slide (images, arrows, rectangles, etc.) and hyperlink LCAPI commands, or link them to other slides.

    The LCAPI commands can control almost anything in the UI, so you can make a tour with a custom UI skin to browse WWT in the UI (with some limitations).

    Linking elements to other slides allows non-linear story telling, looping tours, menus, quiz content and other custom navigations structures... all without code.

    Jonathan Fay

    Jonathan Fay

    Wednesday, January 29, 2014 9:53 PM