locked
WHS invisible to WHS RRS feed

  • Question

  • Background:
    I've been running WHS at my house for over a year and a half.  I love it.  I tell everyone about it.  It's awesome.  A couple weeks ago my primary drive failed.  "No worries", I thought, "I'll just buy some newer drives and restore from those awesome backups that WHS makes.  I put in the new primary drive and reinstalled WHS.  I re-installed the connector software on my client PCs and got their backups running again, everything looked great. 

    Warning Sign:
    I noticed that I couldn't use the green icon in the system tray to connect to my home server console from any of my client PCs.  There was some error about the server not being available.  "That's wierd", I thought, "but I'll just have to check it out later."  The backups were running, the PCs could browse the network shares - everything else was working great except for the weird fact that the clients couldn't directly open up the home server console (I'd have to RDP into the server and open the console from there).

    Windows 7:
    I, like many of you, wanted to install W7 just as fast as I could get my grubby little hands on it.  I told myself "this is perfectly safe, because TMP (The Miracle Product - Windows Home Server) will let me image my hard drive, play with Windows 7, and then just flip back to Vista if things got too rough.  So, I did just that.  I did another backup of my laptop, then installed Windows 7.  Yum.  Windows 7.  Tommy Likey. :-)  Everything was going great with Windows 7 until I tried to install the WHS Connector.  It wouldn't install.  Google said that no one else was having much trouble getting the connector to install in Windows 7.  I found one thread where someone had trouble, and I tried what they did (adding the server to the hosts file), but that didn't help. :-(  What now?  Note that I was able to browse the shares on the home server, RDP into the home server, ping the home server - I just couldn't install the connector because it said the home server was unavailable.

    I have a bad feeling about this, Master:
    Well, I thought this might be a good time to turn back to Vista because I had some work to get done and needed to get back to a stable environment.  I put the restore CD into the machine, rebooted and thought I'd be back to vista in two shakes...  Nope.  The Restore CD couldn't find the home server either.  Aak!  Trying to control the growing panic, I thought I'd just mount the latest backup on my other client PC and get the files I needed from there...until I remembered that in order to mount another machine's backup you have to be running the WHS Console on a client - my other client wouldn't start the WHS Console, it said the server was unavailable.  Um - maybe I can just RDP into the server, start the WHS Console, mount the backup and restore the files from the server.  Nope - it has to be done from a client.  This isn't looking good.
    I did some research and found the WHS Connection Troubleshooter.  I ran it, and it found about 6 errors (i'll include them at the bottom of the post).  One of the things it suggested was to work through a troubleshooting document.  I got through most the basic steps OK, but it asked me to test http://<YourServerName>:55000/enrollid/id.aspx and I got an asp.net security exception.

    In some posts I've read, people recommend flattening the server and reinstalling - I'd be happy to do that under normal circumstances, but I really really really need the data in those backups.  I'm hesitant to try the backup WHS backp db script becuase I'm not confident I've found the latest version, and there doesn't seem to be a way to make sure that it'll work without burning any bridges.

    Help!!!

    Any ideas?  I'll post the output of the connection troubleshooter here:

    The Windows Home Server Connector Troubleshooter tests are now complete.
    Potential issues are displayed below. It is important to follow the recommendations to resolve potential Windows Home Server issues.



    The version of the Connector software does not match the version of Windows Home Server
     
    Cannot connect to the server secure internal Web site
     
    UPnP discovery failed
     
    Cannot connect to the server internal Web site (password hint page)
     
    Cannot connect to the server internal Web site (ASPX page)
     
    Name resolution failed


     

    Server Error in '/EnrollId' Application.

    Unable to read the security policy file for trust level 'WSS_Minimal'.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Web.HttpException: Unable to read the security policy file for trust level 'WSS_Minimal'.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [HttpException (0x80004005): Unable to read the security policy file for trust level 'WSS_Minimal'.] System.Web.HttpRuntime.SetTrustLevel(TrustSection trustSection, SecurityPolicySection securityPolicySection) +467 System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags) +252 [HttpException (0x80004005): Unable to read the security policy file for trust level 'WSS_Minimal'.] System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +3465427 System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +69 System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +279 


    Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433


     

    Tuesday, January 13, 2009 5:27 AM

All replies

  • Sounds to me like a name resolution problem.  From a cmd prompt can you ping the server by name?  If not it will cause all these behaviors.

    The boys and girls hovering in the mothership would rather you(we) figure out why it is not resolving rather than make a simple edit to your host file ;>0


    Still......



    Grey
    Tuesday, January 13, 2009 3:06 PM
    Moderator
  • Yes, I can ping the server by name.
    I _DID_ make a change in my hosts file.  I even added an lmhosts file, I ran "nbtstat -R", I rebooted - none of that stuff has made a difference.

    The only thing I can't get to resolve is a "nslookup server" - that doesn't return back anything, but is that a big deal?  If I can ping it, if I can browse network shares, if I can access web pages - doesn't that mean names are properly being resolved?

    I'm still very much stuck on this one.
    Tuesday, January 13, 2009 11:49 PM
  • Hi,
    you could uninstall all updates for Windows Home Server including Power Pack 1. After this is completed, install the packages again, since PP1 creates a new version of the WHS website, this could work to fix the (as I assume from that message) wrong security settings.

    Did you install Windows SharePoint Services on the server? "trust level 'WSS_Minimal'" could point to that direction.
    In this case check also the event log of the server for related errors and warnings.
    Maybe they can give a hint what to fix (i.e. IISUSR_server account permissions).

    Other than that I see a reinstall as the only option.
    Best greetings from Germany
    Olaf
    Wednesday, January 14, 2009 8:22 AM
    Moderator
  • Will uninstalling all updates including PP1 harm my backup database in any way?
    Yes, I did install WSS and have since uninstalled it.

    Really really hoping there's a way to avoid a reinstall,

    Mesan
    Wednesday, January 14, 2009 6:14 PM
  • If you uninstall Power Pack 1, and after a reboot install it again immediatly (leave your client PCs of during that time to avild the various downgrades and upgrades of the connector software) there should be no harm for your backup database. (Of course this thing is so sensible, that nobody would put his hand in fire for this.)
    Also backups usually can be recreated.
    Best greetings from Germany
    Olaf
    Wednesday, January 14, 2009 6:59 PM
    Moderator
  • Olaf,

    Thanks for your ideas - I'll give that a try tonight.
     When you say "All backups can usually be recreated", what do you mean by that?  Do you mean there's a way to get data out of those backup files other than getting my home server connector to find my home server?  I need the backups of my Vista machine from before I blew it away and loaded Windows 7.  I can't recreate the information from my Vista machine because my Vista machine doesn't exist anymore, it only exists in the backup database.

    Last night I tried following the instructions in the Home Server storage white paper to stop the backup services (pdl and whsbackup), then copy the files out of the d:\files\{00... folder.  I then created a WHS virtual machine and tried to replace its backup database with the files I copied from my production WHS...no good.  It complained that there were database inconsistencies and after it tried to fix them the database was totally flattened.  Are you aware of some other method to get data out of them?

    Thanks again for all your responses,

    Mesan
    Wednesday, January 14, 2009 8:44 PM
  • When you say "uninstall all updates", so you mean go through one by one and uninstall every patch and update that has been applied since PP1?  If they prompt for a reboot do I have to do it?  Will it hurt to?  Should I?

    I'm just really anxious not to burn any bridges.  I really need the data in those backups.  This is exactly what WHS was supposed to protect me from... :-(
    Thursday, January 15, 2009 4:26 AM
  • Hi,
    this uninstall is only related to updates for Windows Home Server, which came after Power Pack 1 to keep consistency.
    (Maybe it works also, if you uninstall PP1 directly, but I have never tested this way.)
    And yes, if a reboot is required, you should do it.

    I really need the data in those backups.
    This is not what the backups are for. The backup database as an archive is not the best idea, since it is relatively vulnerable (no redundancy), its more thought as a recovery method for broken client PCs. So the backup for the backup database is usually the running client.

    For data you should use Shared folders and create regulary offsite backups of these shared folders.
    Data in shared folders can also be recovered relatively easy, if the server goes down and the data disks are still intact.

    Best greetings from Germany
    Olaf
    Thursday, January 15, 2009 8:08 AM
    Moderator
  • I wasn't using it as an "Archive", I was using it as a "Backup".  Isn't it supposed to work as a backup?  It's no different than if my hard drive had crashed and I needed to "restore from backup".  I'm not talking about getting access to some ancient 18 months-ago backup, I'm talking about a backup I made of my machine no more than 48 hours earlier.

    What good is WHS for backups if you can't restore from them?

    Please don't get me wrong - I love WHS and I'm not going to walk away from it after this.  I just find it dissapointing that the backup database can be so brittle.
    Thursday, January 15, 2009 10:29 PM
  • Mesan said:

    What good is WHS for backups if you can't restore from them?
    I just find it dissapointing that the backup database can be so brittle.

    for short term restores of files and folders I prefer the Previous versions, at least in Vista.
    But you are right, would be great, if the Backup database would be a bit more robust. (Although it is seldom, that both the backup and the client break at the same time, it can happen unfortunately.)
    Best greetings from Germany
    Olaf

    Thursday, January 15, 2009 10:59 PM
    Moderator