none
Homebase, My Submission RRS feed

  • General discussion

  •  

    Hi All,

     

    I was kinda nervous about posting this for a while.  I guess I am kinda afraid people will say I suck, or that my add-in sucks.  Oh well, if it sucks, then it sucks, if it doesnt then cool.

     

    So here we go.  I was having a really hard time getting files from the server on my Internet Explorer on my Windows Mobile phone.  Maybe it was me, but I just didnt have a good experience.  So I thought to myself, umm why not make a little client on the device that would allow you to pull files from the Home Server.  Thats where this little add-in started.  It has a web service that allows you to login, get files, etc.  It allows you to do things like save your password (yes I know a little security risk), it allows you to reduce the size of photos (umm, if you have a full sized photo, doesnt really matter on a 320x240 sized screen), and it uses a fairly simple method to retrieve the file, so I think it should be fairly stable ( I was able to use it fairly well).  So thats that part.

     

    Another thing I did, was write a simple blog which you can host on the Home Server.  Since that required you have a SQL Server, I had to package that into my add-in, thats why its a little large.   The Blog can be maintained from either your wireless phone or a desktop client I wrote.  For whatever reason I couldnt get the desktop client to do the Proxy thing, since the contest was closing, I just let it go.  As long as you have a direct connection to the internet, or to your server (umm you probably will be maintining this from one of your home computers thats on the same network as your server) you should be all set. 

     

    To install sql server, after you installed Home Base addin, go to the Home Base table, click install database.  Then get into the user's section, right click, and add each user.  The picture you choose just needs to be on the server hard drive somewhere, don't worry about it, the server automatically re-sizes it. 

     

    So OK, here's the link:

     

    http://www.alekseibytecode.com/HomeBase.msi

     

    Any questions, just get me at my gmail addy:

     

    anipirakis <<<<at>>>>>> gmail 

     

    Or just reply to this post. 

     

    Like I said, hopefully this add-in gives someone something useful.

     

    THNX!!!


    Aleksei (Alexandros Nipirakis)



    More information can be gleaned from my video @ http://soapbox.msn.com/video.aspx?vid=4056d734-a992-41b6-b642-434d4ce05e7c

     

    Sunday, September 9, 2007 8:07 PM

All replies

  • Hello Aleksei,

    I am in the process of installing the add-in you wrote. Seems like a great idea.

    The server side install went fine.

    When I tried to install on my mobile device, I get an "Error This file cannot be viewed on the device" Device is T-Mobile Dash (htc excalibur) running WM6.

    Any ideas?

    Thanks
    Jordan


    Monday, September 10, 2007 2:12 AM
  • Sorry about that.  Someone else had emailed me and I forgot to post this.


    When you install the server side, all you do from the mobile device is go to 

    http://yourserver.livenode.com/HomeBase

    This should take you to a regular webside where you click on mobile device.

    I didnt have a dash or similar device to try this out on.  I used it on a WM5 MDA device which runs a full version of Windows Mobile.  I know that the dash is running Smart Phone version so hopefully that doesnt mean that there is some incompatibility.  Are you trying to load the full msi package, or are you doing the exe from the website? 

    If it is the one at the website, I will need to take a look at that.  I really hope that isnt the case tho.  Let me know if that works Smile

    Thanks,

    Aleksei

    Monday, September 10, 2007 3:16 AM
  • Thats exactly how I did it. The two selections on the website show up perfectly.

    Its after I click on "mobile device" that I get the error on the Dash.

    Monday, September 10, 2007 3:58 AM
  • I am getting the sdk for standard edition.  I will see if I can recompile the code for the standard edition and post that to my website.

    Thanks for that.  Number one reason I should have posted this earlier Smile 

    Thanks,

    Aleksei

    Monday, September 10, 2007 4:02 AM
  • Awesome, please post a reply in this thread when it's ready for D/L.

    Monday, September 10, 2007 4:06 AM
  • When I loaded it, I was able to run it in the emulator, but it excepted when I tried to set parameters.  I loaded using the cradle on the emulator.  Seems that there may be a different assembly or different security setup on a windows mobile 6 standard edition device.  Can you confirm that this same behavior happens when you load it manually through the cradle? 

    Odd thing is that this same executable will work on a 2003->WM6 device as long as it is in professional edition.  Perhaps the Standard edition doesnt play with XML files well?  I don't know, I will try a recompile and see what happens.

    The issue you are talking about almost sounds as though Internet Explorer doesnt want to download the file.  If you have a few extra minutes, try and load it through the cradle and let me know what happens. 

    Sorry for the issues you are having, I am definately going to try and see what the issue with this is, since I know that there are probably more people who would like to use this for that kind of device.  Thanks for helping out, and again I guess this really points out my stupidity for not posting it earlier.  

    Thanks,

    Aleksei

    Monday, September 10, 2007 4:26 AM
  • Using a USB connection from a PC, I put the mobilehomemobileclient.exe on my Dash. Then ran the file from the Dash.

    I get a screen that says "home base" at the top then "User Name: Not Set!" and below that "Server"

    When I select "main" then "set parameters" I get a big "Error" screen

    "ERROR
    An Unexpected error has occured in mobilehomemobileclient.exe. Select quit then restart this program, or select details for more information"


    Monday, September 10, 2007 5:05 AM
  • Looks pretty cool actually. I can currently log into my WHS with my Sprint PPC-6800 running WM6 Pro, but function is somewhat limited.

    I like your add in as it reduces the size of pictures and is set up to handle mobile connectivity. I'll look into installing it here this week after you finish with the tweaks.

    Do I have to install the SQL server portion on WHS to get the mobile web portion to work properly?
    For Parameter section of set up: What do we put in the "Server" box?

    Looks like a cool add in!  .


    Monday, September 10, 2007 5:09 AM
  • In order to use the file browser you do not need to have SQL server installed.  The SQL Server portion is only for the blogriffic application, and you install sql server via the button on the console tab.

    Since you are using WM6 Pro, you shouldnt need the tweak I am working on.  Jordan has a Dash which I believe runs Standard edition.  I think that the setup on a standard edition phone is gonna be a little different.  I had erroneously assumed that this would just carry over from the regular version since I was able to run this on my Axim x50 and my MDA as well as in the Pro emulator.  Well, you know what they say about people assuming things Smile

    In the set parameters screen you put the fully quallified domain name for your home server.   For instance I think at one time i had mine set to lunokhod.livenode.com.  Then of course your username and password.  The program saves this data in an xml file on the device so that you don't have to enter it each time.

    Once you have installed the add-in, and if the user you are using has remote access, you can install the mobile client.  Then set parameters, and it will automatically launch into the file browser.  If you install SQL server via the "Install database" option on the HomeBase tab, then you get two buttons, bloggriffic application and file browser on the mobile device.

    Let me know if that gets you started Smile

    To Jordan, I will be running this in debug to see why it is excepting at that portion.  I will probably need to build a separate client for the Standard edition, so I will do this over this week and get back to you.  Thank you for trying to load via USB for me, and I will be sure to keep this blog updated.

    Thanks,

    Aleksei


    Sorry, you still go to menu and "Login to WHS (I changed the end part a few times before I finished)"


    Monday, September 10, 2007 12:24 PM
  • Ok, I figured this out. First, I did not realize that the Homebase is actually a small application that you use after doing the whole install portion and there is no need to use IE afterward. But that's where I got confused. I kept going through this whole process.  All I have to do is go to My Docs and the MobileHome MobileClient is there.  Now I can log into WHS mucho faster.  Maybe I missed something along the way..LOL.

    Now if I can pin it to my start menu or the Today Screen that would be sweet!

    Thanks for the help. Seems to work nicely.
    Monday, September 10, 2007 11:19 PM
  • I Just (hopefully) fixed the issue with standard edition.  Unbelievably, seems standard edition doesn't allow Windows Button Objects.


    http://www.alekseibytecode.com/MobileHomeMobileClient.exe

    JordanB, I cannot get my emulator to do network, so could you confirm that this client works on your phone?  Seems you might still need to active sync cradle usb it to your phone. 

    JudgeSchambers, I did consider making a package to install it to the start menu but I was having a heck of a time figuring out how to actually get it to work.  It was comming close to "send entry or be disqualified" so I just opted out and decided to leave it as it is.  Perhaps in a future version I will fix this.  As it seems, if I cannot get it to do Start Menu, people with standard edition WM6 phones are gonna have a bear of a time launching it. 

    Again, thanks for all the help y'all gave me.  Again, Jordan, it seems that using this version I can finally get it to allow me to save my settings, but again, I for whatever reason cannot get my emulator to access the internet (plus it runs REALLY slow... it is definately time to upgrade my PC).

    Hopefully that works Smile

    Thanks,

    Aleksei

    Tuesday, September 11, 2007 3:11 AM
  • Thanks Aleski,
    I can now enter the parameters, however, when I go to log in I get this

    "an error message cannot be displayed because an optional resource assembly containing it cannot be found"

    I am assuming that under server parameters, I just enter xxxx.homeserver.com

    Jordan



    Tuesday, September 11, 2007 4:58 AM
  • Jordan,

     

    You are correct, the server parameter should be set to the public name for your server.  In my case it is lunokhod.livenode.com since I am on a RC version, but if you are on the full version then it would be whatever.homeserver.com.

     

    I have a few theories as to what is going on here, but a question before I endulge such theories.

     

    When you login, does it come up with the waiting circle for a bit then display the message?  Does it seem as though it is trying to log in then quit abruptply, or does it just kill its self before it even has the chance?  

     

    Also, did you install the Database portion or are you just doing FileBrowser (this causes a different sequence of events since if you are not doing full, just FileBrowser then it would only show the ListView which contains all your files)? 

     

    Finally, and I know that this is a dumb question since I think it is installed on default, but you do have SSL enabled and working on your server right?  The program by default appends https:// to the begining of the Web Services string when it feeds it to the underlying Microsoft HTTP libary. 

     

    hmm, guess thats probably about it for the interogation.  I will work and see if I can get my emulator to do web.  I know I had one of the other emulators doing web, but I just need to remember how I did it.  

     

    Jordan, Thank you so much for assisting me in creating the Standard Edition client.  I am quite sorry that I hadn't gone through the testing before releasing the software, but I have high hopes that with you testing on an actual device that we will probably get it working Smile

     

    Thanks,

     

    Aleksei

     

    Tuesday, September 11, 2007 1:59 PM
  •  

    Hi Aleksei,

    I am trying to use your add in and it installed fine on my home server but when I try to install the mobile client I get the following error:

    "This application (MobileHomeMobileClient.exe) requires a newer version of Microsoft .NET compact frame work than the version installed on this device."

    I am not sure how to check what version I have or how to update it. I looked thru my device and can't find anything. I think I am missing something easy.

    Thanks in advance for the help

    Tuesday, September 11, 2007 4:37 PM
  • Sorry, forgot to put my device info.

    Treo 700w

    WM5

    Tuesday, September 11, 2007 5:05 PM
  • danjswartz,

    I had this hapens to me a lot believe it or not.  The problem you are experiencing is that I wrote the Home Base mobile client in Compact Framework 2.0.  If you have an older device (like my MDA, or pretty much anything produced before Windows Mobile 6) you will need to manually add this to your device

    You can get the 2.0 redistributable for your mobile device here:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=9655156B-356B-4A2C-857C-E62F50AE9A55&displaylang=en

    By the way, once I get the Standard Edition working (this is my main focus when I am out of work these days) I will post up on my server a little faq section with some better instructions.  As with all software there are some little gotchas along the way. Probably have a section to have known working devices too Smile

    Thank you guys for all your support, I really appreciate it,

    Aleksei

    Tuesday, September 11, 2007 5:09 PM
  • Aleksei,
    Today I tried again, connecting through GPRS. Same parameters as before. I got the waiting circle for a bit then voilla!

    "Windows Home Base"

    "myserver.homeserver.com"

    And a file button.

    I tried the blogarific program, and added an entry.Looks like it worked!

    When I went to flie explorer however, I get the "unexpected error" again.  When I select the details of the error, it says

    "not supported exception at microsoft.AGL.Common.MISC.handlear()at system.windows.forms.savefiledialog..ctor()......and so on and so on.

    Maybe I couldnt connect the first time because I was using WiFi on the same network as the server?
    Tuesday, September 11, 2007 5:48 PM
  • Looks as though you are in a similar (but not same) boat as Jordan.  The edition of windows mobile that you are using must be the smartphone edition, which apparently supports buttons, but does not support the file dialog.  I will work on that as well on the Smart Phone Edition of the Home Base client.  I will post a link once it is out.  

    Sorry about all the issues with this, unfortunately it seems that each edition of Windows Mobile has its own peculiarities.  I am hoping to have a new version posted tonight, latest tomorrow night depending on how long it takes to get my emulators talking to the network. 

    This issue is probably going to be a lot easier to fix than the WM6 standard issues we are running into. 

    Again, Thank you guys for helping me debug this on different mobile platforms.

    Aleksei

    Tuesday, September 11, 2007 6:11 PM
  • Dumb question #3, where is my blog? Or how can one view it?
    Thanks
    Tuesday, September 11, 2007 6:16 PM
  • No dumb questions, I am the genius who didn't post details Smile 

    You should be able to get to your blog from http(s)://serverfullyqualifieddomainname/HomeBaseShare 

    I had noted issues with the HomeBaseShare exceptioning if you didn't restart the server after installing the database.  Something with database permissions and IIS (from what I surmised).  Otherwise, it should work normally Smile 

    Thanks,

    Aleksei

    Tuesday, September 11, 2007 6:40 PM
  • I got right in, thanks. My blog is available for the world to see Smile


    I will be looking fwd to version 3 .


    One suggestion on the blogerific, it would be awesome to be able to post pictures from our mobile devices onto our blog.

    Tuesday, September 11, 2007 8:57 PM
  • Jordan,

     

    Sorry, I got confused about something, you are able to blog now, just not get into file explorer.  That makes my job easier since I know how to fix that.  I was dreading having to figure out what HTTP/Security thing it was broken on.  Sorry to you and to dan for getting you too mixed up.  It is good to hear that you are working now with Blogerific, and I should definately have a new executable up there for File Browser so you can also download files from your home server to your device by the end of the night.  If I am feeling really ambitious, I might even have the afore mentioned faq done.  

     

    On the other, I really did want to make a file upload piece, and actually got one partially working.  The problem was that it was really slow (basically sending byte[100] arrays using a webservice).  It was getting down to the crunch and I really wanted to send this to Microsoft so I cut that feature out (I didnt want to send something to Microsoft that didnt work well).  It is definately something I wanted to put into the program.  For me, every time I call T-Mobile they invariably have me flash my rom which means that I loose all of my documents in my My Documents storage space. 

     

    Since I am under no timeline at this point for a complete date (Microsoft already has my Code2Fame submission, and it is what it is) I will probably re-visit this.  I know it is definately something I would use myself. 

     

    BTW, what is your blog address if you don't mind sharing Smile  Maybe when I get my FAQ website up people can post their blogerific urls.

     

    Thanks,

     

    Aleksei

     

    Tuesday, September 11, 2007 9:30 PM
  • Blogerific is working fine, Thanks Aleksei.

    I have posted twice from my Dash today. I sent the address to my wife, so we can see if a non-nerd can figure out what they are supposed to do to read the blog.

    It will be, interesting to see if I can get her to start posting one also...

    Pretty boring blog so far, but here is mine:

    http://jordanski.homeserver.com/homebaseshare





    Tuesday, September 11, 2007 11:09 PM
  • So after doing some re-writing, here we go:

    I have posted a brand new version of the client which is specifically for Smart Phones.  I will rebuild the HomeBase.msi and post that as well.  

    http://www.alekseibytecode.com/SmartPhoneWHBClient.exe

    This should work.  Load it via the USB Active Sync method.  I ran it in emulator and was able to sucessfully download a file.  I had to write my own save file dialog box Smile Interesting that it isn't included in the regular API, and probably a good indication as to why you can't directly download the EXE to the smart phone. 

    Let me know if you can how the testing goes (Jordan) .  By the way, just wanted to say thank you for posting your URL.  It was cool to see someone elses blog sitting in Blogirffic Smile

    Thanks For all the help and again let me know if it works.

    Thanks,

    Aleksei

    Wednesday, September 12, 2007 1:25 AM
  • Aleksei,

    I got the framework installed on my Treo with WM5. Thanks for that.

    I now have a new issue.

    Now I go to http://mysite/homebase, I get presented with the mobile client link or desktop link to click. I click the mobile client and I say yes to install it. it installs, lets me set parameter of my user name and my server name then when I click logon to home base I get " An error message cannot be displayed because an optional resource assembly containing it cannot be found." Then I click OK and I a spinning wheel that never ends. I can hit the exit and it takes me back to the option of installing the mobile or desktop client.

    Any ideas?

    Thanks again

    Wednesday, September 12, 2007 2:06 AM
  • ALeksei,

    The new smartphone client works great with WM6 on the T-Mobile Dash.

    Now I need to name all my pics on the server so I know what I am downloading I suppose thumbnails would slow everthing down to a crawl.

    My wife never did check out the blog while she was at work. Unlike me, it appears as though she is actually getting paid to work, not post blogs and try out new apps

    Thank you very much for this cool add-in.


    Danjswartz, put the newest client on your treo and you should be good to go..

    Cut this out and paste it in your PC browser, then D/L the file and move it to your treo.

    http://www.alekseibytecode.com/SmartPhoneWHBClient.exe


    JOrdan








    Wednesday, September 12, 2007 2:55 AM
  • That is excellent to hear!!   Again, if there are any other issues, let me know, though it sounds at this point that you are good to go Smile

    DanJSwartz, if for some reason the client that Jordan posted does not work, I will attempt to run in a WM5 emulator and see if it is something else (though from the sound of it it sounds as though it is a similar issue that Jordan was experiencing using the regular WM5/WM6 Pro client since some of the graphical elements I was using are not included in the Smartphone SKUs).  

    I just wanted to say thank you to you all for helping me debug this.  Again, sorry I didnt start this process sooner Smile

    Aleksei

    Wednesday, September 12, 2007 3:49 AM
  •  This is what I get wen i try to access my server http://www.myserver.com/HomeBaseShare

    Anyone get a solution for me?

     

    Tnx

    Server Error in '/HomeBaseShare' Application.

    ExecuteReader: Connection property has not been initialized.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.InvalidOperationException: ExecuteReader: Connection property has not been initialized.

    Source Error:

    The source code that generated this unhandled exception can only be shown when compiled in debug mode. To enable this, please follow one of the below steps, then request the URL:

    1. Add a "Debug=true" directive at the top of the file that generated the error. Example:

      <%@ Page Language="C#" Debug="true" %>

    or:

    2) Add the following section to the configuration file of your application:

    <configuration>
       <system.web>
           <compilation debug="true"/>
       </system.web>
    </configuration>

    Note that this second technique will cause all files within a given application to be compiled in debug mode. The first technique will cause only that particular file to be compiled in debug mode.

    Important: Running applications in debug mode does incur a memory/performance overhead. You should make sure that an application has debugging disabled before deploying into production scenario.

    Stack Trace:

    [InvalidOperationException: ExecuteReader: Connection property has not been initialized.]
       System.Data.OleDb.OleDbCommand.ValidateConnection(String method) +1072909
       System.Data.OleDb.OleDbCommand.ValidateConnectionAndTransaction(String method) +15
       System.Data.OleDb.OleDbCommand.ExecuteReaderInternal(CommandBehavior behavior, String method) +51
       System.Data.OleDb.OleDbCommand.ExecuteReader(CommandBehavior behavior) +111
       System.Data.OleDb.OleDbCommand.ExecuteReader() +6
       DataClass.getAllUsers() +48
       ASP.default_aspx.__Render__control1(HtmlTextWriter __w, Control parameterContainer) +144
       System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +2113547
       System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +24
       System.Web.UI.Page.Render(HtmlTextWriter writer) +26
       System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25
       System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121
       System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +22
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1896
    

    Wednesday, September 12, 2007 10:47 AM
  • scooke,

     

    A couple of gotchas that I have noted:

     

    1.  Did you go to the HomeBase add-in in your console and click "Install Database"? 

     

    2.  After you did that, did you restart your Home Server (some issue with some of the security)? 

     

     

    If the answer to both of the above is "Yes" then I have some questions to help me diagnose the issue:

     

    1. How many users did you set up in the Home Base Console Add-In?

     

    2. Are you able to post from Mobile and/or Desktop? 

     

    3. Are you using File Browser on Mobile? 

     

     

    Thanks,


    Aleksei

     

     

    Wednesday, September 12, 2007 12:28 PM
  • Aleksei,

    I tried Jordon's client and it is the same error I had before. Sorry.

     

     

    Wednesday, September 12, 2007 2:40 PM
  • I will give it a looksee tonight.  Can you just confirm one thing for me:  The version of windows mobile that is running on the Treo:

    I go into the Settings->System-> About Screen and I see at the top: 

    Microsoft Windows Mobile Versionm 5.0 5.1.195 (Build 154955.2.3.0) 

    This will help me use the right emulator.

    Thanks,

    Aleksei

    Wednesday, September 12, 2007 2:57 PM
  • Sure thing.

    Treo 700w (verizon wireless if that makes any difference)

    Windows Mobile Version 5.0

    OS 5.1.195 (Build 14929.2.2.1)

     

    Good luck, this is a promising program. Even though I have had issues I think it is a valuable tool.

     

     

    Wednesday, September 12, 2007 3:03 PM
  • hey aleksei,

    After a reboot everything was ok, except the pictures they were not visible, altough I selected a photo when I created a user, any idea?
    Wednesday, September 12, 2007 6:22 PM
  • hmm.. thats interesting. 

    When you get into the Console and look at that user, does that photo come up?  Basically what this does is makes a link to that photo, so if you delete the photo after the fact then it will not work.  If you are able to see the photograph in the Console then you should be able to see it in the blog.

    Out of my own curiousity are you using the Desktop Client or the Mobile Client (this doesn't help with my diagnostics of the Photo problem, but I am just curious Smile ).  Good to hear that the reboot helped.  Gotta love permissions Smile

    Thanks,

    Aleksei

    Wednesday, September 12, 2007 6:25 PM
  • I did what you told me, so when I open the console I can see the photo without a problem. So that's fine a think...
    Does the location of the photo matters? Now the photo is localized at the shared folders, maybe it need to be stored at an other location?

    I don't have a smartphone :-(, so I created the blog with theDesktop Client.
    Wednesday, September 12, 2007 7:21 PM
  • Alekesi,
    Just an update to let you know that everything is still working well with the smartphone client.

    I posted my blog again, a little more exiting today, from a courtroom no doubt Smile

    http://jordanski.homeserver.com/homebaseshare


    Wednesday, September 12, 2007 8:21 PM
  • The location shouldn't matter.  Is it a JPG?  Also, is it an exceptionally large photo?  If it is large (either in dimensions or file size) it may be being choked on by the server when it tries and resizes the photos.  

    Thanks,

    Aleksei

    Wednesday, September 12, 2007 11:43 PM
  • Its good to hear that you arent having any issues with the software. 

    Wish you the most of luck on what you posted about.  

    Thanks,

    Aleksei

    Thursday, September 13, 2007 12:12 AM
  • Seems like this issue happens when the phone cannot talk to the server.  Can you confirm that remote is working on your home server (IE IIS is working and HTTPS is also working).  Also confirm that the user you are logging in as is good.

    As a last resort, delete the file MHMC.xml.  If this all still doesn't work, I will probably want you to test with my server, since I know that I can connect to it from my device and two emulators (the WM5 emulator could connect as well).  The only other thing I can think about is something specific to that particular model security wise... but I would greatly doublt that.

    Thank you again for helping me figure out the issue here.

    Thanks,

    Aleksei

    Thursday, September 13, 2007 12:22 AM
  • Aleksei,

    Just wanted you to know it works fine now. I can't believe how dumb I can be sometimes, I missed a very obvious clue.

     

    Here is what happened.

    1. Set up Homebase on WHS (worked fine)

    2. Connect via Treo download and install mobile version (worked fine)

    3. Set Parameters (here is where I screwed up)

    Your parameters ask for username, password, and server. I put in username and password just fine. When it asked for the server name I put in my servers name. The local name of the server ie 'myserver'. This is where it failed. 

     

    So then I thought, maybe it wants the real world name of my server. Well at that time I did not have one. I had an IP address only. So I tried the real world IP address of my server. This too failed.

     

    It never dawned on me that your app could not use the IP address. Then I saw the post above with the judge and the FQDN name he used for his blog and it hit me.

     

    I need a FQDN.

     

    So I signed up for a livenode.com name (from WHS Console), got it published, tested it and then put that FQDN name into your app and VIOLA!!!! It works.

     

    It all works just fine.

     

    I hope this helps you out as well as someone else out there who may have had a temporary thought loss!! It all makes sense now.

     

    Anyway, Thanks for the program it is very useful. And thank you for all the attention and ideas you gave me. You have been very helpful.

     

    Keep up the good work. 

     

    Thursday, September 13, 2007 2:37 AM
  • It  is excellent to hear that it is working for you now Smile Thank you for the feedback

    Aleksei
    Thursday, September 13, 2007 10:38 AM
  • Aleksei

     

    I cannot get the Blog portion to work at all and since installing the SQL server portion, it is causing all kinds of lockups with WHS Console. I think there is a conflict with another add in--- Program Launcher.  Sometimes while trying to set up a blog user the WHS DeskTop will pop up like I'm using the Program Launcher add in. Which causes all kinds of lock ups and I have to reboot the server.

     

    I really don't need the blog portion anyway. What's the best way to uninstall the SQL server portion of your add in?

     

    Oh, and even when I'm logged out of Home Base on my Mogul....WHS Console has shown me as still logged in for the past couple days...LOL.

     

    The file system log in works great and simplifies file retrieval! Excellent work!

     

    Thanks.

    Thursday, September 13, 2007 11:10 AM
  • Aleksei,

    Just wanted you to know that I am trying the blogging part as well, from my desktop client and I too am having the same picture not displaying issue. Just the red x

    It is a tiff in my case and not a large one.

     

    Does it need to be a jpg only?

     

     

     

    Thursday, September 13, 2007 1:42 PM
  • Judgeschambers,

     

    You know how when you are in a rush, you always end up forgetting one thing that ends up being big?  Thats what I did here.  Unfortunately I forgot to include the uninstall SQL portion in either the console or in the uninstall of the MSI.  

     

    Basically, what you are going to have to do then is log into your WHS via Remote Desktop, go into add-remove programs, and then find something to the effect of SQL Server (HOMEBASE), if you uninstall that, all the other dependent pieces should also uninstall.


    Sorry that this is a little convoluted, in future versions I will correct this issue.  I am happy that the other pieces are working for you.  On a related note, I will likely try out the Program Launcher and see why it is hanging SQL server.

     

    Thanks,

     

    Aleksei

     

    Thursday, September 13, 2007 1:57 PM
  • Howdy,

     

    I think it can either be a BMP, JPG, or GIF.  I am using a plain old windows Bitmap api to do the resizing on the server and so, I think that Tiff is un-supported.

     

    I should probably add that to the FAQ I am going to start tonight for the Home Base system.

     

    Thanks,

     

    Aleksei

     

     

    Thursday, September 13, 2007 1:59 PM
  • Judge,

    If you run into issues with this, please let me know and I will try and help you out as best as possible.  If you need extra assistance, please get ahold of me at my email anipirakis <at> gmail.com.  

    Again, I appologize for the inconvenience of having to log into the server to remove SQL 2005.

    Thanks,

    Aleksei

    Thursday, September 13, 2007 3:55 PM
  • Aleksei,

    Oh, no trouble at all. I did go into the Services area and stop the Homebase SQL server and set it to manual. There are three entries there and stopping the "HomeBAse" first shut the other two down also. That free'd up my server big time. As an older slower box, it was taxing it pretty badly. No fault of yours...

    I'll check the Add/Remove Programs and see if it's there and uninstall it.

    Yeah, in my opinion, the program launcher add in seems to affect your add in in Console. Sometimes, when I tried to add a user and select a picture....it would lock up then the desktop view would show.... Then totally lock console. Once I was able to select a picture..and accept...the Console locked up. Thinking I at least completed the needed connections before the final lock up, the blog still did not work. The blog option would not show on my phone either. I'm sure the SQL tax on my slower machine did not help either... Hope that detail helps to replicate the issue.

    Thanks again....and the mobile part of your add in is very nice
    Thursday, September 13, 2007 10:37 PM
  • Thanks Judge!  Luckily my machine is pretty slow too, so I should be able to recreate it Smile

    By the way-- I just created a brand new FAQ and Install site for everyone: 

    http://www.alekseibytecode.com/homebase/

    Let me know if you guys like it Smile

    Thanks,

    Aleksei

    Friday, September 14, 2007 2:23 AM
  • Aleksei,

    I went to uninstall SQL Server. Here are the four SQL Sever files I found under "Add and remove programs:

    SQL Server 2005  146 mb
    SQL Server Native Client   4.18 mb
    SQL Server Set up Support Files (english)  22.60 mb
    SQL Server VSS Writer    .67 mb

    None Say HomeBAse.  I stopped the service, so my server runs ok now. But, can I uninstall all four?  Were all Four created when I installed SQL Server using Homebase?

    Sunday, September 16, 2007 4:06 AM
  • Sorry about that judge... I think if you uninstall SQL Server 2005 it should uninstall all the others (they are dependent programs).  

    Again, sorry for the confusion on this one.

    Thanks,

    Aleksei

    Sunday, September 16, 2007 11:55 AM
  • Aleksei,

    No problem. I sort of figured that too. Just wanted to make sure. I've no experience with SQL server...LOL.

    A small note on HomeBase:  Even after I log out of WHS using my phone....when I bring up WHS Console on a PC, it still shows me as logged in to WHS in the left hand corner.  I even turned my phone off over night thinking the phone may be keeping a live connection all the time. But this morning Console said I was still logged on when I was not.

    Now, if I log into WHS through a PC with my account or a buddy's account, WHS releases the notification within a few minutes of logging out.  May want to check that out when you have a chance and see if anyone else has the same thing happening. No biggie, but it's giving a false  reading of users logged in....

    Thanks again!
    Sunday, September 16, 2007 1:41 PM
  • Hi Judge,

    I will definately look into that.  I really do appreciate you helping me out with this.  

    Thanks,

    Aleksei

    Sunday, September 16, 2007 9:17 PM
  • Aleksei,

    Any new updates or changes to the original Add-In? 
    Thursday, September 27, 2007 2:15 AM
  • Judge,

    Not yet.  I am hoping this weekend, or over next week to have a chance to do some more work.  What I really think is going to happen at this point ( I will start a new thread about this ) is that I may actually open source Home Base.  I think that others may benefit from seeing how I did it, and they may have stuff to add in.  Perhaps someone can help me figure out how to get uploads from Mobile working.  In any event I think its at a point where I am happy to share it-- Based on community feedback that is.

    Thanks again for all the helpful assistance you have provided me, and of course I will try and keep you and everyone posted on the progress.



    Thanks,

    Aleksei

    Friday, September 28, 2007 10:14 PM

  • Aleksei,

    I have an HTC TyTN II running WM6.  I downloaded your HomeBase app and found it relatively easy to configure, and it browses my shared folders fine.  However, I get an error when I try to download a file.  If I try to save the file to RAM or my microSD card, I get "The File Didn't Download Fully! Try again latter."  The program gives me a save dialog, waits a bit, then displays the spinning four-color hourglass and after a few minutes fails.  The test file is about 5mb.  I've rebooted both my phone and WHS.  Any thoughts?  Also, is there a way to determine how far along the file download is as it is progressing?  Thanks!

    Mike
    Friday, November 16, 2007 5:42 PM
  • Mike,

    what this typically means is that the internet connection between the phone and the WHS has been cut somewhere in the file transfer and the file downloaded did not get transfered completly (it checks to make sure that the file that appears on the phone is the same size as the one that was on the server).  I have tried larger files (in the 3-4MB range) but never a 5 MB file.  As of right now, I do not have WHS installed on any of my test machines at home, since all of my keys are used up and I cannot seem to get a new one.  I am hoping that Microsoft will soon release a version of WHS for us developers soon.  If not, then I may bite the bullet and use the 30 days that I have on the keys that I have. 

    On the second issue, I tried to make a progress bar but it just never seemed to work right.  What I am thinking for the next version of WHS is that there will be a "Lite" version that will run in the regular web browser.  In that case, the web browser will be much better at handling the progress bar, etc.  

    In short, stay tuned and I will try and find a solution to this issue.  A few questions: what kind of WHS do you have?  Is this one that you put together?  What are the specs of your box?  Finally, what kind of internet connection does your TyTN have? 
    Thanks,

    Aleksei

    Monday, November 19, 2007 2:43 PM
  • Aleksei,

    I tried again today, and got a different error, which was “There was an error transfering the file”.  The file was created in the download directory, with a size of zero bytes.  Running your program in a browser sounds like a good solution.  I have tried accessing WHS directly through PocketIE, which actually worked fine up until I got to the window showing the files available for download, but probably due to the lack of a proper ActiveX component the download button is not available (and Opera 8.65 didn’t work either).

    My WHS is either the last beta or the RC, as I installed it several months ago (late summertime, I think).  I have it installed on a Dell Inspiron notebook, which actually works fine though the network drivers need to be manually installed.  The notebook is about a 2.12ghz Pentium M with 1gb of RAM and 100gb of hard drive space.  I also have a 500gb USB drive connected.  My TyTN II is on at&t and gets HSDPA connectivity at about 500-700kbps.  It is capable of downloading files of this size, as I can access my home network through an IPSec VPN client running on the phone and download files via FTP, but WHS is a much simpler and more flexible solution.
       
    I’ve also looked for the released version of WHS, and it’s not on TechNet (though it should be!).  Since my WHS is still working, I’d be happy to test new versions of your program if that would be helpful.  Thanks!

    Mike
    Monday, November 19, 2007 6:09 PM
  • Aleksei,

     Since the install of WHS OEM I think I'm going to put the add in back on. 

    Any new updates to your add-in coming soon?  Have you worked out a way to put the log on link in the phone on the start menu or to save it as a fav in IE on WM6?
    Wednesday, November 28, 2007 11:48 AM
  • I am actually working on a couple of features. 

    1.  I want to make a version of the file utility and the post utility that will work in the web browser for those people who do not have windows based smartphones which can run the home base client.  (This is started, though none of the work is up on SourceForge yet).

    2.  I wanted to check out some of the bugs (one which you submitted- related to HomeBase keeping a user login alive after they have logged out). 

    3.  I want to give the user the ability to uninstall SQL server, and I also want to give the option to run FireBirdSQL which is much lighter than MS SQL 2005.

    4.  Upload files.  I think I can actually get this since I will be able to use older version of VS to create it using DIME attachments.  Since the original HomeBase was written for the contest, I was prevented from using anything other than VS2005-- now thats over, I will try this and see if I have success. 

    5. This is something I have bouncing around in my head for a bit, but here it is:  A way for regular users to create sharable
    databases.  Think about a mom making a database of chores that she can write from her desktop or phone, or an online shopping list.  Of course this would also have an easy to use web front end for retrieval with usernames/passwords etc.  

    I am going to try to create a poll on the homebase site on AlekseiByteCode.com -- those who wish can vote on which feature for Aleksei to work on first.  Are there any suggestions for new features that I missed?  

    Again, I wanted to say thank you to all of you who have helped me debug HomeBase and make it as successful as it is.  If my download logs are right, I think there are more than 1000 people who downloaded it.  That may not sound like much but this is the first program I wrote which has been distributed widely among disparate populations.  You guys keep downloading and I will keep writing Smile

    Thanks,

    Aleksei

    Wednesday, November 28, 2007 1:43 PM
  • Do you support WebDAV?  If not, you should as it is very general purpose and mapps to alot of existing clients.

     

    Friday, December 7, 2007 8:41 PM
  • Homebase does not support (as of right now) WebDAV. 

    Support of WebDAV is quite a good idea!  I will look into it.


    Thanks,


    Aleksei
    Thursday, December 13, 2007 1:36 PM
  • Hi Aleksei,

     

    This seems like a great utility. I have one stumbling block though. My mobile device is an i-mate K-JAM running WM5. I've installed the compact .net 2 thing and the homebase client. But I cant login via the mobile device because of a very embarassing problem. I have never learnt how to use the slide-out keypad thing, I always use the on-screen keypad. When the Homabase login screen comes up I cant find any way of accessing the on-screen keypad. I've tried using the slide-out one but I never seem to get the characters I want. Is there a trick to this?

     

    Friday, December 14, 2007 1:50 AM
  • Hi Aleksei,

     

    I'm making progress, not on my mobile but resorting to using the desktop client.

    Maybe I dont understand properly what a blog is, but I've added myself as a HomeBase user and used the client to create a blog. I checked using my pc browser that the blog and picture show up which they do. Bouyed by my success I created a second blog, and when I checked it, I noticed that my first blog wasnt showing anymore. Is this how its supposed to work? I presumed I could have a whole list of blogs showing from which people could choose to read.

     

    Friday, December 14, 2007 8:46 AM
  •  

    I have a couple of things to look into once I get my trial CD for Home Server.  Unfortunately I guess I never tried to use the on screen keyboard, and will look into why you cannot access it. 

     

    Sorry for the issues. 

     

    Thanks,

     

    Aleksei

     

    Sunday, December 16, 2007 6:02 PM
  • Hi KiwiFidget,

     

    I am elated to hear that someone is still installing the software.  What should happen with the blog is that the first page will show you all the users with blogs on your home server.  Once you do a blog, that will be posted on the main page along with your picture.  You must click on the users picture, or the link next to it with their name and this will show all recent posts by that user.  This was kind of my prototype for how I would make it work, but if many people find that this format is too confusing then version 1.0 OSS will look differently.  As it is I wanted to give users the ability to install "Templates" so that their site can look a little different from the other HomeBase users. 

     

    Thanks again for installing my software,

     

    Aleksei

     

    Sunday, December 16, 2007 6:07 PM
  • Hi Aleksei,

     

    Thanks for the blog help. It seems so obvious now.

    Still having issues with the mobile client, but quite happy to use the desktop one for now.

    How do I access the mobile client on the PDA after it is installed? I dont see it in my Programs list.

     

    Cheers, KiwiFidget

     

    Sunday, December 16, 2007 7:06 PM
  • I installed your add-in and the blog end is wonderful. I do have some issues though as I am not as tech as probably the next guy.
    What my problem is, is I installed the Home Base in the control panel on my server, added users/pics, and found that 2 of my users were remote desktop clients that had different logon names and would not access the remote end of the server.

     Well, what happen was I had done test blogs on the users to see if the blogs worked, (from MY cpu to server) it worked great. I left that alone and went to set up remote access from the client CPU's and found that I needed to change the name of the users in the Home Base/blog user to match the client machines. I dropped the users in Home Base WHS console, added new users (renamed WHSC HB to the users machines/clients for various reasons, logon purposes and organization) and then went to check and make sure that they had blog access and the new users worked, blog and remote both,  BUT .....viola,

    https://xx.xxx.xxx.x/homebaseshare/GetUserBlog.aspx?userId=0

    https://xx.xxx.xxx.x/homebaseshare/GetUserBlog.aspx?userId=6

     2 old user ID=0 and 6 were still in the blog pictures and all, under the old names they had been givin, yet they don't exist in the control panel anymore, hence I can't delete the blog by logging in. (don't know how or why) "zman shrugs"

    Now it's bugging the *** out of me. I got these 2 old ficticious names in the top of my blog and can't figure out how to stop them from displaying. I went through all the files in Home base because I do know a little about coding, mostly html, script, tags and tables and poop like that but I can't seem to track it down. I looked through the files of HB and I think I read somewhere that it's/HB is calling on system event logs or something for the info so it wouldn't be anything in HB would it? Just for the heck of it, I wiped all events clean. I uninstalled HB and reinstalled it and the problems still there. I know I've caused myself a lot of work but I really don't mind snooping in the work you've done with this as that's how I've learned what I know. READ READ READ I'm self taught. Smile  In other words I don't know a whole lot about anything but I know a little about everything.

    I need help.

    I also haven't been able to figure out the whole mobile/desktop UL and DL of file transfer either but I know I ran across some of the files for it when I went digging. Is there a seperate URL for that. ??? Truthfully I haven't messed with it yet.

    If I missed an explanation for any of my questions I'm really sorry, but I did read everything on this site multiple times and even watched the vid you made for the installation of HB. That's how I figured out where to find the https://xx.xxx.xxx.x/homebaseshare.  I'm thick skinned sometimes. Forgive me. Smile

    Props again for the time spent on this add-in, once I get it straightened out my server of family spread out all over Ohio is going to make good use of this.

    Really hope this thread is still active,
    zman


    Wednesday, January 2, 2008 11:38 AM
  •  

    zmanwitdplan:

     

    First, a disclaimer: I haven't yet installed this plugin. Also, directly working against your data without experience in SQL is dangerous for your data.  You run the risk of completely trashing the info you have up there already. That being said, you said you were self-taught, so I thought I should at least give you a lead.

     

    Here's what I think is going on in your case -- this plugin has a sql server backend (SQL express, I imagine).  If you do not have experience in T-SQL (the language to communicate w/ Microsoft's SQL Server database products), you would need to learn it in order to address your issue.

     

    Assumptions:

    alekseibytecode used SQL Express

    he maintains a list of users in a table

     

    Based off of your info, you'd need to get rid of users 0 and 6. There will probably be a users table, with a field called ID or UserID or something similar.

     

    Friday, January 4, 2008 1:54 PM
  • After being told that, I went to SQL Express and found it straight away. Deleted the 2 lines and all is well. Thanks for the help JNadal, that helped.
    Saturday, January 5, 2008 2:25 AM
  • JNadal is correct, the users are maintained in a table (as you learned).  Sorry I didnt get back to you sooner, I need to get better at keeping up with my hotmail account.

    On the other hand, this brings up an important note, I need to add in the ability to do deleting of an entire blog.  Sorry that this wasn't included in the system.

    If you run into any more issues and for some reason I don't answer the post on this thread within some reasonable time, please feel free to email me at my gmail account.  Again, greatest appologies that I did not check my email sooner:

    my gmail account is anipirakis <at>  gmail.com 

    I will be posting some updates to HomeBase soon.  I have finally installed it on a virtual server which means that development will begin again.  I anticipate the first alphas of the HomeBase OSS version to be available sometime next week, perhaps the week after that.  For those who are interested in this proposition, just keep watching

    http://www.alekseibytecode.com/homebase 

    for updates.

    Thank you all very much.  I appreciate that so many people have downloaded my add-in and found it useful.

    Thanks,

    Aleksei

    Tuesday, January 8, 2008 5:19 PM
  • Hi Aleksei,

     

    I'am having some trouble with the picture that is supposed to be on the Blogpage.

    In the WHS Console i have added a picture to the user and it showes there, but on the ../Homebaseshare page all I see is a black frame with a small red cross.

     

    What could i have been doing wrong?

    I have already changed the size of the picture (It's now just 10kb) but that makes no difference. The picture is located in a submap of the default Shared map : <server>/Photos

     

    Grtz,

     

    -=H@ns=-

     

     

    Sunday, January 20, 2008 2:12 PM
  • One issue I have noted is that some users use non-supported images.  I am using the regular microsoft image library to kind of work with the images, reduce their overall size, etc.  I think it only supports bmp, gif, and jpg.  I mostly use jpg's on my blogrific page.  If that still doesnt help, let me know and I will look into it.  I am currently doing some work on the other parts of HomeBase and would be more than happy to delve into trouble areas Smile

    Thanks,

    Alexandros

    Monday, January 21, 2008 7:39 PM
  • Hi Aleksei,

     

    Thanx for the fast reply.

    It still does not work. I first used a picture from my Photoalbum. Because that was rather big (2816x2112 at 2.7MB) I reduced its size to 154x120 at 10kB. This had no effect. Then I copied some illustrations out of the Office illustrations library and tried them as .WMF, .GIF, .BMP and .jpg. Also with no effect. Even a small icon (.gif of 1kB) did not show up on the Blogpage in my browser.  Not even after a full reboot of the server. All the pictures do show up in the HomeBase tab of the WHS Console if I select a user but not on the webpage in my browser. I've tried IE7 and Firefox both with the same result. 

    Could there be some interference with one off the other Add-ins i have installed?

    I'm running the following Add-ins:

     

    uTorrent 1.1.1.0

    Disk Management 1.0.0

    Event viewer 1.0.0.0

    Homebase 1.0.0

    Whiist 0.8.0.0

     

    Iff you want I can send you more info that might help in the search for this problem by email. Just let me know what files (.logs or what ever) you would like to look at.

     

    Grtz.

     

    -=H@ns=-

     

    (hans2488 at live.nl)

    Monday, January 21, 2008 10:50 PM
  • Hmm.. that is quite strange.  I will have to try it out with those other add-ins installed and see if I suffer from the same effect.  

    I will let you know what I find out.  I should be able to test this in the next couple of days.

    Thanks,

    Aleksei

    Tuesday, January 22, 2008 8:45 PM
  • One other thought, could you send me the picture you are trying to use?  The full sized one would be most helpful.   anipirakis<at> gmail.com.  That way I can have all things being equal situation. 

    Thanks,

    Aleksei

    Tuesday, January 22, 2008 8:49 PM
  • Hi Aleksei,

     

    The pictures are in your mail.

    After sending that mail I had a look in the eventviewer on the WHS Console and came across these Warnings in the Application section around the time I installed the HomeBase Add-In:

    (I've replaced some things with x's on the obvious data)

     

    Type: Error Source: Perflib Category: None

    The configuration information of the performance library "C:\WINDOWS\system32\aspperf.dll" for the

    "ASP" service does not match the trusted performance library information

    stored in the registry. The functions in this library will not be treated

    as trusted.

     

    Type: Error Source: Perflib Category: None

    The configuration information of the performance library "C:\WINDOWS\system32\perfts.dll" for the

    "TermService" service does not match the trusted performance library information

    stored in the registry. The functions in this library will not be treated

    as trusted.

     

    Type: Error Source: Perflib Category: None

    The configuration information of the performance library "C:\WINDOWS\system32\inetsrv\w3ctrs.dll" for the

    "W3SVC" service does not match the trusted performance library information

    stored in the registry. The functions in this library will not be treated

    as trusted.

     

    After those 3 a lot of warning entrys with Source: ASP.NET 2.0.50727.0 Category: Web Event that look like this:

     

    Event code: 3005

    Event message: An unhandled exception has occurred.

    Event time: 20-1-2008 11:10:21

    Event time (UTC): 20-1-2008 10:10:21

    Event ID: fbe979afe1fd47e6bd06a0d5bc34ecfe

    Event sequence: 12

    Event occurrence: 1

    Event detail code: 0

    Application information:

    Application domain: /LM/W3SVC/1/ROOT/HomeBaseShare-3-128452974128281250

    Trust level: Full

    Application Virtual Path: /HomeBaseShare

    Application Path: C:\inetpub\wwwroot\HomeBaseShare\

    Machine name: xxxxxxxxxxxx

    Process information:

    Process ID: 1672

    Process name: w3wp.exe

    Account name: NT AUTHORITY\NETWORK SERVICE

    Exception information:

    Exception type: ArgumentException

    Exception message: Parameter is not valid.

    Request information:

    Request URL: https://xxxxxxx.homeserver.com/homebaseshare/GetBlogPicture.aspx?userId=0

    Request path: /homebaseshare/GetBlogPicture.aspx

    User host address: xxx.xxx.xxx.xxx.

    User:

    Is authenticated: False

    Authentication Type:

    Thread account name: NT AUTHORITY\NETWORK SERVICE

    Thread information:

    Thread ID: 6

    Thread account name: NT AUTHORITY\NETWORK SERVICE

    Is impersonating: False

    Stack trace: at System.Drawing.Bitmap..ctor(String filename)

    at DataClass.WriteBitmap(String theFile, Stream theStream)

    at ASP.getblogpicture_aspx.__Render__control1(HtmlTextWriter __w, Control parameterContainer)

    at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children)

    at System.Web.UI.Control.RenderChildren(HtmlTextWriter writer)

    at System.Web.UI.Page.Render(HtmlTextWriter writer)

    at System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter)

    at System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter)

    at System.Web.UI.Control.RenderControl(HtmlTextWriter writer)

    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    Custom event details:

     

    I think that's the source of the problem. Question remaining is how do I solve this?

     

    Grtz,

     

    -=H@ns=-

    Tuesday, January 22, 2008 9:57 PM
  • I have installed as per instruction except i cannot add a user, i have a list of available users but the function to add is not highlighted.

     

    Help!

    Sunday, February 24, 2008 10:48 PM
  • Howdy,

    I will look into it by the weekend.  I am getting a new computer so that I can finally start coding again (I had been using two computers at home, I am getting one that is capable of letting me run the Home Server in VM and do some real development).  

    Its been a while since I have done anything with Home Base (see issue above) but I think if you higlight a user, the add button should be highlighted.  The users shown will be the valid users on your home server.  I think thats how it works, but I won't be able to tell you for sure until I delve into the HomeBase stuff again.

    Thank you for downloading my program and let me know if this helps your issue,

    Aleksei
    Wednesday, February 27, 2008 7:25 PM
  • I have installed the mobile client on my TyTN II and cannot connect. In the server field I cannot enter a port number and I _think_ that may be the problem. My ISP blocks all the useful ports so I have had to work around it. I even tried to enter it in the XML file however it _seems_ to be ignored. I still get the "can display error" message. I don't know if this info helps at all. I would love to get HomeBase working for file access.

     

    Thanks, Mark

    Friday, March 14, 2008 4:46 AM
  • Port changing will not work I do not think in this version.  I will keep it in mind and integrate into the next version which will be available sometime in April/Early may.  I have started coding on it again since I finally have a machine that can actually run the Visual Studio Mobile Emulator. 

    Sorry you are having problems, but I am sure we will get you up and running soon.

    Thanks,

    Aleksei

    Friday, March 14, 2008 1:32 PM
  • Aleksei,

    I sent you an email the other day asking for an update on your next version of homebase..... give me a shout.

    Thanks.
    Tuesday, April 15, 2008 11:19 AM
  •  

    Hi Aleksei,

     

    I am trying to install your AddIn to Windows Home Server Konsole: 6.0.1500.0 german.

     

    1) Version 1.0.0 is the latest version?

     

    2) DB do not uninstall after removing AddIN.

    2a) Is there an option to clean up the DB?

     

    3) DB is telling me:"Database is installed and functional"

    3a) Users: 0

    3b) Changing to Rider Users and selecting one User:

    "Invalide Objekt Name 'HBM_UserCatalog`"

    3c)I can only "Drop User" or "change photo"

    3cI)"change photo" - I choose a small jpg I get the error msg:

    "Manche oder alle Identitätsverweise konnten nicht übersetzt werden." (This makes also no sence in german!)

    After each task (Drop user/chane photo) the Console disconnects.

     

    I have 3 users:

    bw (me!)

    secure_emule

    gast

     

    This is the ErrorLOG:

    Ereignistyp: Fehler
    Ereignisquelle: .NET Runtime 2.0 Error Reporting
    Ereigniskategorie: Keine
    Ereigniskennung: 5000
    Datum:  17.07.2008
    Zeit:  18:36:39
    Benutzer:  Nicht zutreffend
    Computer: SERVER
    Beschreibung:
    EventType clr20r3, P1 homeserverconsole.exe, P2 6.0.0.0, P3 4683283a, P4 whscommon, P5 6.0.0.0, P6 473ae77b, P7 30e, P8 2f, P9 system.data.oledb.oledbexception, P10 NIL.

    Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.

    If you need more Information, I will be happy to help you!

     

    Thursday, July 17, 2008 5:13 PM
  • sw,

    I've been emailing Aleksie for some months now, but have not heard from him nor has he posted here since March.  Not sure what's up.

    I"ve used his add in for some time, but had  some issues that caused me to uninstall it.  Sorry, but I do not have any help for your problems listed above.


    There is a new add that is similar, has more functionality...but it too can be tempermental.  But, It works. It's on We Got Served Forums. It's up to version 5.0. See threads here.
    Also, here is a link to his blog with the down loads............here.


    Friday, July 18, 2008 12:19 AM
  • Judge and anyone else,

    I have been quite busy lately.  I am a student, as well as a full time programmer so I don't get as much time to work with this software as I would like to.

    I am hoping to eventually work on this again soon, but I cannot promise anything. 

    If anyone else is interested in working with my software, it has been released open source for some time.  I would be most happy to help anyone with whatever they would like (as far as answering questions) if they choose to work with it.

    I had started re-implementing HomeBase to use FireBirdSQL since SQL server was way over kill for this project.  As Judge had noted before (at least I think it was Judge) SQL server will absolutely kill performance on some platforms. 

    SW, I did not implement the clean up feature, you will have to manually uninstall. 

    If anyone wishes, they can contact me at my email address -- 

    anipirakis <at> gmail.com -- the email address attached to this profile I am posting from is not checked that often. 

    I appologize I have dropped out for a while, I will be sure to update as I can. 

    Thanks,

    Aleksei

    Alexandros "Aleksei" Nipirakis
    Monday, December 1, 2008 9:28 PM
  • Have you tried defragging you drive to improve performance and speed. Do that before you upgrade your hardware.
    Thursday, December 4, 2008 9:08 PM