none
User credentials for HPC task RRS feed

  • Question

  • The underlying problem that I am trying to solve is an inability to perform remote debugging of an HPC task. I have an x86 version of msvsmon.exe running on a compute node and I am trying to attach from VS2005 running on a Windows 2003 PC.

    If I log on to the compute node and start my console app from the command line, Visual Studio on the client can see the process and attach to it. In the "Attach to Process" dialog, the process appears with type "T-SQL, Managed, x86" and my user name. However if HPC starts exactly the same program (x86) I can still see the process from VS but the type is x64 and the user name is blank. Trying to attach to the process results in the message "Unable to attach to process. You so not have permissions to debug the process."

    I therefore have two questions:

    1. Why does the process appear as x64 even though it is compiled as x86 and definitely shows as (* 32) when viewed in Task Manager on the compute node?
    2. Why is the user name blank even though Task Manager (on the compute node) shows it as running under my credentials.

    I don't think that this a problem with Remote debugging as such since everything else about RD is behaving as expected, but it does seem to be an issue with the way that HPC is spawning processes and this then has an impact on RD.

    Thanks
    Simon
    Friday, January 8, 2010 1:15 PM

Answers

  • More information...

    I have now tried to run msvsmon.exe as an administrator using the "Run as administrator" context menu option and this has solved my problem. Visual Studio (Attach to Process) now sees the correct program type (x86/x64) and user name details. As a result, this solves my problem but of course it does not explain why the problem was largely limited to processes spawned by HPC.
    • Marked as answer by Simon Place Monday, January 11, 2010 2:33 PM
    Monday, January 11, 2010 2:33 PM