locked
Unable to back up to WHS since upgrading from Vista to Win 7 RRS feed

  • Question

  • Running a Dell Studio 17 laptop, 64 bit.  Able to connect to my WHS when purchased several months ago while running Vista.  After upgrading to Win 7 Home Premium, I receive the following error detail regarding the failed back up of laptop to the server:

    An unexpected exception occurred on the computer.

    COMException

    The request could not be performed because of an I/O device error.

    (Exception from HRESULT: 0x8007045D)

    At

    System.Runtime.InteropServices.Marshal.ThrowExceptionFor HR Internal(Int32 errorCode IntRtr errorInfo)

    I've tried reinstalling the WHS Connector after upgrade but this did not help.

    Any ideas for potential fixes greatly appreciated. 

    Thanks,
    John

    Apologies for the font mishaps.

     

    Friday, January 1, 2010 8:33 PM

Answers

  • Running a Dell Studio 17 laptop, 64 bit.  Able to connect to my WHS when purchased several months ago while running Vista.  After upgrading to Win 7 Home Premium, I receive the following error detail regarding the failed back up of laptop to the server:

    An unexpected exception occurred on the computer.

    COMException

    The request could not be performed because of an I/O device error.

    (Exception from HRESULT: 0x8007045D)

    At

    System.Runtime.InteropServices.Marshal.ThrowExceptionFor HR Internal(Int32 errorCode IntRtr errorInfo)

    I've tried reinstalling the WHS Connector after upgrade but this did not help.

    Any ideas for potential fixes greatly appreciated. 

    Thanks,
    John

    Apologies for the font mishaps.

     
    I/O errors usually represent a problem with the hard drive.  Have you tried running chkdsk /r on the drive in question?
    Saturday, January 2, 2010 4:11 PM
    Moderator

All replies

  • Running a Dell Studio 17 laptop, 64 bit.  Able to connect to my WHS when purchased several months ago while running Vista.  After upgrading to Win 7 Home Premium, I receive the following error detail regarding the failed back up of laptop to the server:

    An unexpected exception occurred on the computer.

    COMException

    The request could not be performed because of an I/O device error.

    (Exception from HRESULT: 0x8007045D)

    At

    System.Runtime.InteropServices.Marshal.ThrowExceptionFor HR Internal(Int32 errorCode IntRtr errorInfo)

    I've tried reinstalling the WHS Connector after upgrade but this did not help.

    Any ideas for potential fixes greatly appreciated. 

    Thanks,
    John

    Apologies for the font mishaps.

     
    I/O errors usually represent a problem with the hard drive.  Have you tried running chkdsk /r on the drive in question?
    Saturday, January 2, 2010 4:11 PM
    Moderator
  • Just ran it at startup with instruction to automatically fix any errors, so didn't see report.

    Unfortunately, this did not help.  Same problem with back up.
    Sunday, January 3, 2010 2:26 PM
  • Success!  After figuring out admin control of command prompt in Win 7 (http://forums.techarena.in/vista-help/863427.htm), I ran chkdsk / r and it found and fixed a corrupt video driver.

    Other threads with same problem indicate this is a reliable fix, but sometimes takes more than one chkdsk run.

    http://social.microsoft.com/Forums/en-US/whshardware/thread/dd90b501-b078-4943-9e63-e22e3fb56c60

    Thanks for the help.
    Sunday, January 3, 2010 6:00 PM