locked
crm 2011->the web page you are viewing is trying to close the window RRS feed

  • Question

  • Hi all:

    I did an upgrade from v3->v4->v2011, and when CRM is opened in IE the users gets a
    dialog pop-up that says "The webpage you are viewing is trying to close
    the window. Do you want to close the window?" Clicking Yes closes the
    window and brings up CRM in a new window.

    The customer does not like this action and I have been unable to stop it. I was
    thinking it might be an IE setting, I put CRM into the Local Intranet zone and
    the log on settings in the security is set to "automatic logon in Intranet
    Zone only".

    Can anyone make a suggestion on how I can stop this?

    Thanks in advance.

    John.



    Wednesday, May 16, 2012 12:25 PM

Answers

  • Hi John,

    You just need to change the setting in CRM.

    Go to Settings->Administraton->System Settings->Go to Customization Tab

    and Disable Open Microsoft Dynamics CRM in Application mode.

    Once this is done, close the IE and access the CRM again.

    Regards,


    Khaja Mohiddin
    http://www.dynamicsexchange.com
    http://about.me/KhajaMohiddin

    Wednesday, May 16, 2012 12:58 PM
  • Hi John,

    What version of IE does your customer running on?

    Have you tried browsing to the main.aspx directly? Eg: http://<CrmServer>/<OrgName>/main.aspx#


    Dimaz Pramudya - CRM Developer - CSG (Melbourne) www.xrmbits.com http://twitter.com/xrmbits

    Wednesday, May 16, 2012 12:55 PM

All replies

  • Hi John,

    What version of IE does your customer running on?

    Have you tried browsing to the main.aspx directly? Eg: http://<CrmServer>/<OrgName>/main.aspx#


    Dimaz Pramudya - CRM Developer - CSG (Melbourne) www.xrmbits.com http://twitter.com/xrmbits

    Wednesday, May 16, 2012 12:55 PM
  • Hi John,

    You just need to change the setting in CRM.

    Go to Settings->Administraton->System Settings->Go to Customization Tab

    and Disable Open Microsoft Dynamics CRM in Application mode.

    Once this is done, close the IE and access the CRM again.

    Regards,


    Khaja Mohiddin
    http://www.dynamicsexchange.com
    http://about.me/KhajaMohiddin

    Wednesday, May 16, 2012 12:58 PM
  • This machine has IE 7. Going directly to main.aspx did it! Thanks.

    John.

    Wednesday, May 16, 2012 1:35 PM
  • Hi Khaja,

    on the computer of the one of our users; we click "yes" button but it does not close the window and CRM 2011 has an error.

    Wednesday, August 21, 2013 12:57 PM
  • We are using Dynamics 365 and only some users IE 11 were getting the popup "The webpage you are viewing is trying to close the window. Do you want to close the window?" and it seemed to be associated with a popup from another domain www.crmdynint.com. I looked into the Application Mode option and that appears to be locked now and users cannot change it.

    I searched across many articles and made several changes to the Internet Options settings and none of them worked. I started playing with the Tools/Internet Options/Security/Trusted Sites/Sites and found that if I removed all references to *.crm.dynamics.com domains, then the annoying popup stopped. I tested adding the *.crm.dynamics.com to Local Intranet and the problem came back. I had originally added that domain to my trusted sites because I wanted more of an SSO-like environment, but it seems that Azure AD is better about how federated identities work across their products so it is not necessary.

    If you found this useful, please vote for my answer.

    Thanks!

    Tuesday, July 25, 2017 2:48 PM