locked
IIS on WHS diskpool RRS feed

  • Question

  • Hello,

    Since my photoalbums are growing I decided to move my websites from tiny tiny 20 gb C: to \\server\web. I left WHS-site untouched on c:\

    I have no problem running my websites (IIS connect to share as WHS-user) from the diskpool and *finally* I get duplication! :)
    All is well except for some folders which I used to use NTFS permissions on, IE would prompt for a username/password that must exist on the server in order to display the webpage. In other word I turned of anonymous access to the directory via IIS-manager. This worked fine on C: but I can not get it to work when IIS think it is accessing a network share.

    Dumb as I am I moved the original folder from C: to \\server\web so I can not double check NTFS permissions..
    This is really not WHS-related, except for the fact that WHS builds a number of groups (RW_D, RO_K etc) that I have absolutley no clue about. These are inherited via NTFS.

    I have gotten so far as getting IIS to prompt for a username/password for a specific directory, but the problem is that any WHS account will do. I want it to be just a specific account that can gain access to pages within this specific directory with the site located on \\server.

    I know this is "not supported on WHS" but maybye someone out there has solved this already?

    /sudda
    Saturday, April 4, 2009 12:30 PM

Answers

  • I have gotten so far as getting IIS to prompt for a username/password for a specific directory, but the problem is that any WHS account will do. I want it to be just a specific account that can gain access to pages within this specific directory with the site located on \\server.

    I know this is "not supported on WHS" but maybye someone out there has solved this already?
    Your solution is going to be to move your web sites back out of the shares. Trying to manipulate permissions in the shares from any interface other than the WHS console (where the granularity is the entire share) is A) unsupported (as you admit), B) not always effective (as you've found), and C) may cause other problems if you do the wrong thing.
    I'm not on the WHS team, I just post a lot. :)
    • Proposed as answer by Ken WarrenModerator Monday, April 6, 2009 4:04 PM
    • Marked as answer by sudda Friday, April 10, 2009 1:45 PM
    Monday, April 6, 2009 4:04 PM
    Moderator

All replies

  • I have gotten so far as getting IIS to prompt for a username/password for a specific directory, but the problem is that any WHS account will do. I want it to be just a specific account that can gain access to pages within this specific directory with the site located on \\server.

    I know this is "not supported on WHS" but maybye someone out there has solved this already?
    Your solution is going to be to move your web sites back out of the shares. Trying to manipulate permissions in the shares from any interface other than the WHS console (where the granularity is the entire share) is A) unsupported (as you admit), B) not always effective (as you've found), and C) may cause other problems if you do the wrong thing.
    I'm not on the WHS team, I just post a lot. :)
    • Proposed as answer by Ken WarrenModerator Monday, April 6, 2009 4:04 PM
    • Marked as answer by sudda Friday, April 10, 2009 1:45 PM
    Monday, April 6, 2009 4:04 PM
    Moderator
  • Never! Must solve this. Must. :-)) Actually, when adding albums from my Nikon D90 there is is no going back. My webalbum has now grown far above 10 gb and totally would fill up tiny tiny C: I was thinking of using D: but then I would not get duplication. I'll have to do some more thinking/testing..
    Friday, April 10, 2009 1:41 PM
  • Rather than using D: you should add a drive and leave it out of the storage pool.

    You could take a look at whiist (see the developers forum). I don't want to host web albums locally, so while I know it has the ability to create albums, I don't know exactly how it does so or what security it supports. Or you could look at upgrading to an HP MediaSmart Server, which has the capability you're looking for as part of it's photo sharing software. Or you could host your web album with some Internet Presence Provider, which is what I do.
    I'm not on the WHS team, I just post a lot. :)
    Friday, April 10, 2009 2:54 PM
    Moderator
  • I'm having a similar problem here with WHS shares and IIS.

    I'm running a small jukebox script on my page and used the junction.exe command to create a symbolic link between my jukebox/music dir in IIS and d:\shares\Music.

    IIS user is thrown out of the NTFS file permissions once every couple of hours / restart and figured out it is WHS doing this.

    How can I add the IUSR account and prevent WHS from overwriting these settings? It's really frustrating!

    Moving 40 Gb of music files is not an option because I need to access the same music files from elsewhere in the house via the WHS share.

     

    Friday, November 12, 2010 12:29 PM
  • Try adding the account to the groups that Windows Home Server uses to maintain permissions in the shares.
    I'm not on the WHS team, I just post a lot. :)
    Friday, November 12, 2010 1:29 PM
    Moderator
  • Hi Ken!

    That did the trick! Now I know why there are 5 medals next to your avatar. :)

     

     

    Friday, November 12, 2010 4:19 PM
  • … Now I know why there are 5 medals next to your avatar. :)

    To be honest, those are mostly due to the fact I mention in my .sig. :) Though I do generally try to help, or at least explain, when I post.

    You should bear in mind that any changes you make to your server from a desktop application or tool are at least technically unsupported. Given that, it's possible (though unlikely I think) that you'll experience other issues as a result of your changes and unanticipated use of your server.


    I'm not on the WHS team, I just post a lot. :)
    Friday, November 12, 2010 5:41 PM
    Moderator
  • Hi!

     

    Just for info. The trick did not work. I found a workaround by placing the HTML files in the music share itself then map a virtual directory in IIS to the \\SERVER\Music share. In IIS you can specify the credentials used to connect to the music share, I created a read-only account for this in WHS user manager and that did the trick.

     

     

    Thursday, November 25, 2010 11:40 AM