The file cannot be accessed by the system. RRS feed

  • Question

  • Hello, I had an install of WHS on my machine, keeping all of my music, videos and and software in the shares folder. For some reason, WHS got corrupted and wouldnt boot, so I have reinstalled Windows Server 2003 over the WHS install.

    Now I cannot access any of the file in the shares folder, I just get a message saying "The file cannot be accessed by the system". Theres like 300GB of stuff sitting there, cant be used or deleted.


    Please help.

    Monday, March 29, 2010 7:34 PM

All replies

  • Right Click on the folder.  Select security, take ownership - you have to be logged in the Administrator.




    • Edited by Al West Monday, March 29, 2010 8:20 PM
    Monday, March 29, 2010 8:17 PM
  • I already am Administrator and ive taken ownership. Still "The file cannot be accessed by the system"
    Monday, March 29, 2010 8:19 PM
  • Are you looking in d:\DE\shares?
    Monday, March 29, 2010 9:08 PM
  • Windows Home Server doesn't use "D:\Shares" as the place where your actual files are stored. All it puts there are pointers to the actual files, and those pointers can only be used by Windows Home Server. Your actual files will be on D: (and any other drives you had in the storage pool) in a hidden folder <driveletter>:\DE\Shares\etc. You can find out more about how to recover files in this FAQ.
    I'm not on the WHS team, I just post a lot. :)
    Monday, March 29, 2010 9:22 PM
  • Hmmm, the DE folder just has a folder called folders in it.
    Monday, March 29, 2010 9:41 PM
  • Did you have other drives in your server? What about them?
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, March 30, 2010 4:15 AM
  • No, no other drives
    Thursday, April 1, 2010 2:56 PM
  • How much space is reported as used for the D:\ drive ?  Have you set in Explorer options to view hidden and system folders?

    Thursday, April 1, 2010 4:19 PM
  • Yes, hidden folders are viewable. I can see the DE folder, there is just nothing in it. Also... there is 302GB of 500 free, so I dont think the files can be there :(
    Thursday, April 1, 2010 5:08 PM
  • Try running chkdsk /r on the data partition.
    I'm not on the WHS team, I just post a lot. :)
    Thursday, April 1, 2010 5:58 PM
  • Hi, I am getting the same error because I just bought a new HDD. I did a fresh install of WHS on the new 2TB HDD, and then booted with the old 1TB HDD as a secondary drive. This means that the old one still has SYS and DATA partitions. On the old and new installs only 1 drive has ever been in the pool. 

    All I want to do is copy and paste from the old drive to new drive, but I am getting "The file cannot be accessed by the system". I am 99.9% confident the data has not been corrupted in the old drive as nothing has happened to it. I tried taking ownership, to no avail. 

    It looks like my option here is to unplug the new 2TB drive, and boot from the old 1TB, then copy the files I need to an external drive and then to the 2TB drive, but this is an extra step that is hassle because the biggest external I have is 500GB.

    Update: It seems to work from old to new hdd, when booting in the old WHS install. But I still think the below question is valid if hypothetically the WHS install may be damaged.

    Has anyone got any other suggestions on how I can get the old installation of WHS to relinquish control over the files in the old drive?

    Thursday, April 22, 2010 10:50 PM
  • Thank you Ken!!  Such a simple solution to the same problem I was having.

    Friday, March 20, 2015 11:25 PM