locked
WHS V1 Console will NOT launch on clients 'error connecting to Windows Home Server' RRS feed

  • Question

  • Good Morning,

    I want to thank you in advance for any direction or advice.  I think I have seen this problem at least once before, but for the life of me cannot remember what I did to fix the issue.  (Chance I ended up reinstalling the WHS, but I am always working on the hardware so that is not an issue for me, for my client, I am not going to be able to go this route as easily).

     

    I got a call from them and on all of the client machines attached to the WHS (V1), the clients see the console launcher, the attempt is made to launch it, put password in and it seems to accept, but then the clients come back with an error that the connection is being reset, and they are not able to complete the connect.

    Now,  the shared folder directory is coming up fine, I logged in remotely to one of the client machines and was able to browse the shared folders, but I am not able to get the console to come up on the client.

    The unit is one of those HP Mediacenter boxes.  Looks the size of a small NAS. 4 bay setup.  I am not as familiar with these units, as I have historically built WHS boxes for both client and myself.

    My fear is that the WHS needs to be reinstalled, in which case I need to migrate their data off the unit before doing so, but it sure would be nice if there is a repair option that I may be missing.

     

    To recap:

    WHS V1 on an HP Mediacenter box

    Client machines enter in password to Console, WHS comes back with a failure to connect the console ('connection reset')

    Can browse shared folders and files, but console will not come up on any client machine.

     

    Thank you for any direction in this.  I know there is very little I am able to do with regard to logging in directly on those little HP boxes, so any suggestion on how to remedy the client FROM the client would be most appreciated.

     

    -Andrew

    Tuesday, September 20, 2011 2:32 PM

All replies

  • Are you able to connect to your server using Remote Desktop?

    As for recovery, the server shipped with a server recovery disk. The instructions on how to use it are in the product documentation, but briefly:

    • Boot the server while holding down a recessed button.
    • Boot a computer on your network using the server recovery disk.
    • Work through the wizard, choosing the recovery option rather than "factory reset".
    • Wait for it to complete (hours to days, depending on the amount of data on the server, and it will look like it's hung at some point...).

    You'll lose anything stored in the system partition (C:) so:

    • users; you'll recreate them and they'll be rejoined to their "user" folders
    • information about home computers, though not their backups, which you can still access using the home computer restore CD, or once you've rejoined a computer to the server, the console and "single file" restore mode
    • Add-ins, possibly including configuration if the add-in doesn't use the proper APIs to store configuration and other data persistently
    • anything you did using the server desktop, like install programs, create users outside of the console, etc.

    I'm not on the WHS team, I just post a lot. :)
    Tuesday, September 20, 2011 2:44 PM
    Moderator
  • Good Morning Ken,

     

    Long time no talk, certainly appreciate you and the time you put in. Thank you again.  I have not actually tried to RDP to it yet, I will try doing that today when I talk to the client.

     

    IF I am able to connect to the HP unit via RDP, my gut was telling me that something has become corrupt with the user authentication or something of that nature.

    And so I am understanding correctly, I *can* boot a client and restore the WHS, but I WILL NOT have to actually connect external storage and remove data before doing so?  That would be a time saver to say the least, I know they have not accessed the unit via RDP, so my confidence is high that there are no personal files or folders that have been stored on the Primary partition.  As far as rejoining the users to the WHS and to their user directories, that would be fine, and an expected consequence of resetting the sever to a factory install.

     

    I am also confident they have not configured or installed any widgets on that machine.  Only thing done was adding in extra HDD storage space.  Besides that, they have used it up to this point as it came out of the box.

     

    All of this being said,  IF I can get into the WHS via RDP.  Any suggestions on what I should be looking for with regard to why the console connect from clients seems to be corrupted?

     

    Thanks again for the help and direction,

     

    -Andrew

    Tuesday, September 20, 2011 4:27 PM
  • I want to know if you can use remote desktop to connect directly because, if you can, the issue is probably not on the server. The console uses a remote desktop connection (with all "chrome" removed) to function.

    If the issue is on the clients, I'm guessnig some update has caused it, but I'm not going to be much help identifying which one. :) How long has the  problem existed?


    I'm not on the WHS team, I just post a lot. :)
    Tuesday, September 20, 2011 5:34 PM
    Moderator
  • I apologize for the delay.  Was out with clients all yesterday afternoon.  Calling this client this morning to see if I can get RDP to work.  From what I understand, this has been a problem for going on 9 months now.  They said everything worked fine for 2 months after I helped them get the initial setup working.  Then it stopped working, yet they never called me.  So as far as looking back to isolate what happened....chances are slim I would be able to.

     

    Again, thank you for your help, I am going to call the client and attempt to RDP to the machine this morning.  Will post back with the results.

     

    -Andrew

    Wednesday, September 21, 2011 3:21 PM
  • No apology needed.

    After months, good luck. There's no way you'll figure out the original cause (unless you're super lucky; how often do you hit the lottery?). You can try setting up a VM with e.g. Windows 7 on some machine (or take a laptop with one pre-configured), then join that to their server and see what happens, though I'd bet either you'll have the same issue there or the client installation will fail as "unable to contact" server or something like that.


    I'm not on the WHS team, I just post a lot. :)
    Wednesday, September 21, 2011 3:56 PM
    Moderator
  • Sir, good morning again,

     

    Was able to get ahold of the client this morning and Went into one of the client machines on the network.  Got RDP running, and I was able to touch the Home server.  Got a UID/PW challenge box up, but the UID/PW was not allowing access.

     

    Its literally like the user data ON the server has gotten corrupted.  Anyway, I am at a bit of a loss here as to where to proceed, so any direction you can suggest would certainly be appreciated.  Again, RDP touches the server, but I cannot authenticate in the same way I was unable to with the 'console'.

     

    I have verified that the client does have the 'server recovery disk', and can go that route. Hoping to exhaust all other options first though, as you can imagine. 

     

    Thank you again for your time,

     

    -Andrew

    Thursday, September 22, 2011 4:14 PM
  • Okay, so you used the user "Administrator" and the password for the console, right? Nothing else will normally do; it's the only account which, by default, is permitted to log on that way.

    If users are able to access shares normally, I don't think it's corrupted user data. I think someone changed the password for the console (i.e. changed the administrator password) and forgot it. PEBCAK.

    Recovery: there are ways to crack the SAM database. I don't like them very much, no matter which hacking method you use. They're slow, not guaranteed to work, and I hate to "give props" to virtual burglars, especially since most tools are the electronic equivalent of a rock through a window. That leaves you with server recovery, I'm afraid.


    I'm not on the WHS team, I just post a lot. :)
    Thursday, September 22, 2011 4:28 PM
    Moderator
  • I had him attempt to log in with an account that has 'administrative' access.  He was going to get back to me today when he found the notes he kept with regard to the actual Admin password.  I am going to be trying that again later today just to confirm one way or the other that the admin account works and RDP is working. 

    I guess where I am confused about this is, regardless of if the Admin account had its password changed and forgotten due to a PEBCAK error, and the user data isn't corrupt, they *should* be able to add in another machine, installing the client connect software and use their current user ID/PW challenge and have the process complete?

     

    And yes, I am aware of some brute force methods, not a fan, and I realize that I am currently working my down the path that is labeled 'Server Recovery ---->This Way'.  Is anyone aware of a recovery password tool that would be by HP, if, say I had the client call HP, give the serial number (this is assuming they registered their product with the product warranty department back when they purchased the unit), and have a way to reset that password, IF that is the problem that is causing this cascade of issues?


    I feel I have taken up an inordinate amount of your time on this problem, Ken, to be honest.  Please feel free to respond with "sorry, but at this point you are on your own", if you don't have the resources to keep digging on this with me.  I do thank you again for your help, going to call the client now and see if he has been able to attempt connecting to the unit with RDP and the Administrator/password that he *hopefully* has found.

     

    -Andrew

    Thursday, September 22, 2011 7:23 PM
  • Don't worry about the time this is taking. :)

    The basic test that is most likely to help you troubleshoot this (and I think you've already done it) is to try to connect to the server with Remote Desktop using the username "Administrator" and the password you believe to be correct for the console. If you can connect, but get an authentication error, which is where I believe you are today, either the username of the Administrator account was changed (unlikely), or the password was changed. Just in case it was set to a useful value, you should be able to get a password hint when you double click the Windows home Server Console icon.

    Assuming you get the authentication error with remote desktop, and the password hint isn't useful, if you have an alternate administrator account on the server (probably set up outside the Console, via Remote Desktop and the management tools available there), you can try logging in with that alternate account and reset the Administrator account password. That has consequences, obviously, and I don't guarantee you'll have a fully funcitonal server afterward, because Microsoft took some shortcuts behind the scenes and the Administrator account owns more than one might expect (so you may need to recover the server afterward anyway).

    For server recovery, read the documentation carefully, and consider taking a drive with you, connecting it to some computer on their network, and jsut copying everything in the shares to the external drive just in case recovery fails for some reason.


    I'm not on the WHS team, I just post a lot. :)
    Friday, September 23, 2011 1:20 PM
    Moderator