locked
CRM 2013 web page access problem RRS feed

  • Question

  • Hi, 

    Recently installed CRM 2013 and have problem with access to web.  Getting  "Unexpected error" in browser.

    In event viewer I see error "The initialization of the CRM authentication pipline has failed and all user requests to this CRM Server role computer will be denied."  Event ID 17205. 

    Setup info:

    MS CRM 2013 SP1 UR4 on windows server 2012 R2

    SQL server v version 2014 CU 6 on win 2008 R2

    Reporting SQL version 2014 CU 6 on win 2012R2

    All CRM services configured to run under domain service users. 

    Firewall's are turned off. 

    Can someone help with this issue?

    Thank you.




    Thursday, July 28, 2016 11:13 AM

All replies

  • is this ifd and claims or just windows? in your IIS check your application pool account, also collect logs with Crm Maintenance tracing tool (2011).

    if it is ifd and claims... check SPN or if never set, then set SPN


    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Thursday, July 28, 2016 12:58 PM
  • Hi Daniel ,

    It's just windows. What do you mean when saying "in your IIS check your application pool account" both CRM app pools (CRMAppPool and CRMDeploymentServiceAppPool)  are working under specified service accounts. Both accounts are added to IIS_IUSRS local security group on CRM server. 

    Thursday, July 28, 2016 1:08 PM

  • gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Thursday, July 28, 2016 1:10 PM
  • Check if the identity is your applicaionpoolaccount user

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Thursday, July 28, 2016 1:11 PM
  • Yes, it is 

    In tracing logs I also see this error message: 

    Error retrieving authentication setting XML from database for authentication strategy : OnPremise and type : CrmAuthentication.  There should only be 1 and only 1 configuration defined for each authentication strategy (i.e. Live, OnPremise, SPLA, Portal...), ErrorCode: -2147220970, InnerException: System.InvalidOperationException: 

    >Type: Microsoft.Crm.CrmInvalidOperationException
    >ErrorCode: 0x80040216: ErrorCodes.UnExpected
    >Message (257): Error retrieving authentication setting XML from database for authentication strategy : OnPremise and type : CrmAuthentication.  There should only be 1 and only 1 configuration defined for each authentication strategy (i.e. Live, OnPremise, SPLA, Portal...)
    >StackTrace: present: 2416DE24


    Thursday, July 28, 2016 1:32 PM
  • its not integrated in your shot its classic

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Thursday, July 28, 2016 1:33 PM
  • Yes, but this was by default I don't changed something here. 

    Also if I'm changing it to integrated another error comes:

    Thursday, July 28, 2016 1:41 PM
  • ok, change back to classic and in advanced enter again your applicationpool account with domain\

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Thursday, July 28, 2016 2:12 PM
  • is windows authentication installed as a feature in roles?


    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Thursday, July 28, 2016 10:14 PM
  • Yes windows authentication feature is installed.

    I also tried to enter again app pool account, but with no success.

     
    Friday, July 29, 2016 5:40 AM
  • is it an upgraded organization, can you if not create a new organization. and also you can enable tracing in IIS and post the error

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Friday, July 29, 2016 7:19 AM
  • This is absolutely newly created organization (was created during the CRM installation).

    When you saying "enable tracing in IIS" do you mean failed requests tracing?


    Friday, July 29, 2016 7:40 AM
  • yes failed request tracing

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Friday, July 29, 2016 7:44 AM
  • I enabled tracing for CRM web site in IIS, but unfortunately logs are not being created when I try to access CRM web. 
    Friday, July 29, 2016 8:29 AM
  • difficult wihtout access.. you installed sp1 and then RU4 and tested before if it had worked?

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Friday, July 29, 2016 8:34 AM
  • try unisntalling Updaterollups and test, could be installation error

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Friday, July 29, 2016 8:36 AM
  • I already tried to just install CRM 2013 without SP1 or rollups same error.

    Maybe it's can be somehow related to SQL version.

    Friday, July 29, 2016 8:38 AM
  • 2014 is supported and we run also in this configuartion for some customer

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Friday, July 29, 2016 8:42 AM
  • Probably next step should be MS support ticket :)

    Friday, July 29, 2016 8:48 AM
  • just to be clear you hvae enabled windows authentication in IIS?


    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Friday, July 29, 2016 8:49 AM
  • before opening case, you should go ahead and reinstall fresh copy and before appling any CUs or updates test if the rootorganization works out of the box

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Friday, July 29, 2016 8:52 AM
  • Yes, configuration same as in your shot. 
    Friday, July 29, 2016 8:53 AM
  • I tried to reinstall several times: with sp, without sp and with UR and without. In all cases getting same error. 

    Friday, July 29, 2016 10:55 AM
  • did ou also reinstalled windows server? a look into events in sql? any unknown GPO?

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Friday, July 29, 2016 11:00 AM
  • Don't think that windows server reinstall is needed because it was fresh install of OS from standard template.

    I made a backup of server before installing CRM and recovered machine when it was needed to reinstall CRM. 

    No unknown GPO's applied.

    I Will check SQL events.

     

    Friday, July 29, 2016 11:32 AM
  • Nothing strange in SQL logs 
    Friday, July 29, 2016 12:16 PM
  • in this article in section analyze is a script, what is the result for auhentication pipeline?

    https://blogs.msdn.microsoft.com/crm/2009/06/10/crm-authentication/


    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Friday, July 29, 2016 9:13 PM
  • If you are talking about this script: 

    select a.ConfigurationName, ap.ColumnName, ap.NVarCharColumn
    from dbo.AuthenticationSettings a, dbo.AuthenticationSettingsProperties ap
    where a.id = ap.id
    and ap.NVarCharColumn like'%<%'

    result is null. Both these tables are empty. 

    Monday, August 1, 2016 6:08 AM
  • You really should set up fresh and also with fresh windows server, don´t use your images...

    could be things like doubled SID with images...


    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Monday, August 1, 2016 10:46 AM
  • Looks I have found the reason (my fail) for this error. CRM setup was done via config.xml file with parameter <Database create="true" update="false"/>. That means that config DB was created, but required info was not inserted. 
    Monday, August 1, 2016 11:06 AM
  • make sence output is empty

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Monday, August 1, 2016 11:07 AM