locked
Visual studio project not opening RRS feed

  • Question

  • I have been working on a project for the last few months.Yesterday i was working with my project as well.There were no error until i installed GemBox.Spreedsheet.After installing gembox.speerdsheed,if u follow the usage procedure in the dev's website,u can see that using gembox spreadsheet requires you a license which you need to place in a new Public Sub.But just after i added the lines of code containing the license,i debugged my application and it gave me an error saying

    ** Could not load file or assembly 'Tabcontrolclass, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0a001c7cd8ca5785' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) File name: 'Tabcontrolclass, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0a001c7cd8ca5785'**

    TabControlClass is my custom made tabcontrol...Anyway, after getting this error yesterday, i turned off my pc and today when i turned on my pc and opened my solution...The visual studio windows is blank.I noticed that the PLATFORM was changed to ANY CPU which had been x64 till today.Then i changed it back to x64.Then i went to solution explore and tried to open a form.But every form i try to open...vs takes forever to open the form showing "OPENING THE FILE..."..Then i closed and restarted vs, wen to solution explorer>references and WOOOOOAAAHHHHHHH...ALL MY REFERENCES GOT YELLOW TRIANGLE...I can't work on my project any more...Please somebody help me...

    I tried changing the .net framework version from 4.5.2 to 4.5 and again setting it back to 4.5.2(4.5.2 is what i had been using) but with no luck.Please help me!


    Thursday, November 16, 2017 12:51 PM

All replies

  • If you edit the project (.vbproj) file with notepad you could remove all the references to the gembox.

    On a sidenote, there are more reasons not to use 3rd party controls than there are reasons to use them. Looks like you have run into reason  #134


    Live as if you were going to die today, learn as if you were going to live forever -Mahatma Gandhi

    Thursday, November 16, 2017 2:31 PM
  • Hi Aousaf,

    According to your description, you said that your project works fine before, and you have this error message when you installed gembox.speerdsheed, so I think you may go to gembox site to seek better and more professional help.

    Best Regards,

    Cherry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Proposed as answer by Stanly Fan Monday, November 20, 2017 12:55 AM
    Friday, November 17, 2017 8:33 AM