locked
Remote Web Access with firefox: mixed languages RRS feed

  • Question

  • When I use the Remote Web Access of my brand new Homeserver with IE all things work finde. If I do the same with fierfox I have a  funny mix of Germn and english on the pages. Does anybody know something about the  issue?

    Thomas

     

    Wednesday, November 30, 2011 10:56 PM

All replies

  • Doubt that has anythng to do with WHS 2011. You might want to check the Firefox forums.
    Thursday, December 1, 2011 2:44 AM
  • We have the exact same issue on a Windows Server 2008R2, so this is not limited to WHS.

    When visiting the Remote Web Access (RWA) site with Firefox which has "de-de" listed as first language, then half of the text on the website is in English and half of it is in German. If you change the preferred language to just "de" then all the text is in German.

    This looks like a bug in RWA.

    Wednesday, June 6, 2012 1:53 PM
  • Thomas and welph,

    Thanks for reporting the issue. Could you please let me know in which page you see the mix of German and English? And which contents/menus are in English and which are in German?

    Thursday, June 7, 2012 7:56 AM
  • It happens on every page. For example on the start page (https://servername/Remote) it says "Remote Web Access: Remotearbeitsbereich for welph", or "E-Mail abrufen" and then below "Check Email". By default the HTTP language header in a German Firefox is as following: accept-language de-de,de;q=0.8,en-us;q=0.5,en;q=0.3. If I change this to something else, eg "en-us, en, de-de, de" then everything is correctly printed in German: "Remotewebzugriff: Remotearbeitsbereich für welph".

    Here are some more funny examples with different language priorities in Firefox:

    • en-us, en, de-de: RWW is in German
    • de, en-us: RWW is in English
    • de, en: RWW has a mixture of English and German as shown above
    • en, de: RWW is in German
    • de, en, de-de: RWW is in German
    • de-de, en, de: RWW is in German
    • de-de, de, en-us: RWW has a mixture of English and German as shown above
    • de: RWW is in German
    • de-de: RWW is in German

    The rule of thumb seems to be:

    1. If a language code with a country is listed (like "en-us"), then every language code without a country (like "en") is ignored, regardless what priority it has.
    2. If "de-de" is found anywhere, then RWW is shown in German, except if it has the highest priority and there are other languages listed, then RWW is showing a mixture of German and English.
    3. The former rule is also true for "de", as long as no country codes are specified, otherwise rule 1 gets applied.

    I believe this bug is independant of the browser. The reason why users don't see it with Internet Explorer is because IE only sends "de" as an accepted language by default. The system I tested this on is SBS 2011 Standard German.

    Friday, June 8, 2012 9:29 AM
  • Hi welph & tower,

    Could you please help to upload some screenshot or the detailed reproduce steps?  Thus the product team can see the details about this bug.

    OR you can submit a bug on SBS 2011 Standard Connect Site. The product manager can recive your bug directly. And your bug will be addressed carefully.

    Thanks

    Monday, August 20, 2012 5:51 AM
  • By the way, the link of Connect Site:

    https://connect.microsoft.com/SBS/feedback/CreateFeedback.aspx

    don't forget to join the Windows Server Solution product. :)

    Monday, August 20, 2012 5:55 AM
  • See Screenshot below. Folder and user names have been changed for privacy reasons, but you can still see the mixed languages.

    Screenshot of RWA

    Wednesday, August 22, 2012 9:38 AM