locked
How to change the server of dynamics crm4.0 RRS feed

  • Question

  • Hi


    I have installed my production server of crm on one domain and testing server on another domain.
    Now I want to use only my testing server i.e., I want to make my Testing server as Production server.

    All my data is present in the Production server. I need to use that data with this crm in the Test server.
    So, what all things do I need to make to achieve this?

    I have taken the backup from the production database.
    But, these two servers are on different domains. So, even if I try to replace the testing database with the production one, how can we change the domain settings and how to create new users?
    Also, I made some customizations on the production server. So, do I need to import all those customizations in the testing server


    To be clear my question is :
    Can I use this New Server(Testing server) on different domain with data present in the old database(Production database) in different domain??? where are the domain settinga are set? How can we change them?


    It is very urgent to make these changes...
    Can any one tell me how sould I proceed to achieve this.


    Thanks in advance...

    Saturday, June 13, 2009 4:46 PM

Answers

  • Hi,

    what you have to do is the followin:
    Restore your production database on the new SQL server with a different name, may be test.
    Then use the Deployment manager to import the Database in the CRM on your testserver. The wizzard ask you for the new Domain and the users.


    Viele Grüße

    Michael Sulz
    axcentro GmbH
    Sunday, June 14, 2009 1:29 PM
  • Hi,

    i think so.
    In this case, you have to install the rollup update 4, what you can find here:

     

    http://www.microsoft.com/downloads/details.aspx?displaylang=de&FamilyID=0ddf8e83-5d9c-4fe7-9ae6-f2713a024071


    Viele Grüße

    Michael Sulz
    axcentro GmbH
    Monday, June 15, 2009 10:43 AM
  • Hi,

    when your crm server has a 32bit OS, than you have to install the x86 file CRMv4.0-KB968176-i386-Server-ENU.exe, for a 64bit OS the file CRMv4.0-KB968176-amd64-Server-ENU.exe.


    Viele Grüße

    Michael Sulz
    axcentro GmbH
    Tuesday, June 16, 2009 4:08 PM

All replies

  • Hi,

    what you have to do is the followin:
    Restore your production database on the new SQL server with a different name, may be test.
    Then use the Deployment manager to import the Database in the CRM on your testserver. The wizzard ask you for the new Domain and the users.


    Viele Grüße

    Michael Sulz
    axcentro GmbH
    Sunday, June 14, 2009 1:29 PM
  • Hi Michael,

    Thanks for your suggestion.
    I tried in the way and almost everything is working fine.
    But, workflows are not triggering and reports are not running.
    I am able to create reports but when I tried to run it is giving an error:
    Reporting Error.Try again...in the popup window of the report
    Also I am unable to import the data. After importing the status remains 'submitted'. I believe that this is also a problem with workflow.

    Is there anything still I need to do?



    -Thanks
    Perfectionist
    Monday, June 15, 2009 10:01 AM
  • Hi,

    are on both server the same CRM-Updates installed?

    To repair the Reporets, you can run a repair-installation from the crm-server. when you have custom reports, you have to save this reports bevore you run the setup with repair option.
    Viele Grüße

    Michael Sulz
    axcentro GmbH
    Monday, June 15, 2009 10:19 AM
  • Hi,

    I refered this link which is explaining the same problem I was facing
    http://support.microsoft.com/kb/950680/
    Is this the reason for my issues?


    -Thanks


    Perfectionist
    Monday, June 15, 2009 10:24 AM
  • Hi,

    i think so.
    In this case, you have to install the rollup update 4, what you can find here:

     

    http://www.microsoft.com/downloads/details.aspx?displaylang=de&FamilyID=0ddf8e83-5d9c-4fe7-9ae6-f2713a024071


    Viele Grüße

    Michael Sulz
    axcentro GmbH
    Monday, June 15, 2009 10:43 AM
  • Hi,

    I downloaded the files from the given link for update rollup4
    But, there are nearly 4 files which are relative to x86.
    From those I installed CRMv4.0-KB968176-i386-SRS-ENU.exe and tried to access the leads. It is not displaying the leads and is giving an error message.
    So, I uninstalled that one and tried the one in this link
    http://support.microsoft.com/kb/950680/
    Now it is displaying the leads but the workflows are still not working.

    Is there any particular rollup for this issue?


    -Thanks


    Perfectionist
    Monday, June 15, 2009 11:58 AM
  • Hi,

    when your crm server has a 32bit OS, than you have to install the x86 file CRMv4.0-KB968176-i386-Server-ENU.exe, for a 64bit OS the file CRMv4.0-KB968176-amd64-Server-ENU.exe.


    Viele Grüße

    Michael Sulz
    axcentro GmbH
    Tuesday, June 16, 2009 4:08 PM