locked
CRM 2011 Documents on SharePoint Online - An error occurred while loading the page RRS feed

  • Question

  • We have previously configured a working connection from CRM 2011 to SharePoint Online.

    Today, while preparing a demo to expand it's use, we encountered an error on the Documents link in a new Opportunity.  The dialog indicating that a folder will be created in SharePoint is shown but then, instead of the SharePoint folder, the following error is displayed:

    An error occurred while loading the page. The URL may not have been mapped in the SharePoint Server. Ask your system
    administrator to check the Configure alternate access mappings settings in the SharePoint Central Administration.
    "

    As this is SharePoint Online, I don't have access to Central Administration.  In any case, the alternate access mappings don't apply as the URL used to access SharePoint Online is the same regardless of from where it is accessed.  (For example, in SharePoint OnPremise we have had URLs such as http://spserver and http://spextranet.domain.com).

    I tried resetting the Document Management Settings in CRM - the process is a) specify SharePoint Site and the entities to include b) URL is validated and option to specify Based on entity is shown c) Document Library creation status is shown.  The Creation Details panel shows Failed for all Entities - the Failure Reason is the same error message as shown above.

    I have tried deactivating and activating the List Component in SharePoint Online - to no effect.

    I have tried deleting the List Component from SharePoint Online.  Downloading the List component from Microsoft, uploading to SharePoint Online and activating - to no effect.

    I can't see anything in the Event viewer.   I think this is surprising as most application issues record something in the Event viewer - but not even the change of the Document Management server is recorded!

    I have a sneaking feeling that there is something cached or written locally or the Registry (CRM server?, client? I don't know) that is corrupted - but that is just a guess really...

    Anyone have an idea as to what is going on?

    Saturday, June 7, 2014 9:10 AM

Answers

  • They've actually just got back to me with an updated CRM list component and it's working for me now. I've made it available to download from here if you'd like to try it.


    Neil - My CRM Blog


    • Edited by Neil McD Tuesday, June 24, 2014 2:00 PM
    • Marked as answer by JohnMPSC Tuesday, June 24, 2014 3:06 PM
    Tuesday, June 24, 2014 12:55 PM

All replies

  • I've hit the same problem with two independent CRM 2011 to SharePoint Online so it is not just you, unfortunately I'm drawing a blank too at the moment.

    Will update here if I get to the bottom of it - hope you do the same - good hunting

    Monday, June 9, 2014 8:06 AM
  • Hi Darren,

    Did you get anywhere with this issue? We've got the same problem here with our CRM 2011 (on-premise) to SharePoint 2013 Online.

    Was working fine until a couple of days ago. I've tried re-uploading the list component to SP Online and it says it's activated, but the Document Management setup wizard wont complete. (The above error)

    If you can help point us in the right direction that'd be great.

    Tom

    Tuesday, June 10, 2014 3:03 PM
  • Hi Tom,

    Not yet no, I have a sinking feeling that the new CRM 2013 SP1 server side document integration for CRM online to SP online may have caused a change in how SP online works and somehow the list component is not doing its job.

    There seems to be a steady trickle of people experiencing this so may an update to the list component is required similar to when this happened http://blogs.msdn.com/b/crm/archive/2013/01/08/impact-of-dynamics-crm-december-2012-service-update-and-sharepoint-online-service-update-on-crm-sharepoint-integration.aspx

    I will definitely come back and post if I get it resolved, please do so as well if you come across a solution before I do.

    Thanks

    Darren


    Darren Bayley

    Tuesday, June 10, 2014 3:26 PM
  • Hello,

    I think I had the same issue...  I updated CRM 2013 to SP1 in a demo crm online subscription, created a new sharepoint site for use with the new sharepoint document management solution.  Doing this appears to have removed the crmlistcomponent solution from the site settings, solutions.

    I re-downloaded the related wsp from:

    http://www.microsoft.com/en-us/download/details.aspx?id=5283

    In my 2013 SharePoint site I went to top level, site settings, solutions and uploaded "crmlistcomponent.wsp" file and activated again.

    My production crm site (CRM 2013 6.0.2.51) documents are working again as expected.

    My demo/test crm (crm 2013 Spring update 2014, 6.1.0.525) appears to be working with the new sharepoint document functionality.

    The problem for me appears to have been caused by using the same sharepoint online regardless of having a unique sub site for each.

    Hopes this helps.

    Christian.

    Wednesday, June 11, 2014 5:12 AM
  • hi,

    Could you also test the following on the SharePoint Online environment. Go to your site and go to the following page *.sharepoint.com/sites/SITENAME/crmgrid/crmgridpage.aspx This is one of the pages that gets installed when activating the crmlistcomponent solution.

    I Get the following error when i go to that page:

    Web Part Error: Sandboxed code execution request failed.

    I was curious if you didn't get this error

    Tuesday, June 17, 2014 10:09 AM
  • Hi

    Yes I get the same error message when going to *.sharepoint.com/sites/SITENAME/crmgrid/crmgridpage.aspx 


    Darren Bayley

    Tuesday, June 17, 2014 10:52 AM
  • We're also seeing this on CRM 2011 and CRM 2013 on-prem/online when using SharePoint on Office 365. It started when the Spring update came out earlier this month.

    I've logged this on connect also, it may be helpful if some of you can vote it up! https://connect.microsoft.com/dynamicssuggestions/feedback/details/899919/sharepoint-online-integration-broken



    Neil - My CRM Blog



    • Edited by Neil McD Wednesday, June 18, 2014 8:53 PM
    Wednesday, June 18, 2014 8:11 PM
  • I have same problem as you guys and it really makes me worry... I tried to delete and reupload crm solution for sharepoint, but it didn't solve problem. 

    Also I tried to open /crmgrid/crmgridpage.aspx  and I have same error message. 

    Thursday, June 19, 2014 9:06 AM
  • I've logged a ticket with Office 365 support. I'd suggest doing the same if you haven't already so that they will acknowledge the issue. I'll update this thread if/when they get back to me.
    Thursday, June 19, 2014 11:37 AM
  • I've just had a screen sharing session with MS support. They've acknowledged the issue and are aiming to have a fix by the end of next week. They are not yet sure whether it will be an update to the list component which we will need to install, or a update to SharePoint which they will push out in maintenance.

    Neil - My CRM Blog

    • Proposed as answer by Petr Kaiser Friday, June 20, 2014 7:20 AM
    Thursday, June 19, 2014 12:54 PM
  • Thanks Neil, That sounds like good news.
    Thursday, June 19, 2014 5:25 PM
  • Do you have some link to Microsoft issue/bug?

    Regards

    Monday, June 23, 2014 1:35 PM
  • Hi Neil, thanks for sharing this information, i'm also looking for an official MS info on this issue and i'd be grateful if you point it out (if there is any). Any additional info would be helpful also. 

    By the way, our client is able to access folders that are created before and everything seems to be in order, the problem is when we want to create new folder for a specific entity, progress dots are spinning infinitely.
    -------------
    Vladimir Djordjevic
    -------------
    • Edited by vladimir dj Tuesday, June 24, 2014 11:13 AM
    Tuesday, June 24, 2014 11:13 AM
  • It's a support ticket within my Office 365 account, so it's not publicly accessible. You're describing the same problem I have though. I can access the old folders, but new folders get the "The URL May Not Have Been Mapped" error.

    Neil - My CRM Blog

    Tuesday, June 24, 2014 11:22 AM
  • They've actually just got back to me with an updated CRM list component and it's working for me now. I've made it available to download from here if you'd like to try it.


    Neil - My CRM Blog


    • Edited by Neil McD Tuesday, June 24, 2014 2:00 PM
    • Marked as answer by JohnMPSC Tuesday, June 24, 2014 3:06 PM
    Tuesday, June 24, 2014 12:55 PM
  • Excellent!  Thanks Neil.  That did the trick!
    Tuesday, June 24, 2014 3:06 PM
  • Neil

    Many thanks - now back up and running


    Darren Bayley

    Wednesday, June 25, 2014 7:16 AM
  • No problem. The official download is due to go up on the 30th. I recommend updating to that once available, just in case they fix anything else.

    Neil - My CRM Blog

    Wednesday, June 25, 2014 10:21 AM
  • It works with the updated component. Thanks Neil!
    Thursday, June 26, 2014 8:44 AM

  • I confirm that latest offical list component (06.00.0000.0809 (9/26/2013)) is here - http://www.microsoft.com/en-us/download/details.aspx?id=40345

    and is NOT working with SharePoint Online.

    I also do confirm that newer version from dropbox is working - https://www.dropbox.com/s/9igakdrms5a1ic3/crmlistcomponent.wsp

    I wonder, when it Microsoft update on public site its version since it passed +6 months.


    -- Hrvoje Kusulja

    Monday, June 30, 2014 11:51 AM
  • Hi Neil,

    Thanks for the advice about the new CRM List component. I've downloaded it from your drop box and it's working great now.

    Thanks again!

    Tom

    Tuesday, July 1, 2014 12:18 PM
  • The new versions are up on the below links now, so I've taken down my Dropbox file. It's a slightly different size to the version I posted, so it would be worth updating in case they fixed some other bugs.

    http://www.microsoft.com/en-us/download/details.aspx?id=5283 (CRM 2011)

    http://www.microsoft.com/en-us/download/details.aspx?id=40345 (CRM 2013)


    Neil - My CRM Blog

    • Proposed as answer by TimDemoor Wednesday, July 9, 2014 2:34 PM
    Wednesday, July 2, 2014 8:37 PM
  • I confirm that the links Neil provided in his last post fixed the problem for us. Thank you.

    Wednesday, July 9, 2014 2:37 PM