locked
CRM 4.0 E-mail Router - Incoming Status: Failure RRS feed

  • Question

  • Hi,

    I am trying to use Email Router for emailing in crm4.0 on-premise. I installed Email Router and I tried to create an Incoming Profile using Exchange Web services with windows authentication as the Authentication Type and Other Specified as the Access Credential.

    It gives the following error when I click Test access under the Tab “Users, queues and  Forward Mailboxes” in E-mail Router
    Configuration Manager.

    IncomingStatus: Failure - Client found response content type of '', but expected'text/xml'.The request failed with an empty response.

    Following are the settings which I used to create a Incoming Profile.

    Direction: incoming

    Protocol:  Exchange Web Services (I used Exchange Web Services since we don’t have POP3)

    Email Server Type: Exchange 2010

    Authentication Type: Window Authentication

    Access Credentials: Other Specified

    Pls anyone help in this. Thanks in advance.



    senthilkumar.m


    Wednesday, February 15, 2012 2:03 PM

All replies

  • This message seems indicates that the exchange web service for incoming is not responding correctly. It should return a .xml file, but not in fact.

    One way to check, open the incoming URL in IE and type in the credentials, see if you can successfully access it.

    For reference, you can refer to the official configuration documents:

    Microsoft Dynamics CRM 2011 Email Router Deployment Scenarios

    Link on TechNet: http://technet.microsoft.com/en-us/library/hh533641.aspx

    Single document CRM_2011emailrouter_scenarios.doc: http://www.microsoft.com/download/en/details.aspx?id=21445


    This posting is provided “AS IS” with no warranties, and confers no rights.Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Leola Xu Microsoft Online Community Support

    Thursday, February 16, 2012 9:18 AM
  • Another useful article for your reference:

    How to Configure Microsoft Dynamics CRM 4.0 E-mail Router (On-Premise) with Microsoft Exchange Server 2010
    http://blogs.msdn.com/b/crm/archive/2009/12/21/how-to-configure-microsoft-dynamics-crm-4-0-e-mail-router-on-premise-with-microsoft-exchange-server-2010.aspx


    This posting is provided “AS IS” with no warranties, and confers no rights.Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Leola Xu Microsoft Online Community Support

    Thursday, February 16, 2012 9:21 AM
  • I am also facing the same problem(IncomingStatus: Failure - Client found response content type of '', but expected'text/xml'.The request failed with an empty response.).

    I have used the following settings for create a Incoming Profile

    Direction: incoming

    Protocol: Exchange Web Services (I used Exchange Web Services since we don’t have POP3)

    Email Server Type: Exchange 2010

    Authentication Type: Window Authentication

    Access Credentials: Other Specified

    Please help me if you have any soltion to overcome this issue.

    Thanks in advance.

    Monday, February 27, 2012 10:47 AM