locked
Missing command bar in MSCRM 2013 online after imported solution from MSCRM 2011 RRS feed

  • Question

  • Hi all,

    I am preparing upgrading MSCRM 2013 online from MSCRM 2011 online.  I found some strange issues after I imported the solutions we are using in MSCRM 2011 platform to a new MSCRM 2013 online platform.  Anyone can give me some hits?  Any help is highly appreciated.  Thanks.

    1. Command bar missing in Forms (See two forms screen below)

    Command bar buttons are totally disappeared in all forms, for example:
    Contact Form: SAVE NEW, DEACTIVATE, CONNECT, etc
    Phonecall Form: SAVE, MARK COMPLETE, CLOSE PHONE CALL, CONVERT TO CASE, DELETE, etc

    2. Sub-Grid not working after imported MSCRM 2011 formSub-Grid always shows "No Record" in a Form, even there are associated records.

    Monday, February 10, 2014 9:41 AM

All replies

  • Hi

    Try this. Its not actually a solution to this, but could be a workaround.

    Go to cusotmize Entity --> Entity you are having issues --> Forms.

    Create a new form from your existing form. You can do that from New button or doing "SaveAs from existing form".

    Publish customizations. Go to record and select this new form and see if you see the command bar there.

    Monday, February 10, 2014 9:56 AM
  • I have a clean install of CRM 2013 and the Command Bar buttons are also missing from ALL forms and dashboards, regardless of browser. Grid links don't work either.  I've created some new users  (system admins) and they can not see the Command Bar either.

    The only exception is the very first user that was created by default (Also a sys admin). If this user browses to CRM whilst on the server it was installed on, then the Command Bar buttons appear. If they browse to CRM from another PC, the Command Bar is missing. 

    CRM was installed on Virtual Windows Server 2012 and has the Update Rollup 1 installed.

    I've installed CRM 2013 twice, once using a trial licence and once using an MSDN licence and this is happening on both installs.

    Any advice to fix this would be appreciated.

    Thanks.

    Thursday, April 3, 2014 4:23 PM
  • I just started having the same issue with the Command Line disappearing from my Opportunities Entity Form.  I do not know whey this happened - not sure what programming changed in the last four days.  When the form loads the Command Line shows, but then it disappears and the user cannot perform most necessary actions from this form.  Others online have stated this happened to them but to delete ANY text in the "ToolTipDesciptionText" - but I do not know where this problem may have originated from since I have not changed any description fields on the form.

    Any help would be appreciated as users are getting very annoyed.  In general CRM 2013 Online is causing a lot of management angst; there are some major issues (Outlook load time significantly slows with the CRM plug-in, Reports cannot be displayed in Dashboards when using IE - and when they do get displayed through iFrames they do not look good, no ability to alter Activities List of choices, the mobile MS CRM app is not working properly on most android devices out staff has, and now this).  Help...

    Wednesday, May 28, 2014 3:40 PM
  • Hi all,

    Thank you for the posts and your feedback. I am sorry to hear about your current experience in this regard.

    I can confirm that we have identified and fixed the following related design mistake:

    When using IE8 or a newer IE version in IE8 Document Mode, if you open a record (e.g. Account or Contact) which has a long name (some of the Sample data records repro this) then when the form is open the related records dropdown is missing from the top command bar next to the name, this makes it impossible to go to related records of this record. This issue was addressed with CRM 2013 UR2.

    If your are not using IE8 or a newer IE version in IE8 Document Mode and the your particular issue is not adressed woth CRM 2013 UR2, I’d recommend you to open a Support Request with CRM Technical Support at the following link - http://www.microsoft.com/en-us/dynamics/crm-customer-center/contact-technical-support.aspx and work with our team to address the issue in your particular environment.  

    @ Morley Group: I am sorry to hear about the additional issues you are experiencing. I would also suggest you to take advantage of the included into your CRM Online subscription Technical support and submit a Support Requests for the other issues as well. In addition, for the none-break fix issues, I would encourage you to send a product suggestion at https://connect.microsoft.com/ and provide insight to the Microsoft development community about a particular feature. Microsoft Connect is a platform and online solution that enables collaboration for gathering actionable feedback to improve and build the best in class products and services. 

    Please let us know if this helps.

    Thank you for using Microsoft Dynamics CRM Communities.

     

    Nina Peneva

    Support Engineer

    Microsoft Dynamics CRM

    Wednesday, June 4, 2014 7:50 AM
  • This is what I noticed.

    When I access CRM (via Firefox 31.0, IE 8.0.7601.17514) and say entered this http://servername/OrgName/Main.aspx (take note of capital M) I can recreate the scenario where the Command buttons are missing.

    However, when I access CRM simply as http://servername/OrgName/ (or even with main.aspx) then I can see all the command buttons.

    Please see and try if this will help.


    • Edited by Ian Salgado Tuesday, August 19, 2014 3:27 AM
    Tuesday, August 19, 2014 3:26 AM