locked
Home Server remote access problem i tried everthing! (verifying your web site is accessible from the internet) RRS feed

  • Question

  •  

    well where to start

     

    i recently installed Windows homeserve on one of my spare pc at home at respectable spec and using Netgear DG834GT as a modem router.

     

    i have tried enable to remote access my server when i am away from home, but it only allows to be accessed with in a local network.

     

    explain what i did after throughly reading forum here.

     

    1. opened all the ports that it requires and forwarded to my server

    2. closed firewall feature on windows on server.

    3. tried port block on 80 443, 4125 ( well after checking with port dectector both of them were blocked but ISP doesn't wanna admit it after contacting them)

    4. tried to change tcp port to 81 and ssl port to 600, at  IIS/website/default website/website identification just doesnt' work (this had to be done because my router doesn't have function of port remapping, if you know one it does please let me know)

    5. tried using port relay from tzo.com, unconfigured the domain on homeserver control, and tried number 4 above changing port to 81, 8080, 9000 none of them link to it.

    6. restarted, upgraded firmware on router

    7. DMZ setting on homeserver IP

     

    i am starting to get fed up with something that i don't even know what is causing it to fail.

     

    please help ~

     

     

    Tuesday, January 22, 2008 1:43 PM

All replies

  •  

    if the ISP Blocked all the incoming requests is that means idon't need firewall at all?
    Tuesday, January 22, 2008 1:49 PM
  • Ususally they only block a few specific ports or ports below 1024. Keep using firewall at all times when connected to the internet, even when behind NAT router

     

    1. If you have a separate DSL modem in front of your router you may also need to configure port forwarding there.

    2. If you want remote access using the high ports you may need to use http://yourserver.homeserver.com:8009/HOME or https://yourserver.homeServer.com:8010/HOME or https://yourserver.homeServer.com:8010/remote or possibly even http://IP-address: portnumber/HOME

    3. Stop and Restart IIS service after you made changes, or do IISRESET

    4. Always test acces from a remote location for which you are sure none of the required ports are blocked. Do not solely trust the checkmarks in the WHS remote access settings console

    5. Have a look at Philip Churchills blog on this subject: http://mswhs.com/2007/06/21/problems-accessing-whs-web-interface-ports-80-and-443-blocked/  (Perhaps this should be "1." on the list of things)


     

    Tuesday, January 22, 2008 3:01 PM
    Moderator
  • Sorry you are frustrated, I know how it feels!

    First off, the #1 issue with remote access failing is due to a DOUBLE NAT problem. This means that there are bacially 2 NAT routers in the "chain" of your network.  In most cases, this double NAT is caused by a Vonage or VOIP router or cable/DSL modem that has NAT enabled. 

    In most cases, these devices are in FRONT of your "normal" router.  If it's a Vonage or VOIP router, set the DMZ port on that router to point to the WAN IP of the second router.  THen DMZ the second router to the IP of the WHS box and try again.  Most cases this solves it.  If it works, then you should set the WAN IP of the second router to be static so it doesnt change, then tighten up the port forwarding int he second router - remove DMZ and forward individual ports.

    Then set the IP on the WHS box to be static so it doesnt change...this is a must if you have manually forwarded ports.

    For more detail on troubleshooting, see the remote access troubleshooting guide over at http://www.MyHomeServer.com

    Tuesday, January 22, 2008 9:26 PM