locked
CRM Router does not process old emails. RRS feed

  • Question

  • I had a number of issues with the CRM Email Router not processing any messages from the forward mailbox.
    I applied rollup 11 and some hotfixes and configured request filtering on the Exchange server to allow double escaping URL’s and that seems to have fixed my problems.
    So far the router looks like it is working fine but it does not want to process any of the older mails. Anything older than a week just gets ignored.
    I’ve tried clearing the Inbox and just adding the CRM related messages one at a time but no luck. Anything new gets picked up and processed almost immediately.

    I have a  few thousand mails and I don’t really want to resend all of it, is there a better way to fix this?

     

    Sunday, August 22, 2010 11:16 PM

Answers

All replies

  • Are the older e-mails forwarded as an attachment?  Can you check the server to see if there are event log errors.

    Regards, Donna

    Monday, August 23, 2010 1:23 PM
  • Yep, all the messages include the original mails as attachments. Since I applied the changes I dont see any errors in the event logs. It's like the router just ignores the old messages.

    Monday, August 23, 2010 9:20 PM
  • Maybe there is some sort of rule and they were flagged as failed messages or something so they are not getting processed.  What happens when you forward one back to the forwarding mailbox

    Regards, Donna

    Monday, August 23, 2010 11:07 PM
  • Hi,

    Can you try making few old emails as 'unread' and see if they are processed?

    Regards

    Zahid


    Microsoft Certified Business Management Solutions Specialist
    Tuesday, August 24, 2010 7:41 AM
  • In the Inbound Email Router Configuration settings http://msdn.microsoft.com/en-us/library/cc906238.aspx there is a MessageExpiry setting that 'Specifies the threshold time after which a message in the mailbox is considered old and will no longer be processed'.
    MSCRM Bing'd - http://bingsoft.wordpress.com
    Tuesday, August 24, 2010 11:32 AM
    Moderator
  • Thanks, that looks like what I was after.

    Do you know if there is a max value that can be set. I increased it to 2 weeks - 1209600000 milliseconds but it is still not processing the mails.

    It does not make a difference if the mail is marked as read or not. Forwarding the messages back to the forward mailbox does work but I can only do it one at a time and I have a few thousand unprocessed mails.

     

    Tuesday, August 24, 2010 10:27 PM
  • the default limit of emails to process per cycle is 1000 I think. See the MaxMessageCount setting in the Common Provider Config settings http://msdn.microsoft.com/en-us/library/cc906236.aspx.

    So if you have more then 1000 emails in your inbox then only 1000 will be processed and the rest left out of the cycle.


    MSCRM Bing'd - http://bingsoft.wordpress.com
    Wednesday, August 25, 2010 11:42 AM
    Moderator