locked
WHS On Multiple SUBNETS with static routes RRS feed

  • Question

  • My network Using a computer running M0N0Wall with 3 nic cards WAN LAN OPT1 Lan 192.168.0.0/24

    OPT1 192.168.15.0/24 interface connects to another network through a wireless bridge and the OPT1 (3rd nic in a twin  Computer running M0n0Wall.

    This monowall box is LAN 192.158.25.0/24 and opt one on .15.0/24
    Both routers have a static route on the opt1 interface to the lan interface of the other box and As far as I know the firewall is open through this static route.
    I can access any server on to or from either network.  Network shares of coarse don't work. Ping any computer as well.

    I want to let users on the .25.0/24 network access and back up to my WHS box on the .0.0/24 network.
    The fire wall on the WHS is at the moment OFF and I have set this up to any computer http://social.microsoft.com/forums/en-US/whsfaq/thread/295498e9-de53-46c8-9d38-7f110bdb2aeb/  Except the remote desktop.

    Tried to set up the connector today on the other network and it failed . If I opened a browser to the IP of my WHS :55000 it opened the main page. and let me down load the setup file. but would not find the server during setup.

    Thanks for any advanced networking help. I'm not a pro by any means ,,,learning as I go.
    Allan
    Monday, November 23, 2009 8:23 PM

Answers

  • After some searching I learned that editing the LMHOSTS file on the client PC can make a huge difference in name resolution.

    For any one reading this post I'll give as much of a layman's how too as possible . This might even help on a 1 subnet network.

    First off on the client machine navigate too  Windows folder in C or Maine drive letter. Then   \system32\drivers\etc  .

    At the top of your window click tools then folder options then the View tab look for Hidden files and folders , set it to show just in case, then look for  Hide extensions for known file types and take the check out of the box. Close the window.
    Now in the etc folder if it has not been modified the LMHOSTS file will be labled LMHOSTS.SAM . Right click on this file and choose rename , wipe out the SAM and the dot / period   leaving only LMHOSTS as the file name. ( This makes the file active)
    Now Last step Open the file It will ask for a program to do this Choose Notepad.

     Scroll to the bottom of the file Read it all if you wish .
    On the first empty line type the IP address of your WHS server in my case it's (192.168.0.30 )  Leave 1 or 2 spaces and type the name of your WHS server the same as you filled it out during setup or if you left the default name it's SERVER then a couple more spaces and  type this #PRE this makes windows load the name at startup.

    So the bottom of the file should look like this with your own IP and name

    # Therefore it is not advisable to simply add lmhosts file entries onto the
    # end of this file.
    192.168.0.30  SERVER  #PRE

    Worked for me !!!
    Allan

    • Marked as answer by Alan87i Wednesday, November 25, 2009 1:09 AM
    Wednesday, November 25, 2009 12:45 AM

All replies

  • You could start by following all the directions in that FAQ you linked, rather than intentionally skipping some steps. I don't know that it will help (I don't have a multi-segmented network) but it won't hurt.

    The other main option, considering you admit you don't have a lot of networking expertise, is to abandon the idea of a complex network. One router, at the point of entry for your internet connection, with switches/wireless access points is much easier to figure out and especially to maintain.
    I'm not on the WHS team, I just post a lot. :)
    Monday, November 23, 2009 9:11 PM
    Moderator
  • Hello Ken
    I only skipped the remote desktop scope settings.
    The network is setup this way because each lan has it's own wan connection and address.
    Basically The two routers with the bridge link between them was setup for file sharing with another server / security video surveillance with several computers using Ubuntu and Zoneminder. All these services and a few more currently running have never needed more than the IP of the box hosting them.
    WHS on the other hand is a new experience for me and does not work through this static route.

    Thanks Allan
    Monday, November 23, 2009 11:49 PM
  • After some searching I learned that editing the LMHOSTS file on the client PC can make a huge difference in name resolution.

    For any one reading this post I'll give as much of a layman's how too as possible . This might even help on a 1 subnet network.

    First off on the client machine navigate too  Windows folder in C or Maine drive letter. Then   \system32\drivers\etc  .

    At the top of your window click tools then folder options then the View tab look for Hidden files and folders , set it to show just in case, then look for  Hide extensions for known file types and take the check out of the box. Close the window.
    Now in the etc folder if it has not been modified the LMHOSTS file will be labled LMHOSTS.SAM . Right click on this file and choose rename , wipe out the SAM and the dot / period   leaving only LMHOSTS as the file name. ( This makes the file active)
    Now Last step Open the file It will ask for a program to do this Choose Notepad.

     Scroll to the bottom of the file Read it all if you wish .
    On the first empty line type the IP address of your WHS server in my case it's (192.168.0.30 )  Leave 1 or 2 spaces and type the name of your WHS server the same as you filled it out during setup or if you left the default name it's SERVER then a couple more spaces and  type this #PRE this makes windows load the name at startup.

    So the bottom of the file should look like this with your own IP and name

    # Therefore it is not advisable to simply add lmhosts file entries onto the
    # end of this file.
    192.168.0.30  SERVER  #PRE

    Worked for me !!!
    Allan

    • Marked as answer by Alan87i Wednesday, November 25, 2009 1:09 AM
    Wednesday, November 25, 2009 12:45 AM